cancel
Showing results for 
Search instead for 
Did you mean: 

Spurious graphic seen at bottom of forum pages

Superuser
Superuser
Posts: 9,988
Thanks: 1,532
Fixes: 19
Registered: 22-08-2007

Spurious graphic seen at bottom of forum pages

Has anyone else seen this...
Was in the forums this afternoon on my iPhone 4 and noticed a picture of "Jaggers" at the bottom of the page... asked OldJim if he knew what's going on, who replied in the vain that I might have lost the plot!
Well something some where has lost the plot!
Photo 3 is Safari on iPad
Photo 4 is Safari on iPhone 4 Version 5.1.1 - note "Jaggers'" photo bottom centre
21 REPLIES
Community Gaffer
Community Gaffer
Posts: 4,906
Thanks: 179
Fixes: 4
Registered: 04-04-2007

Re: Spurious graphic seen at bottom of forum pages

That appears to be in place of http://community.plus.net/wp-content/themes/plusn-optimized/images/technoratiLogo.gif
If you see his smiling face again, can you tell us what the url of the image is?
Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: Spurious graphic seen at bottom of forum pages

Now you come to mention it, I've had spurious images of Jaggies flash up on a few occasions. I don't recall the image staying there or where exactly it appeared, but if it's at the bottom of the screen, I may not have noticed as I rarely scroll that far down.
But can you see what it's replacing, that link is a 404 anyway  Shocked
Ah, I see Kelly beat me to posting about that.
Community Gaffer
Community Gaffer
Posts: 4,906
Thanks: 179
Fixes: 4
Registered: 04-04-2007

Re: Spurious graphic seen at bottom of forum pages

I want to know the image url, not the url it's linking to.
Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: Spurious graphic seen at bottom of forum pages

I meant the Technorati link is a 404 not Jaggies image.
Superuser
Superuser
Posts: 9,988
Thanks: 1,532
Fixes: 19
Registered: 22-08-2007

Re: Spurious graphic seen at bottom of forum pages

Hi Kelly,
If I click the picture, this is what I get - http://technorati.com/faves?sub=addfavbtn&add=http://community.plus.net
But I guess that is not what you want - you want the image URL in the HTML page.  I cannot work out a way of getting that out of Safari.  Note if I run Safari in debug mode, I get 4 JavaScript errors - 3x security policy violations and that something is undefined.
If anyone can suggest how I can get hold of the html from Safari I'll have another go.
Kevin
Moderator
Moderator
Posts: 17,249
Thanks: 904
Fixes: 104
Registered: 11-01-2008

Re: Spurious graphic seen at bottom of forum pages

Safari menu > Preferences > Advanced.

Check "Show Develop menu in menu bar". Close Safari's preferences.

Develop menu > Show Page Source
Will Moderate For Thanks
Community Gaffer
Community Gaffer
Posts: 4,906
Thanks: 179
Fixes: 4
Registered: 04-04-2007

Re: Spurious graphic seen at bottom of forum pages

with FF you can just right click and select view image....  can you not do something similar with Safari?
Superuser
Superuser
Posts: 9,988
Thanks: 1,532
Fixes: 19
Registered: 22-08-2007

Re: Spurious graphic seen at bottom of forum pages

Hi Kelly,
I really do not mean to take the mick here, but this is the best laugh I've had in days... do you meant click my touch sensitive screen with the right hand instead of the left hand...  Cheesy Grin Shocked Roll eyes
Note I'm seeing this on my iPhone but not iPad - both using Safari.
Context click menus (right click) are a real design issue / no-no for touch sensitive UIs.  So much of what we have come to accept as "normal functionality" will in coming years need to be traded out for the benefit of touch sensitive UIs.
I know of no way of "right clicking" on a touch only UI.
Crazy
Kevin
Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: Spurious graphic seen at bottom of forum pages

Quote from: Kelly
with FF you can just right click and select view image....  can you not do something similar with Safari?

Or even "Copy Image Location" - atm he's in hiding  Cheesy
I forgot to say in my earlier post(s) that I'm using FF.
Community Gaffer
Community Gaffer
Posts: 4,906
Thanks: 179
Fixes: 4
Registered: 04-04-2007

Re: Spurious graphic seen at bottom of forum pages

I was subtly taking the mickey out of Apple Smiley
Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: Spurious graphic seen at bottom of forum pages

Careful, you'll have PlusComUK posting here  Grin
Superuser
Superuser
Posts: 9,988
Thanks: 1,532
Fixes: 19
Registered: 22-08-2007

Re: Spurious graphic seen at bottom of forum pages

Kelly,
Well, be careful!!
By the power of the internet I've now managed to display the HTML of a web page on Safari / iPhone 4 (IOS 5.1.1)
The HTML for the graphic is correct

<img src="/wp-content/themes/plusn-optimized/images/technoratiLogo.gif" alt="Add to Technorati Favourites" border="0" />

I'm concluding that something is screwed on the iPhone's image cache - going to do some more testing.

If anyone is interested in how I did this see here - http://banagale.com/view-source-from-safari-on-ipad.htm - note the difficult bit was recognising that there were some line feeds in the code which meant it did not work first time.  Some I saw before I started, one I did not.  This worked fine after the second edit.
Kevin
Superuser
Superuser
Posts: 9,988
Thanks: 1,532
Fixes: 19
Registered: 22-08-2007

Re: Spurious graphic seen at bottom of forum pages

Well I nearly don't believe it!  Looks like my image cache on the iPhone is screwed.  I constructed a very simple web page (locally) pointing to said PN graphic... (note the URL reference to the graphic has been made absolute - thought this might have fouled up the test, but apparently not)

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<title>Untitled</title>
</head>
<body>
<p class="TechnoratiFooter">
  <a href="http://technorati.com/faves?sub=addfavbtn&amp;add=http://community.plus.net">
    <img src="http://community.plus.net/wp-content/themes/plusn-optimized/images/technoratiLogo.gif"
              alt="Add to Technorati Favourites"
              border="0" />
  </a>
</p>
</body>
</html>

When run on the laptop, I got the expected green graphic, when run on my iPhone, I got "Jagger's" beaming face.
I've seen everything now!  I'll now have to work out how to fix this... !
Cheers to everyone for their input.
Kevin
RPMozley
Aspiring Pro
Posts: 1,066
Thanks: 21
Fixes: 3
Registered: 04-11-2011

Re: Spurious graphic seen at bottom of forum pages

I've seen similar icons being mixed up, also on iOS 5 (iPod touch). The cache data gets mixed up somehow. Clearing the cache and reloading the forums will get it back to 'normal'.  Wink