cancel
Showing results for 
Search instead for 
Did you mean: 

Painful browsing the forum, like wading through treacle

Superuser
Superuser
Posts: 3,581
Thanks: 2,021
Fixes: 12
Registered: ‎10-04-2007

Re: Painful browsing the forum, like wading through treacle


@Townman wrote:
Looking at the page load tracing, there are resources being loaded from the *.plus.net space which could benefit from some optimisation.

Between 8% and 10% on both Domain calls and data content according to the Pingdom links I've looked at for various pages on Community?

jab1
Aspiring Hero
Posts: 2,430
Thanks: 675
Fixes: 12
Registered: ‎24-02-2012

Re: Painful browsing the forum, like wading through treacle

@JonoH Any more from Lithium, please? The past couple of days, 'waiting for community.plus.net' has been lasting for up to 35 seconds before the page loads - andthis has been on three devices at four locations/providers.

John
Highlighted
smiffy1
Grafter
Posts: 49
Thanks: 14
Registered: ‎23-09-2018

Re: Painful browsing the forum, like wading through treacle

Its absolutely dire at the moment Sad11/02/19,, 18.21

Community Gaffer
Community Gaffer
Posts: 2,555
Thanks: 4,335
Fixes: 84
Registered: ‎29-09-2011

Re: Painful browsing the forum, like wading through treacle


@jab1 wrote:

@JonoH Any more from Lithium, please?

There may well be but I'm out of the office until the end of the week, just checking in in case anything is urgent and to see how it performs from my home PC (Flawless so far) 

 Jono H
 Plusnet Community Manager
Superuser
Superuser
Posts: 13,303
Thanks: 4,663
Fixes: 27
Registered: ‎22-08-2007

Re: Painful browsing the forum, like wading through treacle

Superuser
Superuser
Posts: 3,581
Thanks: 2,021
Fixes: 12
Registered: ‎10-04-2007

Re: Painful browsing the forum, like wading through treacle


@JonoH wrote:

.................... and to see how it performs from my home PC (Flawless so far) 


It is highly poradic @JonoH.  Today is OK, but yesterday mid afternoon it was taking up to 25 secs to read a new post!  Mostly "waiting for community.plus.net"

Community Gaffer
Community Gaffer
Posts: 2,555
Thanks: 4,335
Fixes: 84
Registered: ‎29-09-2011

Re: Painful browsing the forum, like wading through treacle


@Townman wrote:

Which browser are you using @JonoH?

Chrome. I use it in the office as well.

Half term hols?


I wish Smiley 

 Jono H
 Plusnet Community Manager
idonno
Aspiring Pro
Posts: 246
Thanks: 40
Fixes: 1
Registered: ‎22-10-2015

Re: Painful browsing the forum, like wading through treacle

It can be painful using Firefox (my default browser), don't ask me why. It just is. Pages take an age to load. Tap, tap, tap.....

 

And yet using Opera, pages load very fast. Don't use Chrome can can't tell you how long that takes. IE seems to load pages quite fast too.

 

Edit 1: uploading this took about 10 seconds with Firefox

Edit 2. uploading this took about 3 seconds with Opera.

Community Veteran
Posts: 5,866
Thanks: 1,697
Fixes: 38
Registered: ‎16-10-2014

Re: Painful browsing the forum, like wading through treacle

I am not really convinced by the Browser X is faster than Browser Y argument; if anything I suspect it’s all down to timing. To get a better view of this it would make sense to use Browser X for an entire day or even a few days, then do the same with Browser Y to see how this effects the overall performance / user experience.

I am aware that some Browsers have 'better' performance than others, so if Browser X is ‘better’ than Browser Y then this performance, both the good from X and the bad from Y should be consistent across all web sites visited and I don't think this is the case. Unless someone has evidence to the contrary?

 

JayG
Pro
Posts: 1,068
Thanks: 118
Fixes: 3
Registered: ‎30-10-2011

Re: Painful browsing the forum, like wading through treacle

I switched to Chrome because IE11 seemed to be increasingly showing its age so rarely gets brought out of the garage and cranked over.

So, using Chrome, this site sometimes performs 'OK' (like today), and sometimes it lags badly - other regularly visited sites perform pretty consistently at all times.

So yes, something to do with timing, but exactly what is happening behind the scenes at these different times is of course the $64,000 question!

Community Veteran
Posts: 5,866
Thanks: 1,697
Fixes: 38
Registered: ‎16-10-2014

Re: Painful browsing the forum, like wading through treacle

To elaborate on my reference to timing, I mean when a user hits the site and what the server(s) are doing in the background at the time the user makes their request.

If I knew the answer to that @JayG, I'd be 64K richer! All I can do for now is make assumptions.

Superuser
Superuser
Posts: 13,303
Thanks: 4,663
Fixes: 27
Registered: ‎22-08-2007

Re: Painful browsing the forum, like wading through treacle

@Mook,

At the same time I’ve seen different browsers render differently both in appearance and speed concurrently.

Edge is particularly bad.
Community Veteran
Posts: 5,866
Thanks: 1,697
Fixes: 38
Registered: ‎16-10-2014

Re: Painful browsing the forum, like wading through treacle

That’s fair enough @Townman, but can you replicate this behaviour consistently to a point that it is proof positive?

Above, @MauriceC says that he frequently sees “waiting for community.plus.net” and I too have witnessed this on many an occasion, but while a browser is waiting for content it doesn’t matter how fast it can render it if there’s nothing to render.

mac51
Dabbler
Posts: 17
Thanks: 10
Registered: ‎09-11-2017

Re: Painful browsing the forum, like wading through treacle

I agree completely with @Mook

Every page change is delayed while the browser displays “waiting for community.plus.net” which suggests it is not an issue of browser rendition speed. But it is not getting better and I am wondering if any changes have been made to try to improve things.

The pattern is still that most of the time it takes 6 to 15 (estimated, not timed) seconds for a page to appear with occasional short periods of roughly "normal" browsing experience. The bottom line is it's not getting better.

Superuser
Superuser
Posts: 3,581
Thanks: 2,021
Fixes: 12
Registered: ‎10-04-2007

Re: Painful browsing the forum, like wading through treacle

Bad again around 09:30 so I took another pingdom trace of access to this topic on Community.

Some interesting data:

  • 78 requests across >6 domains to render the page?
  • Looking at the File requests section you can view the results by various criteria.  Selecting 'Wait time' is particularly revealing and clearly shows the wait is at the server end and should not be browser dependent?

Where are community.plus.net and www.plus.net hosted?