cancel
Showing results for 
Search instead for 
Did you mean: 

Lithium smtp problems, emails from forum not been delivered

Community Veteran
Posts: 1,990
Thanks: 5
Registered: 11-12-2013

Lithium smtp problems, emails from forum not been delivered

I am personally not been affected by this but am posting on behalf of others who because of this problem cannot login to the plusnet forum.

 

To some providers Lithium smtp server's emails will not get delivered so things like password reset emails cannot be received by the recipients.

 

I did some checks using my own mail logs and the only 2 issues I found were.

 

1 - No DKIM signatures

2 - Email sent over plain unencrypted smtp protocol.

 

#2 could be the cause as some providers may be enforcing smtps encrypted traffic, and this is very lax security protocol on Lithium's part to not encrypt email's.  Ironic given their policy on terminating session's only but send authentication email's in plain text.

19 REPLIES
Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: Lithium smtp problems, emails from forum not been delivered

Plusnet are aware of the problems some are having and I've seen members of the Help Team trying to resolve them as quickly as possible when people manage to get on here. Quite a few of the problems have been related to people not having updated their email addresses as mentioned here. Plusnet were also made aware some time ago about the security aspects of the emails, it appears nothing has been done.
There have also been some delays in the delivery of email reported by some, but most of mine seem to have been arriving pretty promptly. I've read reports elsewhere a while back about other Lithium forum's emails having delays.

Community Gaffer
Community Gaffer
Posts: 12,861
Thanks: 677
Fixes: 64
Registered: 04-04-2007

Re: Lithium smtp problems, emails from forum not been delivered

Lack of TLS transport is an acknowledged 'problem'. If anyone is experiencing email delays first hand then I'd appreciate them private messaging me with the headers of any delayed messages they've received.

Bob Pullen
Plusnet Products Team
If I've been helpful then please give thanks ⤵

kitz2
Hooked
Posts: 6
Thanks: 5
Registered: 09-04-2016

Re: Lithium smtp problems, emails from forum not been delivered

Hi

I'm one of those that couldn't access the forums - Nothing seemed to work for me.

I am 100% certain of which email address should be used as it was the first thing I checked -  I just dont seem to get any mail notifications at all.

I also tried creating a dummy account with a different email address, but that didn't work either because I never got mail to confirm the new account and therefore I wasn't allowed to make any posts that way.

Ive spent quite a while this evening trying to look into what could have gone wrong - Chrys has also been trying to figure out what could be happening hence why he made this topic.

 

Ok so Im in now - what is different this time is that I used a plusnet email address and not one that goes through my server.   Now that I am in, I can confirm that I have attempted to send my usual account several PMs - none of these notifications worked.

 

One of the things I noticed is that some of the other people experiencing difficulties do so when using their own domains via hosting companies.  For example theres 2 that use TSO, I use Vidahost and theres another member on my forum who uses a totally different webhost. 

 

Ive tried changing settings on my server.  Ive tried disabling DKIM for incoming mail.  Ive even turned Spam Assassin totally off.    Ive tried viewing the mail logs and although I can see when my server rejects certain mail..  despite looking through I cannot find anything to say that mail from Lithium has been anywhere near my server, nvm rejected.

 

Everything I've tried is detailed in full in this thread here.

 

Finally I tested using the BT forums and I'm seeing the same problem there - not getting any mail notifications from there either, so it seems specific to Lithium.  

 

 

Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: Lithium smtp problems, emails from forum not been delivered

@kitz2

Hi kitz, I take it you've read this lot

me2
Newbie
Posts: 1
Registered: 09-04-2016

Re: Lithium smtp problems, emails from forum not been delivered

.

Community Veteran
Posts: 1,990
Thanks: 5
Registered: 11-12-2013

Re: Lithium smtp problems, emails from forum not been delivered


bobpullen wrote:

Lack of TLS transport is an acknowledged 'problem'. If anyone is experiencing email delays first hand then I'd appreciate them private messaging me with the headers of any delayed messages they've received.


yeah Bob but this is specific to Lithium smtp servers, not the existing issue reported on plusnet smtp servers.

 

kitz has now verified that with her testing the BT forums.

kitz2
Hooked
Posts: 6
Thanks: 5
Registered: 09-04-2016

Re: Lithium smtp problems, emails from forum not been delivered

Gawd..  Its taken me days to actually get in with a temporary name, so I haven't had the joys yet of experiencing all the bugs too.  Cheesy 
 
TBH the forums make my eyes hurt with the animated gifs and what was the old Brightspark animation.    I understand it may look ok on  mobile, but on desktop its horrible....  but that's not really for this thread and I'll save it for another day. :/
The problem is that many emails just are not being received for some reason.   I have also raised a ticket with my hosts to see if they have any suggestions or ideas what could be going wrong.

I'm not alone in this, there are others elsewhere who also cannot get into these forums and its nothing to do with using wrong email address or checking spam folder Sad

kitz2
Hooked
Posts: 6
Thanks: 5
Registered: 09-04-2016

Re: Lithium smtp problems, emails from forum not been delivered

btw... I just found a way to get around not getting email confirmation for the dummy account I set up last night, not sure how much of a security issue this could be so I will report it to someone like bob via PM.  

It doesn't seem to affect my old account, just the dummy recently created. As proof of concept Ive just tried it again with another test account.  

kitz2
Hooked
Posts: 6
Thanks: 5
Registered: 09-04-2016

Re: Lithium smtp problems, emails from forum not been delivered

If anyone is experiencing email delays first hand then I'd appreciate them private messaging me with the headers of any delayed messages they've received

I've just got a PM notification which has an 8 hour delay, so I will PM it to you.   

I'd sent myself 3 or 4 test PMs but this is the only notification that has arrived.   

None of the dozen or so password resets Ive requested over the past few days have arrived yet.

 

Co-incidentally about 1/2hr ago I received a notification from BT forums which had a 4 hour delay.

Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: Lithium smtp problems, emails from forum not been delivered

Are you sure that's not a time zone thing? One which arrived promptly of mine had an 8 hour shift in one line, that's what I think it might be. Sorry, several lines and yes it's PDT in mine Wink

kitz2
Hooked
Posts: 6
Thanks: 5
Registered: 09-04-2016

Re: Lithium smtp problems, emails from forum not been delivered

Yep Im positive - it only just arrived about half an hour ago.   The PM was sent at 17:23 

 

Delivery-date: Sun, 10 Apr 2016 00:50:06 +0100
Received: from smtp2.Lithium.com ([46.19.168.11]:49303)
        by myserver.servers.eqx.misp.co.uk with esmtp (Exim 4.86_1)
        (envelope-from <community@plus.net>)
        id 1ap2df-00044o-Ib
        for me@mydomain.co.uk; Sun, 10 Apr 2016 00:50:05 +0100
Received: from ams1papp30.am.Lithium.com (am-lb-VIP-VLAN90.am.Lithium.com [10.50.90.6])
        by smtp2.Lithium.com (Postfix) with ESMTP id 2086B3B0576
        for <me@mydomain.co.uk>; Sat,  9 Apr 2016 18:23:56 +0200 (CEST)

 

 

Community Veteran
Posts: 19,099
Thanks: 434
Fixes: 21
Registered: 31-08-2007

Re: Lithium smtp problems, emails from forum not been delivered

Ah, of course, I'll wake up in a moment, mine are gmail, that's the reason Embarrassed Time for a dose of caffeine, where's that coffe mug smiley Thumbs Up

kitz2
Hooked
Posts: 6
Thanks: 5
Registered: 09-04-2016

Re: Lithium smtp problems, emails from forum not been delivered

btw, just for comparison, this is the BT notification which had a 4 5 hour delay

Notification was sent at 19:23 BST  Received at 00:20 BST

 

Return-path: <forum.moderation.team@community.bt.com>
Envelope-to: me@mydomain.co.uk
Delivery-date: Sun, 10 Apr 2016 00:20:06 +0100
Received: from smtp2.Lithium.com ([46.19.168.11]:52289)
        by myserver.servers.eqx.misp.co.uk with esmtp (Exim 4.86_1)
        (envelope-from <forum.moderation.team@community.bt.com>)
        id 1ap2Ad-00030X-Nn
        for me@mydomain.co.uk; Sun, 10 Apr 2016 00:20:06 +0100
Received: from ams1papp20.am.Lithium.com (am-lb-VIP-VLAN90.am.Lithium.com [10.50.90.6])
        by smtp2.Lithium.com (Postfix) with ESMTP id 7C6E13B0530
        for <me@mydomain>; Sat,  9 Apr 2016 20:23:03 +0200 (CEST)
Community Veteran
Posts: 1,990
Thanks: 5
Registered: 11-12-2013

Re: Lithium smtp problems, emails from forum not been delivered

As a side note I am about to turn off email notifications, as this Lithium forum very annoyingly sends an email for each reply instead of just for first new reply.

The latest theory regarding all these delayed emails is I think it is caused by greylisting, the reasons still unknown for the greylist (possibly failed callback) and to compound the problem Lithium smtp servers are taking an age to retry the send.