cancel
Showing results for 
Search instead for 
Did you mean: 

using companyname rather than username.force9 for cgi space

N/A

using companyname rather than username.force9 for cgi space

Hi,
I want to use my companyname rather than my username.force9 for my cgi space, i.e.

http://cgi.companyname.com/cgi-bin/

rather than

http://cgi.username.force9.co.uk/cgi-bin

I understand that to do this, I need to make a DNS entry under my company's domain. I've tried a couple of attempts but they have not succeeded.

Please could someone give me the precise format that I should use.

And...if I make an entry for the cgi space in the DNS settings, does that mean that I need another for the www space or will that remain pointed at my htdocs folder - as it would by default?

Many thanks,
-Paul
8 REPLIES
Marteknet
Grafter
Posts: 577
Registered: 13-10-2007

ok here goes

go to the f9 portal
login
in the menu select My account Domain names
click configure on the domain your wish to change
at the Additional DNS records (Advanced) enter cgi under left field, cname under type and cgi.username.force9.co.uk. under right field. (make sure you it ends with a fullstop.
submit the changes.
lastly open a ticket to support and ask them to Change the CGI service to basic.
a few hours later you will find it works just fine.
I have several cgi.domains running on crofters. there is no way to set up a subdomain but that's not a problem.

In answer to your last question your www.domainname will continue to point to your current webspace till you change it. you will see a entry in the configure domains if you want to do that.

I have three domains and have set up a directory in homepages htdocs for each one. I do the same on crofters. I find it helps to keep filesets for each domain in their own directory, making changes to files easier in the future.

take a look at www.petsallsorts.co.uk to see one domain in action.

html stuff is on homepages.
cgi stuff is on crofters.
but the domain in the URL allways says petsallsorts.

hope this helps.

regards Peter.
N/A

using companyname rather than username.force9 for cgi space

Thanks Peter,
I think you made a typo - don't you mean cgi.username.force9.co.uk in the right field?
Then it works exactly as you say.

Thanks for taking time out to answer.
Much appreciated,
-Paul
Marteknet
Grafter
Posts: 577
Registered: 13-10-2007

well spotted

yes you are right it's the username in the rigth field. sorry about that.

I have corrected the typo.

did you manage to get it all working.
N/A

using companyname rather than username.force9 for cgi space

Yes, thanks - it works fine.

I think my confusion arose because I also have a .com address and the Force9 support people had to configure that a different way.

Once again, thank you for your help.
Best wishes,
-Paul
N/A

using companyname rather than username.force9 for cgi space

Hi, [was previously known as eaglecentre, but have left home, and got 2Megabit broadband... schweeet]

Quote

lastly open a ticket to support and ask them to Change the CGI service to basic.
a few hours later you will find it works just fine.

What's the difference between CGI service being advanced and basicHuh

Cheers
Marteknet
Grafter
Posts: 577
Registered: 13-10-2007

using companyname rather than username.force9 for cgi space

Quote
What's the difference between CGI service being advanced and basicHuh


Sorry I've no idea between advanced and basic, I read the tutorials and they said that after changes are made to cgi domain settings to open a new ticket to support to change the cgi service to basic. I would guess it indicates to them to use the new updated setting. if anyone knows more on this please enlighten us.
N/A

using companyname rather than username.force9 for cgi space

I thik my space was incorrectly set to 'semi-auto' the first time we asked... it didnt work.

Jarv
N/A

using companyname rather than username.force9 for cgi space

Someone did explain somewhere what the difference was (I think it was in Customer Feedback here...) I'll try and find the post later on.