cancel
Showing results for 
Search instead for 
Did you mean: 

session_start() permission denied!

N/A

session_start() permission denied!

This afternoon my nice shiny new PHP pages which had been working fine suddenly game me these error messages:

Warning: session_start(): open(/tmp/sess_9a8cd1ee7fe1edabbd104a883753d11d, O_RDWR) failed: Permission denied (13) in /files/home/warner/index.php on line 21

Warning: session_start(): Cannot send session cookie - headers already sent by (output started at /files/home/warner/index.php:21) in /files/home/warner/index.php on line 21

Warning: session_start(): Cannot send session cache limiter - headers already sent (output started at /files/home/warner/index.php:21) in /files/home/warner/index.php on line 21

Warning: Unknown(): open(/tmp/sess_9a8cd1ee7fe1edabbd104a883753d11d, O_RDWR) failed: Permission denied (13) in Unknown on line 0

Warning: Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/tmp) in Unknown on line 0

Presumably, the subsequent warnings are all caused by the initial one. I am assuming that these messages must have something to do with the CGI upgrade since I've changed nothing in my scripts.... it looks to me like i can't write to the /tmp/ directory or something... Anyways is this likely a temporary problem or will I need to change anything in my scripts to get the session handling to work again with the new platform?
13 REPLIES
N/A

session_start() permission denied!

I would imagine it would be temporary, but I recommend raising a link:Contact Us ticket about it as the CGI Forum is not really monitored by the staff quite so much.
N/A

session_start() permission denied!

Okay, thanks for the reply; I will do that if the problem persists...

Love the Tux mascot by the way; always nice to see him around!
N/A

session_start() permission denied!

I'm having the same problem with my page!

Let me know if you figure out a workaround!

Steve
Plusnet Staff
Plusnet Staff
Posts: 12,169
Thanks: 18
Fixes: 1
Registered: 04-04-2007

session_start() permission denied!

Hi Steve,

I've added your details on to internal problem 17273 , our network team are looking into this issue.
re-create-it
Grafter
Posts: 55
Registered: 13-08-2007

session_start() permission denied!

Has there been an upgrade?
I am having problems with an osCommerce install (previously fine) that no longer works that I installed for another f9 customer.

Simply get
Quote
FATAL ERROR: register_globals is disabled in php.ini, please enable it!

where the site was working yesterday.

http://cgi.five-forty.co.uk/shop/

HELP!
N/A

session_start() permission denied!

I'm not seeing any errrors ATM on that site... can you give a specifc URL where the error shows?

Register_Globals seems to be on, BTW... so someone either saw your message and enabled it or something else was up Smiley
re-create-it
Grafter
Posts: 55
Registered: 13-08-2007

session_start() permission denied!

The link affected to the site is above word HELP!

Here it is again:
http://cgi.five-forty.co.uk/shop/

10am Saturday morning and I am still getting the error about register_globals.

A mirror of the site is running on my home server
http://server.re-create-it.co.uk/dev/fiveforty/
and works 'perfectly' (for a site under development!)

Here's hoping it is an easy fix as we are planning to go live any day now...
N/A

session_start() permission denied!

I know that - I was asking for a specific page that had the errror as there are no warnings about register_globals on that link when I visit it just now... and there was none last night either.
N/A

session_start() permission denied!

Right, I may have tracked the issue down, over on the PlusNet forums.

Assuming the server setup is the same (my cgi account on Force9 isn't setup yet (for a different account)) and has the same config then:

Quote
support@cgi02 support $ php -i | grep register_g
register_globals => Off => Off

[csogilvie@cgi03 csogilvie]$ php -i | grep register_g
register_globals => On => On

[csogilvie@cgi04 csogilvie]$ php -i | grep register_g
register_globals => On => On

support@cgi05 support $ php -i | grep register_g
register_globals => Off => Off


which means that the server config is out of synch, I'm hitting one with it on and you're hitting one with it off.

I'm hoping it will be picked up by the comms team and raised as a problem so that the NEtworking guys can fix it.

If they fix it so that it is off on all the servers, there is some code in http://cgi.support.plus.com/var.php?sud=false&page=gt which could be added to your script to make it compatible Smiley
N/A

session_start() permission denied!

Ben has now set it to On on all machines, so it should work now Smiley
re-create-it
Grafter
Posts: 55
Registered: 13-08-2007

session_start() permission denied!

Colin,

Thanks for the reply. The link I gave is the homepage of the shop and the error reported was on that page - no file, sub directory or script below that could be accessed either.

After the first reply requesting a specific link, I checked the link given and the same error remained - a blank white page and the regiuster_gloabals warning. Strange, as phpinfo showed that they were on!

However, when I checked the site again just now the error seems to have vanished and all is working at my end (and the clients) for the first time since I reported the error.

No work has been done on the scripts from this end so I guess it was something server side that has sorted itself out now. I am checking now to make sure that it is not random or browser related....

As long as it stays sorted, we are cool!
N/A

session_start() permission denied!

It was server related - as I said, half the servers had register_globals on and half had them off - they are now all on. Thats why I wasn't seeing the error, I was hitting one with it off... it should all be sorted now though Cheesy
re-create-it
Grafter
Posts: 55
Registered: 13-08-2007

session_start() permission denied!

Cheers - it's all good now Tongue

Phil