cancel
Showing results for 
Search instead for 
Did you mean: 

pictures not showing after uploading

N/A

pictures not showing after uploading

Hello, I am Angela Halliday.
After creating a site in WebPlus8 (Serif) I uploaded to ftp://ftp.force9.net but found many of the images were not showing. All upper case letters were removed and the upload tried again and again, but with the same result.
Considering I have had a previous web site up for about 10 years, I am very surprised that I am getting these problems.
Can anybody give me any solutions? Sad
7 REPLIES
N/A

pictures not showing after uploading

Hello angelah,

I have written numerous websites over the years but (I wouldnt describe myself as an expert) from what you have described & IMO from the symptoms your problem lies in the way you have created (made) your web page. When you display an image on a website or webpage you must link the image and page, this is done by specifying the image's exact location. So the problem is a basic PATH problem (it sounds like the images dont show becuase the location/s cannot be found).

1) you need to create a folder called "images" on your website. On your webspace using the FTP program to do this i.e. create new folder etc.
2) place all your image files in this folder. (upload all images into the new folder)
3) in your web page make the path show the images by refering to this image folder, for example http://www.mysite/images/example.jpg (this path satement has to be precise and exact (i.e. the correct syntax) before the images will display correctly.

**The problem doesnt sound like it has anything to do with FTP'ing the files.

**What web page program are you using to make your site?

Ivan
N/A

missing images

Dear Ivan,
Since last sending a mail I have been trying to change the name of images both out of and within the authoring tool. This is impossible in Explorer and there is no such option in WebPlus8, only an import/export option.
So I am unable to see how to direct the paht of each individual image to a specific folder in the web space directory.

Still scratching my head and getting splinters!
:?
Angela
N/A

images not showing

Dear Ivan,
A thought occurred to me about the folders for the web site.
If I was to rename the site as htdocs and put all the images into an images folder that when uploaded the addresses would be correct. Does that sound logical?
I cannot find any other way to do it, although just uploading everything to htdocs is what Force9 told me to do and it worked for 10 years.

Angelah Sad
N/A

pictures not showing after uploading

you could always try transferring the files manually using cmd.exe. Its easier to use gui applicaitons to do this, but is not my personal choice. There are other applications out there like cuteftp or bulletftp which will allow you to upload your site.
N/A

Path to images by hand, Ivan

Hello,

I fear the problem as I said before is your web authoring package, it is insisting on linking the files ITS way (i.e. automatically so you dont have the control you actually need and this is why I suggested using a different package from the tool your trying to use). You need a program that will allow you to create the image file paths manually by hand. FTP'ing IS NOT the problem!! I state again FTP ing isnt the issue here at all.

Ivan
N/A

pictures not showing after uploading

Hi Angela

I'm not sure if this is of any use to you at all, but...

If you upload all of your files to the default folder in your webspace then the code in your page should look something like this:

<img src="image.jpg">

If you then put your images into a folder called images, the code should look something like this:

<img src="images/image.jpg">

As an afterthought. Looking at the code on your page, it says that the images are in the same directory as your index page so the code on your page is correct. I use Frontpage and have found on occasions that the filename extensions can be different. If you look on your pc and make sure that your images are jpg and not as FP does JPG or even jpeg, JPEG.

Other than that, I can't really offer much more help as it all looks okay to me.

Regards

Mark
N/A

pictures not showing after uploading

Hi Mark,

Your comments are fine and good but thats NOT her problem, the problem is the package she is using WONT allow her to link the images by hand or the way your suggesting (your suggestions are good but assumes she can do this by hand and the package wont let her!!). The only way around this as I can see it is to using a different web authoring program that allows manual editing as you've suggested.

Ivan