cancel
Showing results for 
Search instead for 
Did you mean: 

.htaccess under CGI server

N/A

.htaccess under CGI server

I'm trying to modify my .htaccess file to enable URL redirection.

Support have indicated that the server is properly configured to allow for any commands in the .htaccess file on my CGI pages to take effect. However, when testing a simple command such as:

Quote
errordocument 404 http://marcpeters.co.uk/error.html


...i get a 403 unauthorised error. The same .htaccess file works fine on www.marcpeters.co.uk. If I can't get this to work, I don't stand much chance of the ReWrite command to work.

Support suggested I write here, does this mean that I am doing something wrong if they can't helpHuh
2 REPLIES
N/A

.htaccess under CGI server

I've realised that I wasn't uploading the .htaccess file as ASCII (der!)

Now that I've got that sorted, using the rewrite command causes a dreaded "Internal Server Error"
message. Could this be because the Module "mod_rewrite" isn't installed on the server? I really need to use this to enable my LONG urls to be made search engine friendly.
N/A

.htaccess under CGI server

Problem: Query strings in the URL of my forum pages mean that google doesn't index them. I need to change the URLs to make them search engine friendly

Solution: Use mod_rewrite to redirect the a URL for example www.videoeditingforums.co.uk/forum/01/31 is typed in the browser and returns: http://www.videoeditingforums.co.uk/index.php?action=displaythread&forum=comments&id=31

Unfortunately uploading the relevant commands in the .htaccess file results in an internal error code being produced. Ahh, but this is a CGI script issue I hear you say? Yep, I've asked tech support and they said post in the CGI forums. Thing is, it's not a CGI issue.

I thought I'd come up with a workaround. I uploaded the same .htaccess file to the "main" server (ammended slightly) so that www.marcpeters.co.uk/forum/01/31 returns http://www.videoeditingforums.co.uk/index.php?action=displaythread&forum=comments&id=31

It worked!!! So that suggest that the mod-rewrite funtion on the CGI server isn't installed? This kinda solves my problem, but google will probably frown upon this as essentially I am mirroring content. I REALLY need to use the .htaccess on the CGI server.... Cry Cry Cry