cancel
Showing results for 
Search instead for 
Did you mean: 

VPN through Netgear DG814 Router

MadBob
Grafter
Posts: 55
Registered: 02-09-2007

VPN through Netgear DG814 Router

(Task here's your seperate threads) Smiley

I have tried to set up VPN :/ the Routing and Remote Access refuses to re-start once I check Remote Access Server and LAN and Demand Dial Routing in the Server Options

I even disabled the Routing and tried Re-enabling with VPN but same problem,under Event Viewer I have a couple of errors, Unable to add the interface Internal with the Router Manager for the IP protocol. The following error occurred: The parameter is incorrect. and The Routing and Remote Access service terminated with service-specific error 2. also Unable to load C:\WINNT\System32\iprtrmgr.dll. which I have checked the following
Quote
Source: Router
Description: Unable to load C:\Winnt\System32\Iprtrmgr.dll
If use the Routing and Remote Access service management console to view the Ports container, the available ports may not be displayed.
To resolve this problem, troubleshoot:

1. Use Regedt32 to verify that the following keys / values exist:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\RemoteAccess\RouterManagers\IP

Value name: DLLPath
Data type: REG_EXPAND_SZ
Value data: %SystemRoot%\System32\Iprtrmgr.dll

Value name: GlobalInfo
Data type: REG_BINARY
Value data: The data varies between computers

Value name: ProtocolID
Data type: REG_DWORD
Value data: 0x21 (Hexadecimal)
2. Verify that Iprtrmgr.dll exists at the specified location.
3. If all the above are correct:

Disable the service.

Uninstall the modem using Device Manager.

Restart the server and let Plug and Play detect the modem.

Enable the Routing and Remote Access service.
which as you can see doesn't really apply to a Router just a Dial up. oh and the Registry is fine the DLL is there and actually in \system32\ as well.