cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to run php on new cgi server

N/A

Unable to run php on new cgi server

I've uploaded my phpBB forum to the new ccgi space, but I'm have a problem.

when I go to install it, it reports the following

CGI System Error: Execution of this script not permitted
CGI System Error: Request Error


The forum worked fine on old cgi space, so should work on new one.

I called support to find out why can't run php and was told to use the forums

regards
Mike
8 REPLIES
N/A

Unable to run php on new cgi server

N/A

Unable to run php on new cgi server

why does the PHP file have to be executable by the user and group if all your scripts are run as you?
N/A

Unable to run php on new cgi server

No idea - I'm just echoing what the support pages say and what the network engineer that built the platform said...
N/A

Unable to run php on new cgi server

ok - but I am currently running my site with php files set at 500, and all non-script files as 040 and its working fine (directories 550).

http://ccgi.jarvis.force9.co.uk/djarv/
(only front page works due to lack of URL rewrites at the moment).

The thing is that this way round you can do some clever stuff like blocking access to images by setting directories to 500 and using a php feeder to get them - stops ppl nicking your bandwidth if you code the feeder right and no need for .htaccess files!

Apart from the permissions advice I'm very pleased with the new CGI so far Cheesy
pops1000uk
Grafter
Posts: 38
Registered: 02-08-2007

Unable to run php on new cgi server

i have the same problem, so how can i get this to work?
N/A

Unable to run php on new cgi server

You should be able to run
/usr/local/bin/fixphpperms.sh -r
from the default location if you SSH or Telnet into the servers.
N/A

Unable to run php on new cgi server

take a look at the link csogilvie suggested, that should hopefully sort you out.
N/A

Unable to run php on new cgi server

...d'oh, too slow Wink