cancel
Showing results for 
Search instead for 
Did you mean: 

Typo3 wont run on new CGI server

N/A

Typo3 wont run on new CGI server

I've been running a typo3 installation (utterly magic PHP-based CMS) on the old CGI server for a couple of years and had no problems. I've run similar installations on my on Linux boxes and on other hosting systems too...no problems.
On installing typo3 on the new server, all I get is the now ubiquitous "CGIWrap Error: Execution of this script not permitted".
To cut a long story short, I tried a simple self-contained PHP script in the same directory as the typo3 installation and it ran without problem. I figured that it is probably a file permission problem and so tried various permissions to no avail. In the end I simply set 777 recursively over all my files (yike!).
Same result.
So I wiped everything. Went to the old CGI server and tarballed all my files. Unzipped them on the new CGI server. Same result. Recursively set all file permissions to 777. Same result.
Wot I'd really like is some more helpful diagnostic telling you exactly what the problem is.
Is there such a diagnostic?
Anyone else tried typo3?
2 REPLIES
N/A

Vote with my feet

So I raised a ticket. < 10 hours cited as response time.
24 hours later...nothing.
So I raised another ticket, whinging about the lack of response to the first ticket.
24 hours later...nothing.
I haven't got time for this c**p. So I voted with my feet. Bye-bye Force9 CGI.
Moved to betterwebspace.com. 12 quid a year, goes like greased lightning. Support is better than excellent. Supports everything you could reasonably want. If it doesn't, they'll make it.
Bye-bye.
N/A

The answer

The answer to my troubles came...
Quote
To asnwer your query regarding this problem, your script installation uses symbolic links, and unfortuantely these will not work on our new server, i beleive they have been disabled for security reasons.


Why, you might ask are symbolic links on a Debian-based server a security risk? A properly enforced permissions policy isn't rocket science!
Quote
i beleive they have been disabled for security reasons

They don't even appear to be sure of the reason for it.

They don't even know how to spell.

I'm glad I moved my hosting.