cancel
Showing results for 
Search instead for 
Did you mean: 

Tried and tried

Howell
Grafter
Posts: 26
Registered: 30-07-2007

Tried and tried

Yes i used this on the first installation so knew how to upload the files.

I did refer back to it to make sure i'm doing it right. I am and still get the errors?

I'm ripping my hair out! Cry
4 REPLIES
Howell
Grafter
Posts: 26
Registered: 30-07-2007

Tried and tried

To install a newer version of phpBB but now all i'm getting after entering my details on the install page is this error message?

Quote
phpBB : Critical Error

Could not connect to the database


I used to have an older version working but completely removed the old versions off the server.

I have double checked and double checked again and i'm deffinatly entering the correct details on the install page!!

Anybody able to help me with this problem? Sad
N/A

Tried and tried

Have you seen the Help Installing phpBB tutorial? Does it help you resolve your problem? If not, please post again.
N/A

Tried and tried

Because you're doing an upgrade rather than a fresh installation, your database tables already exist. It may be better to follow the instructions for upgrading, which may be found in the What's the difference between CGI and MySQL? thread (the second batch of instructions in that topic).

You could check if the problem really is to do with connecting to the database by doing an installation (rather than upgrade), but specifying a different database prefix, which will result in a new forum. If a new forum is acceptable (ie in effect you throw away all previous messages [unless you backup and restore to the new forum]), then this would be a possible route forward, followed by deletion of the previous set of database tables. If you do this, and it still reports it cannot connect to the database, then further investigation is necessary -- have you specified the correct database server, username and password; can you manually connect to the database using phpMyAdmin?
Howell
Grafter
Posts: 26
Registered: 30-07-2007

Tried and tried

I've got it working now! I was entering 'rumpus' instead of 'humbug' as this is what my browser was suggesting in a drop down box.

Teach me to trust my browser hey! Shockedops:

Thanks for your help. Tongue