cancel
Showing results for 
Search instead for 
Did you mean: 

Solwise SAR110 and mIRC DCC SEND

N/A

Solwise SAR110 and mIRC DCC SEND

Is there anyone out there who actually has this working... properly, and is prepared to let me know exactly how to get the damn router to do this.

After testing it looks to me like the MIRC ALG translates the port to use into the napt range. when the inbound connect comes back i get a NAT translation entry which shows the napt port correctly translated back only the local IP address hasnt been translated from the external address to the relevant internal one.

I have a VERY simple NAT (1 rule) and IPFilter (2 Rules - only one relevan) config

Any help appreciated
(and please please please dont point me to the www.mirc.co.uk page about firewalls or I may have to scream)
3 REPLIES
N/A

Solwise SAR110 and mIRC DCC SEND

Ahem. Would you scream if we sent you to the Netgear DG814 and mIRC topic?

OK, it's Netgear not Solwise, but the principles will be the same. Take a look there and see if that helps. If not, post back here.
N/A

Solwise SAR110 and mIRC DCC SEND

Thank you for the suggestion, sadly didnt help.

I'll paste here the email i sent to solwise that may help:
==============================

I have a Solwise 110 ADSL Router as provided by Force9 (Plusnet), and I am experiencing difficulty getting DCC SEND to work in mIRC.

I have read through your forums, and many others in an attempt to find the solution, and while many people glibly say oh just do this or that, no one that I am aware of is actually able to offer a solution to this problem.

I have taken a little time and looked quite closely at this problem and here is my analysis.

The local mIRC sends the CTCP message containing the DCC SEND request successfully to IRC. In my case it selects a port in the range 5000-5016 and the correct (external) ip address. This message is modified (I assume by the MIRC ALG in the router) to use a port in the napt range. Thus when initiating the connection the remote mIRC attempts to connect to a port in the napt range on the external IP. The port translation back to the 5000-5016 range appears to work, however the external IP doesnt seem to be translated so this fails - and I assume this is because the MIRC ALG is not quite doing its work completely and realising that the inbound connect corresponds to the application CTCP message previously modified by the ALG. As you can see from the entry in the translation table below the address isnt translated to the internal IP address of the relevant machine

Translation Index: 69
Rule ID: 1
IF Name: ppp-0
Protocol: TCP
ALG Type: -
Translation Direction: Outside
NAT Age: 4
Translated InAddress: 81.174.240.11
In Address: 81.174.240.11
Out Address: 4.7.212.165
In Packets: 3
Out Packets : 0
In Ports: 5012
Out Ports: 4455
Translated In Ports: 50484


At present I lean towards the suspicion that the ALG isnt quite doing its job, however I am quite prepared to accept that I have done something stupid in the setup if someone can tell me what that is.

Just for completeness here are the NAT rules and IPF rules in the router:

Rule ID IF Name Rule Flavor Protocol Local IP From Local IP To 5 ALL RDR TCP 192.168.7.2 192.168.7.2


Rule ID I/F Apply Stateful Inspection Direction Rule Action In I/F Log Option Rule Description Oper. Status
10 ALL Enable Outgoing Accept ALL Disable - On
20 ppp-0 Disable Incoming Accept N/A Disable 1.Protocol eq ICMP 2.ICMP Type 11
On
N/A

Solwise SAR110 and mIRC DCC SEND

OK... I've fixed it.

The solution, for any SAR users who may need to knwo is this....

1) you dont need any port forwarding for DCC SEND
2) you dont need any special IP filters for DCC SEND

in mIRC go to LOCAL INFO in the mIRC Options.

clear out local host and IP address

uncheck On Connect get local host
check On Connect get IP Address

Select Normal Lookup method

Now when you connect you should see your internal IP address in the IP address box. DCC SEND should work fine.

My router has JUST the rules given in the above posting and it works fine