Showing results for 
Search instead for 
Did you mean: 

Protection problem?


Protection problem?

I'm completely confused about what is happening here.
I have some .php files (its actually webcalendar) which was all working just fine on my own server, but I have problems having moved it on to the force 9 server.

I've set the protections to rx for u g and o for all files.

The php scripts work just fine, and display the generated HTML. However any .gif files which get referenced in the pages cannot be seen.

Similarly any plain .html files cannot be opened. I get server error.

It is as if the protections were set wrong, but as far as I can see they are about as wide open as can be. (probably too wide, but I'm trying to eliminate any problems at the moment).

Any suggestions?

e.g. the file is

-rwxr-xr-x 1 standrewsoxshott cgiusers 319 Feb 5 15:42 test.html

the directory is

drwxr-xr-x 11 standrewsoxshott cgiusers 4112 Feb 5 15:52 webcalendar

could it be something to do with the sticky bit? Have I manged to nuke it?

i.e. this bit from the FAQ

3. Directory Permissions
The base permissions you need on a directory is chmod 750. Additionally, a special bit is set on the group permission that ensures all files you create in the directory is group-owned by the group nogroup. If this special bit is removed, files under that directory will be owned by the wrong group and you won't be able to access the contents via a web browser. Due to a security restriction which protects the system from published hacking attempts, you will NOT be able to add this bit back by yourself.

This implies the group should be "nogroup".

Any suggestions?


Protection problem?

you havent be spacific on what errors your getting and what callander your using.
all php files need cmod 755.
your index file might need to be .php
dose it need mySQL?
check any config.php files need editing. because of the server change.

there are loads of reasons your script might not be working to name a few.
hope you figer it out


The problem was an old .htaccess file (in which I had tried to turn on magic quotes) It hadn't had the desired effect on running the php scripts (and I had since changed them to not need magic quotes), but for some reason or other it DID block loading of .html or .gif files.
Any way, deleting the unnecessary .htaccess file fixed the problem.

BTW the information about the group needing to be nogroup seems to be bogus. Mine are still group cgiusers and all is working fine now.