cancel
Showing results for 
Search instead for 
Did you mean: 

Problems with new platform

tony2007
Grafter
Posts: 115
Registered: 15-08-2007

Problems with new platform

Hi,
I've just been trying to set up my files on the new platform.
But when i try to set up the files in the cgi-bin I keep getting the following error:

Quote


CGI System Error: Execution of this script not permitted

--------------------------------------------------------------------------------


CGI System Error: Request Error

--------------------------------------------------------------------------------

There is a problem with the request. Please contact the owner of the site you are trying to access.



--------------------------------------------------------------------------------


Local Information and Documentation:

CGI System Docs: /usr/doc/cgi

Server Data:

Server Administrator/Contact: support@force9.net
Server Port: 80
Server Protocol: HTTP/1.1
Virtual Host: ccgi.sociologyonline.force9.co.uk




Can anybody advise what I'm doing wrong?

Thanks
7 REPLIES
N/A

Problems with new platform

Check the permissions on the file are correct - they should be 740.
tony2007
Grafter
Posts: 115
Registered: 15-08-2007

Problems with new platform

Thanks for your very quick response - but chmod-ing to 740 [read, write and exec for owner and read for group?] doesn't seem to make any difference.
Cry
N/A

Problems with new platform

What sort of file?
N/A

Problems with new platform

try this

    cshell02:/# fixphpperms.sh

    fixphpperms.sh - a script to add user executable bit to .php files you own

    Usage: fixphpperms.sh {-c | -r | -s}

    Where:

    -c will fix all .php files in your current directory AND all subdirs
    -r will fix ALL .php files from your homedirectory down
    -s will fix all .php files in your current directory only


you need to telnet onto your cgi server and run from shell

the following thread will give some more info as i had that problem

http://portal.f9.net.uk/central/forums/viewtopic.php?t=5343

regards
mike
tony2007
Grafter
Posts: 115
Registered: 15-08-2007

Problems with new platform

Thanks Mike for the advice, but I don't use .php very much at the moment.
Most of the files which are causing the present problem are .cgi and .pl
Any advice, anybody?
N/A

Problems with new platform

Hi

Sorted mine using 755.

Regards

Stottie
tony2007
Grafter
Posts: 115
Registered: 15-08-2007

Problems with new platform

Thanks Stottie,
But still doesn't work for me when I chmod at 755
But now I'm getting an Error 403 page
Quote

You might not have permission to view this directory or page using the credentials you supplied.

Have even tried uploading a new version of the Coranto CMS to the 'bin' [in case my old files were still using old paths] but get the same error page with this as well.
Get the same error page when I point to what should be my index page


http://ccgi.domain.force9.co.uk/