cancel
Showing results for 
Search instead for 
Did you mean: 

Php4 + a Qube2

N/A

Php4 + a Qube2

This is really a shot in the dark, but I am trying to put php onto my Colbalt qube2. I have already installed MySQL on it.

The problem is is that when i try to install php4.3.1 on the Qube it comes up with :
[admin@mrgoose.plus.com php-4.3.1] ./configure --with-mysql --with-apxs
loading cache ./config.cache
checking for Cygwin environment... no
checking for mingw32 environment... no
checking for working sed... sed
checking host system type... i686-pc-linux-gnu
checking for gcc... gcc
checking whether the C compiler (gcc ) works... yes
checking whether the C compiler (gcc ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking whether gcc and cc understand -c and -o together... yes
checking how to run the C preprocessor... gcc -E
checking for AIX... no
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking for ranlib... ranlib
checking whether ln -s works... yes
checking for gawk... gawk
checking for bison... no
checking for byacc... no
configure: warning: You will need bison if you want to regenerate the PHP parsers.
checking for flex... lex
checking for yywrap in -ll... no
checking lex output file root... ./configure: lex: command not found
configure: error: cannot find output from lex; giving up

I then tried to install Flex (lex) but that failed..

Any help would be grateful

Angus
8 REPLIES
N/A

Php4 + a Qube2

OK, it's not allways that simple to install programs or libraies.

if it is a library, you usualy have to place the path to the library in /etc/ls.so.conf and regenerate the ld.so cache (use "ldconfig" as root).

For other programs, you need ot make sure that you install them within the reach of the PATH environment variable.

You may also find it usfult o search the net for some craching resources. I have seen many sites in the past that provide ISO's that provide a full clean install with these services for the Cube.
N/A

Php4 + a Qube2

I have been looking for the last 4 weeks for an ISO that will do it all in 1... but can't find any. bar Brosoft who want $175 for thier ISO, and as I'm doing it all for fun, I really can't afford to pay for it.

I have found about 5 instructions on the net of how to install php on the Qube & I have tried all, and the keep coming up with the above problem.

I've been installing it in /home/src which is I'm told correct?

If your bored one day I can give you telnet or SSH access to the box??

Angus
N/A

Php4 + a Qube2

First off, your avatar is above the 80x80 limits. Takes up half my screen.

After lookign a little at the PHP website, I couldn't find anything definate, though I did find what flex was needed for.

When you install lex/flex, did you make sure it was in the path, or place an entry into your path to reflect it.
N/A

Php4 + a Qube2

I have changed my avatar for you.. sos for taking up your screen...

All the documents about flex don't really say where it's meant to be.. I'm new to playing with my qube as I am just starting to understand it.

I tried to install it in the same dir as the rest /home/src ? But it might be in the wrong place?? I'm unsure.

Mysql installed straight in to that dir so I presumed that all programs were meant to go there? Which is where php-4.3.1 is as well.

Angus
N/A

Php4 + a Qube2

You shoudl be able to type "whereis flex" or "whereis lex".

This should give yout the current location, so long as it is in the path.

If not, then it sounds to have been installed in the wrong location.

Having done a little reasearch on getting it installed on the Raq2 and Cube2 (same in hardware terms from what I make out). I find that nothing seems to deal with flex issues.

I can only guess that that flex isn't instaled correctly.

http://www.phpbuilder.com/mail/php-install/2000101/0015.php
The reply to this message also sugests the same (Must be a bug int he configure script of php)
N/A

Php4 + a Qube2

So I'm guessing I need to try another version of php4?
I'm currently trying to install 4.3.1 - I think this is the lates version. Might try php3 .

Angus
csogilvie
Grafter
Posts: 5,852
Registered: 04-04-2007

Php4 + a Qube2

You could try downloading and compiling ftp://ftp.mirror.ac.uk/sites/ftp.gnu.org/gnu/non-gnu/flex which might work. (I remember having to install flex on my laptop, but can't remember how I did it Smiley)
N/A

Php4 + a Qube2

I have got flex-2.5.4a in the dir /home/src but unsure if it's meant to be in there.

Might also try to use a diff version of php.

It's only so I can test my phpbb with diff types of mods before I put them up http://cgi.mrgoose.plus.com/phpBB2/index.php and not cause myself more grief when I have done & they don't work. Cry

Angus