cancel
Showing results for 
Search instead for 
Did you mean: 

PHP file no longer working.

N/A

PHP file no longer working.

Hi,

I've just updated a PHP file to my cgi-bin, but now it doesn't work any more - I'm getting an Internal Server Error. It was just a simple change to add a link to an HTML page which I've tested OK offline.

I've tried copying it across using WS_FTP and using just FTP, both as binary and ascii. The file is in there and it looks OK. I've made sure that the permissions are set to 755, which is consistent with other files in the cgi-bin.
So now I'm a bit stuck as to what to do next.

I'd be grateful for any suggestions.

Thanks,

Harvie Mills
harviem@scotlegal.com
3 REPLIES
N/A

PHP file no longer working.

I KNOW WHAT IT IS! - sort of.

I bet you're getting

Quote
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, [no address given] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.


This was happening to me back in March 2003 and was the subject of a contact-us ticket 6545721

The problem was in the stuff right at the top of the file - it either needed or had to NOT have a space at the end of one of the lines before the carriage return.

Can't remember exactly what. I do recall posting to a forum with what I found but I think that was in the old version and I don't know if it's archived or if we can get to it.

Get one of the support guys to look for postings from me around the date of ticket 6545721 and you'll have your answer.

Note that the f9 gang don't look in this forum too often so you'll have to go to the customer feedback one and point them here.

Hope this helps.
N/A

PHP file no longer working.

Thanks for your reply. There didn't seem to be anything wrong with the top of the file, but some guys on the newsgroup came up with a working solution.
They suggested creating a php directory in the cgi root (/home/username/php)
and moving the php file into there from the cgi-bin.

This works, so problem solved, but I'm not entirely happy that it was working fine in the cgi-bin and now it doesn't, so I'll take that up with customer support, quoting your ticket number.

Regards

Harvie Mills
harviem@scotlegal.com
N/A

PHP file no longer working.

Found the thread.

Don't know how to put a link to it here.

it's dated 26 Mar 2003 11:06
subject is Internal Server Error

Look there and see