cancel
Showing results for 
Search instead for 
Did you mean: 

PHP Upload Script no longer working

N/A

PHP Upload Script no longer working

This is really annoying now!

I wrote an upload script to upload jpg and gif file to my cgi webspace. It was working yesterday and for months before that. Now it is not working for jpg's larger than about 6.5kb!

After spending all day trying to get it working I thought I would see if anyone else is experiencing the same problem.

If I choose a small jpg < 7k, after transferring
The mime type is correct.
The size is correct.
The file will pass the 'move_uploaded_file' validation
A file is created in the directory, but the file is only 0 bytes.

If I choose a file larger than 7Kb,
No mime type is picked up
Size is 0 bytes
obviously it won't pass the 'move_uploaded_file' validation. The error code given is 3, the file only partially uploaded

I have checked the directories have 777 permissions, I have tried overiding the mime type by using an .htaccess file in the directory with the line AddType text/plain .jpg but it doesn't seem to effect anything.

I have tried the page on another computer just incase my browser (IE6) has been updated, and is now submitting the wrong mime type.
I have searched the net, can't find any examples of similar problems.

Is anyone experiencing the same thing?
Can anyone help?
4 REPLIES
N/A

Apache 2 configuration

Ok, I have found some references to similar problems when people have upgraded to Apache 2. There is a setting in the configuration files that causes the same problem.

Anyone know whether F9 upgraded to Apache 2 recently? Does F9 even use Apache?
N/A

PHP Upload Script no longer working

The CGI servers are running on Apache/1.3.9 according to http://cgi.force9.net/phpinfo.php
N/A

PHP Upload Script no longer working

Oh... That scuppers that idea then!

Anyone got any ideas?
N/A

Waaheyy

Well, I don't know what has happened, the scripts have remained untouched for 24 hours as I had gotten fed up of going around in circles.

I thought I would just try again, and guess what... Working perfectly. Files upload, sizes are correct, no problems.

Wonder what was wrong/has changed?

I hate/love computers!!!!!