cancel
Showing results for 
Search instead for 
Did you mean: 

PHP Nuke Problems

N/A

PHP Nuke Problems

Hi,

I am having a problem installing PHP-Nuke onto the CGI server, i have followed the guide thought he problem i have is the below error message:

"Warning: main(language/lang-.php): failed to open stream: No such file or directory in /files/home2/jjc100/phpnuke/html/mainfile.php on line 163

Warning: main(): Failed opening 'language/lang-.php' for inclusion (include_path='.') in /files/home2/jjc100/phpnuke/html/mainfile.php on line 163

Warning: get_lang(admin/language/lang-.php): failed to open stream: No such file or directory in /files/home2/jjc100/phpnuke/html/mainfile.php on line 178

Warning: get_lang(): Failed opening 'admin/language/lang-.php' for inclusion (include_path='.') in /files/home2/jjc100/phpnuke/html/mainfile.php on line 178

Warning: head(themes//theme.php): failed to open stream: No such file or directory in /files/home2/jjc100/phpnuke/html/header.php on line 31

Warning: head(): Failed opening 'themes//theme.php' for inclusion (include_path='.') in /files/home2/jjc100/phpnuke/html/header.php on line 31

Fatal error: Call to undefined function: themeheader() in /files/home2/jjc100/phpnuke/html/header.php on line 47"

From what i have seen on google i have a problem with connecting to the database (humbug) so i have done a test.php file and thats working. So now i think it is because i have not created the tables in the SQL server manually but the problem is i don't know how to do this, does anyone know how i can learn? Also if i am wrong does anyone know what i have done wrong?

Thanks
3 REPLIES
zigzak
Grafter
Posts: 63
Registered: 08-06-2007

PHP Nuke Problems

Hi jjc100,
I install PostNuke the other day without any problems.
I just copied all the files provided in the .ZIP file using FTP to my CGI space - there are loads of files and it took a good while - perhaps 30 minutes!

I then set write permission on the config.php file and config-old.php file as per PostNuke instructions then opened the file "install.php" in my browser - again as per their instructions.

When it came to the database part of the setup you just need to tick the option about making the tables automatically and then it should work fine.

I think the bit about doing things manually is referring to making your mySQL database in the first place - but then Force9 have already done that when you activated your webspace.

After the steps above the install told me everything was fine and I was then able to access my new PostNuke site with no problems - it looks interesting. However as I was one of those who lost all my CGI data the other day I'm going to have to install it all again tonight!!!!
zigzak
Grafter
Posts: 63
Registered: 08-06-2007

PHP Nuke Problems

Sorry - I've just looked at it again - the tick at the database set-up point says "Create Database" - this should NOT be ticked as your MySQL database already exists.
Provided you've supplied the database connection information which Force9 emailed to you when you turned on the MySQL service it'll be fine!
N/A

PHP Nuke Problems

Thanks, i will have a look when i come back as i am currently in Goa at the moment though thanks for your help...

JJC100