cancel
Showing results for 
Search instead for 
Did you mean: 

Netgear DG814 and mIRC

MadBob
Grafter
Posts: 55
Registered: 02-09-2007

Netgear DG814 and mIRC

(Task here's your seperate threads) Smiley

I can connect mIRC through the Router without any alterations but I can no longer DCC Send, or use my Fserve (I can DCC Get just not send)

I am trying to test by running mIRC on my server and connecting to my ICS running mIRC, this is something I had done in the past when testing my settings, this no longer works now I have the Router,

both versions of mIRC are set up DCC > Options > Local Info to always get Local Host and IP address, and to use Lookup Method 'Server' they have the correct Host and IP info, and I can use /dns MyNick in the Server Connect page, and also //say $ip in the Channel to make sure both give the correct IP and Host info (they do)

I assume there is need of either port forwarding or Opening a port on the Router?
9 REPLIES
N/A

Using mIRC DCC Send with an ADSL Router

To put any contributors to this thread in the picture (literally), here is a diagram showing the network topology of "SkankyNet" and its Internet connection:




This topology comes about as a consequence of replacing a USB-connected ADSL Modem with the DG814 router (the connection between "GW" and "DG814" was previously a USB connection, and "DG814" was the ADSL Modem; "GW" was performing Microsoft Internet Connection Sharing [ICS] and "Server" provides DHCP and DNS services to the PCs in "Inner Net").

*****

My own first comment on this thread:

Have you see the DCC Send with NAT Router page on the NewIRCusers.com website? It's written with a Linksys Router in mind, but it seems to me the principles must also apply to any router.
MadBob
Grafter
Posts: 55
Registered: 02-09-2007

Netgear DG814 and mIRC

Without the aid of that Tutorial (and without the aid of a safety net) Smiley I had already set up all of those mentioned settings, different ports but the same principles,

however there is no (Step 5) 'Port Triggering' in the Netgear setup, and I cannot find a way to add this information which I assume now is the missing link.
N/A

Netgear DG814 and mIRC

Quote
however there is no (Step 5) 'Port Triggering' in the Netgear setup, and I cannot find a way to add this information which I assume now is the missing link.


I was reading the manual for that Linksys router (turns out it's what we would call a "Cable/DSL Router" -- it doesn't incorporate an ADSL modem) to find out what that port triggering feature does.

It's a nice trick, but I suspect it's probably been superseded by UPnP. This is what (I think) it's doing:
    In the "port triggering" configuration, you can define a range of ports to be opened for incoming connection requests. But, unlike normal port forwarding, you don't tell the router the internal IP address to which it should direct these incoming connections. Instead, you tell the router to monitor outgoing traffic on ports you specify (these are the trigger ports). When it detects traffic on these ports, it looks to see which internal IP address it came from, and at that point it makes the association for the port forwarding, using the IP address of the internal host which sent the trigger. It means the port forwarding is more dynamic, so it could forward to "PC-A" one day, and "PC-B" the next, without any manual reconfiguring.
But it still boils down to port forwarding.

So, if you can live with the constraints of always forwarding to the same internal IP address, any router will do, even ones without this fancy bit of footwork.

On that "newIRCusers" website, the ports they were forwarding through triggering were 6660-7000 (port 6667 is the one that is frequently mentioned for IRC), so if you know you're always going to be using mIRC at a given PC, you could just set your router to forward ports 6660 to 7000 to that PC, and live without the triggering.

But, something tells me you've probably done that already...

As a matter of interest, which ports have you opened for mIRC? It seems there are standard ones, which every[/i[ mIRC user will have to open in order to use the product at all. Then there are other ports (or sets of ports), which can be any range the users likes and which are used for particular mIRC functions, so not every user will need to open them.
MadBob
Grafter
Posts: 55
Registered: 02-09-2007

Netgear DG814 and mIRC

Still no solution yet, more info on another site Here I will be continuing this into the early hours (again) Smiley
N/A

Netgear DG814 and mIRC

Quote
Still no solution yet, more info on another site Here I will be continuing this into the early hours (again) Smiley


That's what weekends are for!

I notice the author of that article is another chap with a Linksys router. But he's not using the triggering facility (and makes no mention of ports 6660-7000 -- perhaps that's in a different part of his guide).

I'm not sure he's added anything new -- maybe forwarding ports 59 (for the port the [file?] server is listening on) and 113 (Identd)?
MadBob
Grafter
Posts: 55
Registered: 02-09-2007

Netgear DG814 and mIRC

I set up mIRC to use Ports 1020 - 1029 and set Port forwarding in Netgear Set-up to Forward 1020 - 1029 to 192.168.1.2, and that was all Smiley it seems to work now,

part of the problem seems to have been that some people who use Fservers only use Port 59 for Fserv, I set mIRC to Enable DCC Server and listen on port 59 and it seems OK

the other part of the problem was trying it out with a connection to mIRC on another of my systems, this it doesn't like at all Smiley
N/A

Netgear DG814 and mIRC

Well done! Another success chalked up!

So, in the end which ports did you have to forward for this, and what does each one do?
MadBob
Grafter
Posts: 55
Registered: 02-09-2007

Netgear DG814 and mIRC

In mIRC under (Alt+O) DCC > Options I set the ports to 'First = 1020' 'Last = 1029' and 'MAx Sends = 10'

under DCC > Server I Checked 'Enable DCC server' and set 'Listen on Port = 59'

under 'Connect > Local Info' I left the 'Local Host' and 'IP info' empty and checked 'On Connect Always Get: = Local Host' and 'Lookup Method = Server'

under Connect > Identd I checked 'Enable Identd Server' and made sure the the port was 113,


then in the Netgear Setup I added two services in the port forwarding

name | start | end | Forward
====================================
mIRC | 1020 | 1029 | 192.168.1.2
mIRC2 | 113 | 113 | 192.168.1.2

and I think that was that Smiley

but as I said it allows me to DCC Send / Get with no problem *so far* but if I run another instance of mIRC on one of my other PC's, something I have always done to test my Fserve when I had a USB Alcatel Broadband "Modem" it will not DCC Send to that PC

===

Ports 1020 - 1029 are the DCC send ports, hence setting 10 as Max Sends for the 10 ports configured (you could set more)

port 59 is the Fserv listening port, again you could set your own but some firewalled Fservs will only accept this port.

and Port 113 is the Ident Server Port which is used to respond to a request with 'verified' server information,

if I have any of this wrong feel free to educate me Smiley
N/A

Netgear DG814 and mIRC

Quote
if I have any of this wrong feel free to educate me Smiley


No, that wasn't my game! I was interested in getting it all documented in a single place, so that if anyone else was interested, they could get everything they need in one shot, without having to pull together bits and pieces from all over the place.