cancel
Showing results for 
Search instead for 
Did you mean: 

It won't work - I have tried everything

N/A

It won't work - I have tried everything

I don't know if anyone out there will be able to help, but before I pull all my hair out i am going to ask anyay.
I am installing movable type blog, everythign is up and running fine, configured it perfectly (or so I thought anyway) can control the weblog.
BUT when I go to view my weblog, can I? Nope, I just get the message saying that I cannot access it - not happy.
Anyway I need to check a few things just to make sure I have all the correct info in there, incase I have made a dumb mistake.
Obviously i have all the cgi files in my cgi-bin. my html fiels and all files which need to be are stored outside of my cgi-bin.

some of the cofig setting I am unsure about are as follows (what they ask for and what I have entered)

Local Site Path (where main index file is located - outisde of cgi-bin in my case) I have put : /files/home/username/blogfoldername
Local Archive Path (outside of cgi-bin again) I have put : /files/home/username/blogfoldername

they ask for absolute paths - and I am not sure if these are correct as it seems to want to access my cgi-bin for these files - have i done something wrong?
2 REPLIES
N/A

It won't work - I have tried everything

Hi, I have movable type set up ... email me at mt@edbateman.com if this doesn't sort the issue out.....

Just to check:
1. You've installed the movable type stuff inside your cgi-bin directory. So you've downloaded the tar or zip and copied them (using the correct mode as set out in the manual) to the cgi-bin directory.
2. You need to set up a static directory outside of your cgi-bin directory
3. Inside this (I called mine mt-static) you need the docs folder, the images folder and the styles.css file.
4. In my mt.cfg file I have: CGIPath http://cgi.eaglecentre.force9.co.uk/cgi-bin/
StaticWebPath /mt-static/

and at the very bottom, where I have my SQL database access set up:
ObjectDriver DBI::mysql
Database eaglecentre_f9
DBUser eaglecentre
DBHost humbug

You need to insert the various correct bits in there.^^^^^
You want to use SQL because it is much faster than the berkely flat file database stuff that is available. You can upgrade to SQL at a later date if you like though. You'll need to set up the db folder though (707).

5. Save and exit mt.cfg
6. Open mt-db-pass.cgi in a text editor. On this line:
database_password
7. cd cgi-bin; chmod 705 *.cgi
this will change the permissions on the files.
8. next, OUTSIDE OF YOUR CGI-BIN , create a new folder, called blog or something equally remeberable Wink . Set the permissions on this to 707.
9. Let's check that you have set the permissions up for your mt installation: http://cgi.whatever.force9.co.uk/cgi-bin/mt-check.gi
that should work like mine http://cgi.eaglecentre.force9.co.uk/cgi-bin/mt-check.cgi
Does that load and show the same thing as mine?
I'm hoping so Smiley

10. http://cgi.whatever.force9.co.uk/cgi-bin/mt.cgi
login using: Melody and the password Nelson
11. The first thing you should do is change your author name and password. To do so, click Edit your profile, then change the author name and password there
12. Then:
The next thing to do is to configure your first weblog. A weblog called First Weblog already exists in the system; this weblog will help to give you a head start in setting up your first weblog in Movable Type. First Weblog comes with some pre-made templates; of course you can edit these templates, or delete them, or do whatever you like with them. But they are a good starting point, and will give you a sense of familiarity with the Movable Type template tags and structure.

To configure the weblog for your own purposes, click on the link to First Weblog under Your existing weblogs, then click on the link to Weblog Config. Change the name of the weblog to whatever you wish to call your weblog, and enter a description.

Then, fill in the path and URL information (Local Site Path, Site URL, Local Archive Path, and Archive URL). Values for Local Site Path and Site URL are provided by default, to give you a sense of what the paths should look like; when setting the values of Local Site Path and Local Archive Path, it is best to use absolute paths (paths beginning with a /), rather than relative paths. Note that all four of these fields must be filled in. You should already have created the directories for your weblog (above, in Create your weblog directories). Fill in the local paths (site and archive) with the full paths to those directories. Then enter the appropriate URLs, corresponding to those directories.

Edit any other configuration settings for your weblog; when you are done, press SAVE.


So my values are:





Any other issues with setting it up?
(send me an email so I 'm reminded to come back and check!)


Oh, and you want to go and download Jay Allen's mt-blacklist cgi script once your blogging gets going to protect yourself from comment spam.

HTH!



Cool
N/A

It won't work - I have tried everything

I may have gone a little overboard on the description of setting it up, but I wanted to make sure that you did indeed have the static files in the necessary places on the CGI server.
Also, just to emphasise that the pages for your blog (the actual pages you're trying to look at) must be outside of the cgi-bin.