cancel
Showing results for 
Search instead for 
Did you mean: 

INSERT using F9 SQL Admin tool

N/A

INSERT using F9 SQL Admin tool

I'm trying to populate my database by using F9's SQL Admin tool. I first tried to do a schema dump from my development environment and copy and paste the SQl into the Query box, but it come up with 'internal error'.

I then tried dumping each of the tables one by one, but it still didn't work. It only seems to work when I give it one SQL command at a time. This is going to take hours if I have to runeach INSERT INTO Sql command one-by-one.

Can F9s tool only handle one SQL command at a time? Is there a better way of doing this?
2 REPLIES
Ianwild
Grafter
Posts: 3,835
Registered: 05-04-2007

INSERT using F9 SQL Admin tool

Hi,

We plan to replace this tool with phpMyAdmin in the next couple of weeks, but I will try and see if I can recreate the problem if I get 10 minutes spare later...

Regards,
N/A

f9 admin tool is hopeless

Hi When I first joined f9 I had to import a flatfile db into MSQL and could not do it either. In the end I download PHPMyAdmin and have been using it ever since.
It is easy to confirgure to your f9 database and is simplicity itself to use.
However even when I tried to edit my table using the admin tool I constantly got "internal error" too, even though I was following the selfsame procedures as updating a much smaller table.

The good news is that f9 are promising us PHPMyAdmin very soon as so long as they don't put anything between the user and MyAdmin you should be up and running soon.
Set up your table structure, and then just import the text delimited file. One word of warning - if you have lots of quotation marks or backslashes (ie.g. url addresses in your text file you will need ot do a lot of "escaping" to get it to transfer correctly. I had a friend write me a small script that did it for me which was great.
Good luck
Gina Dee