cancel
Showing results for 
Search instead for 
Did you mean: 

IIP

N/A

IIP

I am practicing with asp as part of my college course. I have installed iip on my XP machines, but cannot actually load the asp pages I put in wwwroot There were no instructionjs, but I am calling them with www.machinename/pagename.asp am I getting it wrong somewhere? All I get is page not found.
8 REPLIES
Plusnet Staff
Plusnet Staff
Posts: 12,169
Thanks: 18
Fixes: 1
Registered: 04-04-2007

IIP

Hi,

Try using the address http://127.0.0.1/ this will be the (or one of) the IP addresses of your PC. This should give you a SIte Under Construction or Help Page unless you've put an index page of your own in the wwwroot folder.
N/A

IIP

Tried the machines IP, just got page not found (Oh and its IIS not IIP)
N/A

IIP

hmmm - try apache

and while your at it move to linux Cheesy
N/A

IIP

running apache on my server, wouldn't touch Linux Smiley But I want to be able to run asp from my local machine for testing
N/A

IIP

Hi Rev,

Well it's a good sign that you're getting "Page not found" rather than "Cannot find server or DNS error" because that indicates that IIS is running.

It sounds like your default website isn't looking for pages in the same place that you're putting them. Have you configured the website?

Apologies if this is obvious to you but I'm covering the basics before launching into anything more complicated. It's probably something quite straightforward that's causing the problem as what you're trying to do is simply serve an ASP page!

The default website looks for its content by, ahem, default, in c:\inetpub\wwwroot where you said that you put your ASP pages but it's worth checking. You can either put your ASP pages in this folder (or a folder "beneath" it) or configure IIS to look for the content elsewhere.

If your ASP pages aren't in the default location, or perhaps your default website doesn't have the default settings, or in any case just to check it out, you'll need to load up the Microsoft Management Console with the IIS snap-in. This is a needlessly complicated way of saying "Go to Start | Control Panel | Administrative Tools | Internet Information Services".

Expand the "local computer" branch, under which should be "Web Sites" and possibly other stuff such as "Default SMTP Virtual Server" depending on what other components you've got installed. "Web Sites" is what you want (obviously!), so expand that to see "Default Web Site".

Right-click on "Default Web Site" and select "Properties" which will bring up a window with 6 tabs at the top. Select the "Home Directory" tab and you're where you need to be!

At the top there are 3 radio buttons to tell IIS where to look for your web content. Make sure that the "A directory located on this computer" button is selected (that's assuming that your content IS on your local machine but I think that's a fairly safe assumption...).

The next section specifies a "Local Path:" which is the path to the folder containing your web content. This can be absolutely anywhere that you desire n your computer - it makes no difference to IIS, as long as it knows where to look.

At this point you can either click on "Browse.." to locate your web content or note the current location and move your files to that location.

There are a number of checkboxes underneath which control access permissions to the web content. All that needs to be checked to make the page display is "Read".

Leave the rest of the settings for now, unless you've changed any of them they should be set so that the site displays.

Now fire up a browser and go to http://127.0.0.1/pagename.asp as dtomlinson suggested, or http://localhost/pagename.asp which is the same thing.

Any luck? If not I'm sure we can get it going somehow.

Jon.
N/A

IIP

I just had a thought! (Quick, have another before it dies of loneliness!) I had to adjust my host file so that I can get to websites stored on my server from other machines on my network! DUH! Thats the problem I think cos I also redirect localhost to my server. Time for plan B I think. How do I add IIS to my lappy running XP home?
N/A

IIP

Hahaha, ok I think my "tutorial" was pitched at the wrong level :lol:

Not sure if evil Microsoft allow IIS to run on XP home but if so, go to Control Panel | Add/Remove Programs then click on the "Add/Remove Windows Components" icon to the left, select "Internet Information Services" from the resulting list and proceed!

Must... do... some... work today.... Wink

Jon
N/A

IIP

not listed Sad i need it as an add on. i tried installing pro over home but it didn't work. i think my lappy hates me! I know my main one does cos it won't autosearch from the browser despite what I do in tools/internet settings.

And as for the W word at the end of your last, have you no shame young man? usung words like that in public!

http://www.komputers4kids.co.uk
Helping all in education get IT equipment


(Must find the sig settings here...)