cancel
Showing results for 
Search instead for 
Did you mean: 

FormMail.pl - cannot get it to work

rifraf
Newbie
Posts: 4
Registered: 04-08-2007

FormMail.pl - cannot get it to work

Has anyone used the latest version of FormMail.pl from Matts Script Archive?

The file is in the correct pace - but it doesn't seem to run - i intially got a "you dont have permission ..."

So i went into @referrers and addd the server ie.

'cgi.force9.net'

but still the same error.

I'm not sure if i'm setting the permissions correctly. Using WS_FTP is go onto the file, right click and go to "CHMOD(Unix)" and make all of the sections owner, group and other "read, writre and execute" as i have done with another script which i am using which works fine. This one doesn't - can anyone see waht the problem is?

9 REPLIES
N/A

RE: FormMail.pl - cannot get it to work

I'm using the formmail.php script from boaddrink.com and am having the exact same problems with the refers. From what I can work out with the version I am using is you need to specify the IP of the server hosting the form as well as the server receiving the mail - I think this is mail.force9.net yet when I ping it I get no responseHuh

If I work anything out I will let you know.
--
Regards

Richard
rifraf
Newbie
Posts: 4
Registered: 04-08-2007

RE: FormMail.pl - cannot get it to work

> I'm using the formmail.php script from boaddrink.com and am having the exact same problems with the refers. From what I can work out with the version I am using is you need to specify the IP of the server hosting the form as well as the server receiving the mail - I think this is mail.force9.net yet when I ping it I get no responseHuh
>
> If I work anything out I will let you know.
>
> --
> Regards
>
> Richard

N/A

RE: FormMail.pl - cannot get it to work

> Has anyone used the latest version of FormMail.pl from Matts Script Archive?
>
> The file is in the correct pace - but it doesn't seem to run - i intially got a "you dont have permission ..."
>
> So i went into @referrers and addd the server ie.
>
> 'cgi.force9.net'
>
> but still the same error.
>
> I'm not sure if i'm setting the permissions correctly. Using WS_FTP is go onto the file, right click and go to "CHMOD(Unix)" and make all of the sections owner, group and other "read, writre and execute" as i have done with another script which i am using which works fine. This one doesn't - can anyone see waht the problem is?
>
>


Is it just an email script that you want to work?

if so just make a php file and use the
mail($to,$subject,$msg,"From:me@me.com\r\n");

then you can customize it to do whatever you want to? Hope this helps....

Cheers.

--------
Chris.

N/A

FormMail.pl - cannot get it to work

If you get your formmail script from here http://nms-cgi.sourceforge.net/, it gives fault diagnosis when setting it up.

Mark
N/A

FormMail.pl - cannot get it to work

Make sure you uploaded as ascii otherwise it won't work.

martin
N/A

Re: FormMail.pl - cannot get it to work

Quote
So i went into @referrers and addd the server ie.

'cgi.force9.net'


I think I have a similar perl script, although maybe not exactly the same one. For what it's worth my referers statement is as follows:

@referers = ('force9.co.uk','force9.net');

Doesn't Force9 offer a standard perl script for this purpose now? I suppose, by rights, we should all use that!
N/A

Re: FormMail.pl - cannot get it to work

Quote


They do but is is set up very basically, you have no control over the variables. If you want to send the email to someone outside of F9 for example, you are not allowed. Only email addies to F( and PN customers work.

Mark
N/A

FormMail.pl - cannot get it to work

If you want the F9 version to post to a non-F9 address, just set up an alias on your F9 account and use that in the script. The point the alias to any email address you like.
N/A

FormMail.pl - cannot get it to work

hi.. it took me ages to get this script to work! But for the @referers bit i simply but the address of the URL that was submitting the data to it

e.g the address i was sending from was www.unique.f9.co.uk/formsender.html, so i put the unique.f9.co.uk domain as the referer, like so:

@referers = ('unique.f9.co.uk');

hope this helps!

Andy Burton