cancel
Showing results for 
Search instead for 
Did you mean: 

Can't delete a file that I own!

N/A

Can't delete a file that I own!

I was trying to delete a wiki board that I had installed to see what it was like. It turned out to be rubbish, so decided to delete it. Initially I ran
rm -R wiki
but afterwards it complained that the directory was not empty. I then attempted to remove the directory by hand....

eaglecentre@cgi05 wiki $ rm .nfsA1f2b4.4
eaglecentre@cgi05 wiki $ ls
eaglecentre@cgi05 wiki $ ls -a
. .. .nfsA1f2b4.4
eaglecentre@cgi05 wiki $ ls -lart
total 16
drwx---r-x 9 eaglecentre cgishell 4096 Jul 3 13:14 ..
-rwx------ 1 eaglecentre cgishell 4452 Jul 3 13:48 .nfsA1f2b4.4
drwx---r-x 2 eaglecentre cgishell 4096 Jul 3 14:59 .


As you can see I've changed the permissions on the file so that no else can edit it, and I clearly own the file YET when I try and rm the file it doesn't disappear....
:shock:
When I wrote my own file system... my rm worked!! ;-)

PS. If anyone is getting slightly frustrated by the way in which the connection drops after a quite short period of inactivity, then use putty (google for it), and turn on 'keep connection alive'.
1 REPLY
N/A

This is just a thought??

Hi eaglecentre,

This is just a thought that I had after reading your posting and I dont know if this IS correct? but perhaps the reason you are unable to delete your own file is that the file in question might still be in use by some other unknown or otherwise invisible process. Perhaps the server & OS still have a hold of this file in memory or the OS is still threaded to it in some way.

I've seen very similar things happen in windowsNT many times and only untill the underlying system process is killed or released then it will remain impossible to delete this file?? Dun know what you think? and dont know how your going to get the file released (usually requires a reboot of the system or a techie too do it for you?)

Ivan Cool