cancel
Showing results for 
Search instead for 
Did you mean: 

Ghost calls

PJtaste
Browser
Posts: 2
Registered: ‎19-12-2017

Ghost calls

Recently switching to plusnet business super fast fibre we have started to experience continual ghost calls to one or more of our phone extensions. We run a VoIP system via yay.com and apparently this can happen. The calls appear to have originated from one of our own extensions but of course if answered no one is there! Yay’s help info says this can happen but are not so helpful on how to cure.
So far we have managed to prevent to one extension as it is a Grandstream unit for which we found some instructions to block. Yay also suggest changing the default SIP port.
Has anyone experience of this, advice on whether it is sensible to change the SIP port or any other suggestions?
Thanks
Peter
2 REPLIES 2
wisty
Pro
Posts: 591
Thanks: 112
Fixes: 8
Registered: ‎30-07-2007

Re: Ghost calls

I assume when you say  "...one of your own extensions" that the handset is showing 100, 1001 or something similar.

These are direct IP calls. I got these a few years ago on my SIPgate VOIP account.

Sipgate gave me a pointer to their help page on this problem. they cover a number of different IP phones. It may be of use

http://basichelp.sipgate.co.uk/hc/en-gb/articles/204424011-Receiving-Direct-IP-SPIT-Calls-from-numbe...

In my case I changed the ATA settings to disallow direct IP calls, and (my "phone" is an OBI ATA) used its facility to only allow inbound calls from the  VOIP providers ID. I also changed the SIP port from the default.

That solved the problem completely for me.

I suspect it will depend on the phones you have on the system. Clearly the Grandstream has the facility. What are the others?

 

 

PJtaste
Browser
Posts: 2
Registered: ‎19-12-2017

Re: Ghost calls

Many thanks for your help.  We have been able to change the settings in the Grandstream DP715 following advice as follows: (https://forums.grandstream.com/forums/index.php?topic=27825.0😞

"The calls are likely coming from network traffic being translated as a call, as a result you won't see anything in the phone systems log.
If the call is coming from the internet it would have to pass through the phone system to get to your cordless phone and thus would be in the log.

The only two ways I know of to fix it is:
Option 1
The SIP Security settings: (I use all 3 but I know not all 3 are required)(not the one you already tried)
1) Validate Incoming Messages: Yes
2) Check SIP User ID for Incoming INVITE: Yes
3) Authenticate Incoming INVITE: Yes

Option 2
Put the phones in a separate vlan from the regular network traffic."

Moderator's note by Mike (Mav): Post released from Spam Filter.