cancel
Showing results for 
Search instead for 
Did you mean: 

XBMC remote connectivity

inuit
Newbie
Posts: 5
Registered: 08-01-2014

XBMC remote connectivity

Hello one and all.
I have a Technicolor 582n router and I have setup XBMC on a machine in my house and have setup the IP to always be the same. I have setup a program on the router with access to port 8080 and 9777, then assigned it to that machine.
When trying to connect to it remotely from any mobile device I have no joy at all. I tried a telnet session and it could not find port 8080 or 9777, but a ping to the local IP was successful.
Has anyone had any joy with this or can point out if I am doing something very stupid?
Many thanks
21 REPLIES
Community Veteran
Posts: 6,773
Thanks: 257
Fixes: 20
Registered: 16-02-2009

Re: XBMC remote connectivity

Did you setup the port forwarding correctly on the router?
You need to set the 2 ports to forward to the ip of the xbmc "server".
Also can you connect locally to make sure the xbmc is working?
inuit
Newbie
Posts: 5
Registered: 08-01-2014

Re: XBMC remote connectivity

I'm pretty sure port forwarding is setup correctly. I have ports pointing at the IP for the XBMC server. Is there a way I can check this or a tutorial or something, I haven't seen one?
Do you mean connect to the port through browser on the same machine that XBMC is running on?
Community Veteran
Posts: 3,274
Thanks: 339
Fixes: 12
Registered: 24-10-2013

Re: XBMC remote connectivity

so when you are attempting to connect to it remotely on your mobile device (ie when out of the house etc), you are using your external IP address and not the internal IP address?
unless you have a static external IP address then your IP can and will change.
a service like DynDNS will get around the problem of changing IP addresses.
Community Veteran
Posts: 6,773
Thanks: 257
Fixes: 20
Registered: 16-02-2009

Re: XBMC remote connectivity

I meant connect to those ports from a device NOT the one running the app. That at least will verify you can connect to the xbmc.
As chenks76 said make sure you are connecting to your PUBLIC ip not the 192. address when you are out and about. Also if you don't have a static ip then you will need to setup a redirector using Dyndns or similar.
inuit
Newbie
Posts: 5
Registered: 08-01-2014

Re: XBMC remote connectivity

Trying to connect to it from my nexus in the house using the 192 address, that is what I am having difficulty doing and cannot connect to XBMC. I can ping the 192 address I cannot telnet the ports it.
Community Veteran
Posts: 6,773
Thanks: 257
Fixes: 20
Registered: 16-02-2009

Re: XBMC remote connectivity

What is the xbmc running on? Any firewalls in the way?
If you cannot connect locally then you will not be able to connect remotely either.
inuit
Newbie
Posts: 5
Registered: 08-01-2014

Re: XBMC remote connectivity

It's running on Vista the only thing firewall wise is windows firewall, but XBMC has permission. I think I confused it when I said remotely, I meant remote app for my nexus
Community Veteran
Posts: 3,274
Thanks: 339
Fixes: 12
Registered: 24-10-2013

Re: XBMC remote connectivity

if you are trying to connect via a browser, are you putting the port at the end of the URL?
eg http://192.168.1.21:8080
Community Veteran
Posts: 6,773
Thanks: 257
Fixes: 20
Registered: 16-02-2009

Re: XBMC remote connectivity

Which xbmc remote app, there are several. Check all the settings. On the pc TURN OFF the firewall/AV for testing.
ON the app, check it has the correct ip 192. for local or your EXTERNAL ip if you want to use it away from the house.
For testing:
AV/Firewall OFF on pc
xbmc app set to 192. address and 8080 as the port unless you have changed it on the xbmc server CHECK.
If you cannot connect locally then you need to check the xbmc setting on the pc & the tablet. Until you have this done then we cannot go further.
I have the Yatse app installed on my tablet.
LukeAger
Grafter
Posts: 121
Thanks: 5
Registered: 15-02-2012

Re: XBMC remote connectivity

not sure if this will work but i have xbmc running on a few devices, an ATV2 and a few Minix G4 and x5 mini android pc's
In both cases i use mobile devices apps as remotes.
With Rowmote for Iphone (controlling apple tv) I just entered the 192.168.#.# address of the apple tv.. I did not need to enter the port number. Im also surprised you had to mess with any ports in the router for an internal network issue.
IMO the tg582n is usually ok with that sort of use.
VileReynard
Seasoned Pro
Posts: 10,823
Thanks: 245
Fixes: 10
Registered: 01-09-2007

Re: XBMC remote connectivity

Have you tried telnetting from the XBMC PC to itself?
Note that the default telnet port is 23.
If you don't have a telnet server running, then it won't respond to telnet requests.
A bit tricky the first time, but it would be worth installing SSH on each machine (if available).
You could then control a machine remotely and run backups etc...

Community Veteran
Posts: 6,773
Thanks: 257
Fixes: 20
Registered: 16-02-2009

Re: XBMC remote connectivity

I think we need to clarify :-
Quote from: inuit
When trying to connect to it remotely from any mobile device I have no joy at all. I tried a telnet session and it could not find port 8080 or 9777, but a ping to the local IP was successful.

REMOTELY as in from a unit inside the house or from the internet?
If inside the house then changes to the router is of no use. It is all done on the local devices. I would still say disable all AV/FW and try again.
inuit
Newbie
Posts: 5
Registered: 08-01-2014

Re: XBMC remote connectivity

To clarify this is in the house trying to connect my Nexus 7 using Yatse, to a windows laptop with XBMC on it. I have disabled the firewall and AV and still no joy
Community Veteran
Posts: 6,773
Thanks: 257
Fixes: 20
Registered: 16-02-2009

Re: XBMC remote connectivity

OK so if it is locally then the router port forwarding is a red herring.
All the connections are on the local lan so it is down to the settings on the xbmc and tablet.
Can you connect using a web browser on the laptop, and you HAVE checked the allow remote connections in the xbmc settings haven't you?