cancel
Showing results for 
Search instead for 
Did you mean: 

Worst broadband i've ever had...

gennylou
Newbie
Posts: 2
Registered: 22-07-2012

Worst broadband i've ever had...

We changed from AOL when we moved house and boy do i regret it. We are meant to have fibre optic broadband and it's slower than when we were with AOL. I have just done a few speed tests as it's taking so long for pages to load, it feels like we are on dial up. The speed is struggling to get to 1.0 mbps it's ridiculous! Our broadband has gone down quite a few times since we have went with plusnet and occasionally we have to completely reset the router as the internet goes off and all we get is ''No internet access''
Anyone have any ideas why my internet is so slow?!!...I wish i could cancel with these and go with a different provider.
2 REPLIES
Community Veteran
Posts: 19,100
Thanks: 437
Fixes: 21
Registered: 31-08-2007

Re: Worst broadband i've ever had...

Sounds like you may have some sort of problem with your line, which you would just take with you to another provider. It's the same wires to the exchange/cab whoever you are with.
It's not clear if you already have fibre, in which case with that speed you must raise a fault as something is seriously wrong.
If you are waiting for fibre and have standard ADSL then it will be affected (as will any broadband) by line problems,. so the Exchange DLM (Dynamic Line Managment) will ultimately slow your speed in an attempt to stabilise your connection. This is an automatic process over which no ISP has direct control.
The best place to start is have a listen to your phone line, do you hear any crackling or other noise when using the phone, or have any problems making outgoing or incoming calls? This would suggest a probable line problem - who do you pay line rental to?
Do you have any fixed extension sockets and wiring? Are you using any extension leads? Do you have a Master Socket that looks similar to the one on the Left or right.
Is every phone, sky box or any thing else plugged in by Microfilters look that like this
Plusnet Alumni (retired) chrispurvey
Plusnet Alumni (retired)
Posts: 5,369
Fixes: 1
Registered: 13-07-2012

Re: Worst broadband i've ever had...

Hi gennylou,
There is certainly an issue if you are only achieving those speeds, I've checked your line and can see nothing wrong with the profile of your connection. I would advise to raise a fault at http://faults.plus.net, this way we can run tests on your line and help sort your speed issue out. As Anotherone said in the previous post, if it is a line problem then this would carry over to another provider. Raising a fault will be the quickest way to resolve it.
If you need any further support please let me know.
Chris