cancel
Showing results for 
Search instead for 
Did you mean: 

WiFi on tg582n router

71delboy
Newbie
Posts: 7
Registered: ‎07-11-2014

WiFi on tg582n router

I moved to PlusNet broadband last month from Sky which had worked well for 12 months, but became too expensive to continue.  I have a Dell computer wired to the router and a Lenovo g505 laptop and Nexus7 tablet both using the wifi.
My problem has been with the laptop.  Since the switchover most browsing sessions (IE 11 on Windows 8.1) result in a 'This page can't be displayed' message.  Sometimes a second attempt will be successful but often the same error appears. Probably 80 - 90% of sessions end this way.
The tablet (Chrome browser on Android) runs perfectly as does the desktop (IE 11 on Windows 7).
Previously, on Sky, both wifi and the Ethernet connection worked fine, particularly the laptop
I have discussed this with PlusNet support who had no constructive advice ( change channel on the routerHuh) and more recently talked to Lenovo support who suggested  returning it to them for repair/replacement.  I am a bit wary of doing this as they retain the right to charge for their time if they find no fault.
Does any of this make any sense?
Delboy
5 REPLIES
Community Veteran
Posts: 5,187
Thanks: 486
Fixes: 21
Registered: ‎10-06-2010

Re: WiFi on tg582n router

It might be the same problem as this thread, if so one way to workaround that problem is to set some DNS servers on the laptop itself.
Alternatively, see if the laptop works using an Ethernet connection instead of wifi.
Superuser
Superuser
Posts: 12,973
Thanks: 4,268
Fixes: 26
Registered: ‎22-08-2007

Re: WiFi on tg582n router

Hi 71delboy,
Ejs has already provided a link to my (long) thread - the useful conclusions are down the back end.
This looks as though a number of not quite ideal issues have come together to cause an almighty head ache.  I do not believe wifi plays a part in the problem.
I found that changing the DNS settings to use Google's DNS (8.8.8.8 and 4.4.4.4) virtually eliminated the problem, albeit does not fix the causes which are how Win8 manages it's name resolution caches and how the TG582n behaves when it does not get a DNS query response.
71delboy
Newbie
Posts: 7
Registered: ‎07-11-2014

Re: WiFi on tg582n router


Hi Townman
Thanks for the advice.  Used the Google DNS for the laptop and initial results are improved.
Is this likely to be the final solution?  I have read numerous posts where the TG582n is blamed for the way it works with Windows 8.1, but no one seems to be in any hurry to investigate this.
What do you think?
delboy
Superuser
Superuser
Posts: 12,973
Thanks: 4,268
Fixes: 26
Registered: ‎22-08-2007

Re: WiFi on tg582n router

It is on someone's radar.
Every element of the solution space plays a part in the blame game.  Win8 makes the matters worse by the way it manages DNS caches and that it pre-fetches DNS resolutions for every link on a web page - even before it is know if the user wants to follow a link.  This has to contribute a massively increased load on DNS services.
The fact that the TG router queries both primary and secondary DNS at the same time, generates nearly 50% wasted effort as in most cases the resolution from one DNS makes the results from the other nugatory.
The when the TG receives no response, it (in correctable I would argue) throws a spoofed (useless) IP address at the client, which it then uses steadfastly.
I am hope that the PN products guys will get an angle grinder on the issue.  Fixing this could deliver a marked improvement in perceived stability and performance.
Community Veteran
Posts: 5,187
Thanks: 486
Fixes: 21
Registered: ‎10-06-2010

Re: WiFi on tg582n router

I'm not sure why web browser DNS pre-fetching has been implicated with this problem. According to this page, Firefox has been doing DNS pre-fetching for approx. the past 6 years (since version 3.5).
Likewise, I've not seen what exactly Windows 8.1 does differently to provoke the issue. If the DNS cache was actually improved, then that would mean less DNS queries being sent to the router.