Showing results for 
Search instead for 
Do you mean 

Very strange oscillating Speedtest readings

Highlighted
Rising Star
Posts: 5,076
Thanks: 12
Fixes: 1
Registered: ‎19-06-2011

Very strange oscillating Speedtest readings

My usual "straight" speedtest measurement this morning 01:00 am is instead oscillating between a couple of readings, approx one per second.
Just look at the green speed readings graph, just below 8.99, a series of peaks and troughs, which is usually a straightish line.
And my speed has dropped from a usual 16.6mb/s to a lower 9.25mb/s
Same result when repeated several times
The needle can be seen very visibly moving up and down.
Almost as if some sort of data chopping compression is in effect.


10 minutes later, back to normal, nice straight line.


Then after a few "normal" results, back to oscillating !!


Throughout, the Upload speed appeared to be non-oscillating.
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Back to normal this morning.

And on conclusion of test, the download speed is again a number, not the peaks and troughs graph with no number.


Oh no it's not 3½ hours later, I promise you, nothing else is downloading at the same time...

24 REPLIES
Grafter
Posts: 9,786
Registered: ‎16-06-2010

Re: Very strange oscillating Speedtest readings

HI PlusComUK,
That is strange. Wonder if anyone else has ever seen that before.
Jojo Smiley
Rising Star
Posts: 809
Thanks: 10
Registered: ‎07-02-2012

Re: Very strange oscillating Speedtest readings

Re the result being a number not a graph, that is probably because you moved the cursor/carat away from that position on the screen. Move it back and the graph replaces the number Smiley.
Rising Star
Posts: 5,076
Thanks: 12
Fixes: 1
Registered: ‎19-06-2011

Re: Very strange oscillating Speedtest readings

Nope sorry, tried that, graph remains, no number ever having appeared, on completion of test, as per normal.

I can't show you it with the cursor, screen grab doesn't show cursor, but it is there !
Tried a different tack, I recorded a screen movie, then grabbed a frame from that, which shows the cursor.


However, as you state, when the numbers appear upon completion, the cursor moving does show a graph, or numbers !!
Community Veteran
Posts: 6,284
Thanks: 78
Fixes: 3
Registered: ‎08-01-2008

Re: Very strange oscillating Speedtest readings

I've had a similar effect (though not so pronounced) when the PlusNet line profile ('Current Line Speed') was throttling things a bit, I'd guess it could have something to do with line profile or traffic mangenment systems as these seem to 'bounce the speed down' every time it hits whatever limit is in place.
Call me 'w23'
At any given moment in the universe many things happen. Coincidence is a matter of how close these events are in space, time and relationship.
Opinions expressed in forum posts are those of the poster, others may have different views.
Rising Star
Posts: 5,076
Thanks: 12
Fixes: 1
Registered: ‎19-06-2011

Re: Very strange oscillating Speedtest readings

Personally I am nowhere near any download limit, and my speed is usually around 16.6mb/s, but it sometimes goes up to 19.98mb/s, on an upto 20mb/s service.
Community Veteran
Posts: 1,392
Registered: ‎29-01-2009

Re: Very strange oscillating Speedtest readings

I saw exactly this case of oscillating last night - also to the Leeds server, which was chosen as the "recommended" server due to a low ping value of 15ms. When it oscillated, it also gave an overall speed reading lower than normal: 32Mb rather than 37.5Mb
The other servers I choose manually (London or Newbury) worked just fine - so I put it down to something funny with the Leeds server.
BTW - I could have sworn I answered this post last night!
Plusnet Customer
Using FTTC since 2011. Currently on 80/20 Unlimited Fibre Extra.
Grafter
Posts: 9,786
Registered: ‎16-06-2010

Re: Very strange oscillating Speedtest readings

Quote from: WWWombat
BTW - I could have sworn I answered this post last night!

You're obviously dreaming about these forums now, but don't worry, I do it all the time! Smiley
Rising Star
Posts: 5,076
Thanks: 12
Fixes: 1
Registered: ‎19-06-2011

Re: Very strange oscillating Speedtest readings

Quote from: WWWombat
I saw exactly this case of oscillating last night - also to the Leeds server, which was chosen as the "recommended" server due to a low ping value of 15ms. When it oscillated, it also gave an overall speed reading lower than normal: 32Mb rather than 37.5Mb
The other servers I choose manually (London or Newbury) worked just fine - so I put it down to something funny with the Leeds server.

Thanks for pointing that out, if it happens again I'll choose another server.
Rising Star
Posts: 5,076
Thanks: 12
Fixes: 1
Registered: ‎19-06-2011

Re: Very strange oscillating Speedtest readings

It's LEEDS !!!

Birmingham is fine.


Well spotted WWWombat, it didn't seem to affect my PN BB, presumably it is routed differently to Speedtest.

These two tests done approx 1pm today, Wednesday
Jo, will you be reporting it as a fault ?
Grafter
Posts: 48
Registered: ‎22-10-2010

Re: Very strange oscillating Speedtest readings

So there I was catching up with some iPlayer this morning, and while the audio was fine, the picture was freezing sometimes as often as every 5 seconds or less. So I did the usual tidy up and defrag, tried again, still the same problem.
Guess what?
Speedtest takes me to Leeds based on ping, and I'm getting identical results to the OP.
Grafter
Posts: 131
Thanks: 1
Registered: ‎06-07-2007

Re: Very strange oscillating Speedtest readings

I am getting the same on mybroadbandspeed tester. Wild swings going on with nothing being downloaded but the test. I am on gateway pcl-ag04.This is located in City Lifeline House. Been happening since yesterday. Loads of buffering on sky or cutting out.  At times cannot get to sites like BBC then can.
Rising Star
Posts: 5,076
Thanks: 12
Fixes: 1
Registered: ‎19-06-2011

Re: Very strange oscillating Speedtest readings

Quote from: brokenthumb
So there I was catching up with some iPlayer this morning, and while the audio was fine, the picture was freezing sometimes as often as every 5 seconds or less. So I did the usual tidy up and defrag, tried again, still the same problem.
Guess what?
Speedtest takes me to Leeds based on ping, and I'm getting identical results to the OP.

Whilst all the oscillating was going on for me, I did a BBC iPlayer speedtest, no problems.
Results pretty much as always.
http://www.bbc.co.uk/iplayer/diagnostics#results
Presumably a different route.
Results were similar to these, just done now.

Community Veteran
Posts: 1,392
Registered: ‎29-01-2009

Re: Very strange oscillating Speedtest readings

@PluscomUK - Mere luck.... Because PN's pipes terminate in London, I assume the fastest testers are in the south-East too - so usually force one of those testers. However, I also occasionally hit the "recommended" button to see what server it chooses, and compare the results. Last night, it happened to pick Leeds (with some very good ping values) - and it still picks it (only 13ms pings), but it still oscillates.
Apropos of nothing, I notice that there is a new IP-peering exchange based in Leeds: http://ixleeds.net/. I wonder if this has anything to do with it.
@brokenthumb - I'm not sure the two things are linked either. My iPlayer test results were 30/10/20/20, average 17. More importantly, they didn't seem to oscillate either.
Plusnet Customer
Using FTTC since 2011. Currently on 80/20 Unlimited Fibre Extra.
Grafter
Posts: 60
Registered: ‎31-07-2007

Re: Very strange oscillating Speedtest readings

Hi All,
Just thought I'd add my pennor'th.
I'm on City Lifeline pcl-ag03 and am also getting wide swings of speed. Also getting messages form Microsoft Essentials saying unable to update antivirus etc due to "internet connection issues."
Looks as though somthings adrift !!
Perhaps someone could check to see  if the plug is in properly !!!