cancel
Showing results for 
Search instead for 
Did you mean: 

Very slow internet response times. Packet loss?

HojoNorem
Dabbler
Posts: 14
Registered: 08-04-2014

Very slow internet response times. Packet loss?


I've been getting what looks like so much packet loss recently that my line is acting like I'm back on dial-up.
AR7 DSL Modem Statistics:
--------------------------------
[DSL Modem Stats]
US Connection Rate: 448 DS Connection Rate: 6144
DS Line Attenuation: 46 DS Margin: 5
US Line Attenuation: 26 US Margin: 22
US Payload : 72499824 DS Payload: 996304464
US Superframe Cnt : 180915 DS Superframe Cnt: 180915
US Transmit Power : 12 DS Transmit Power: 5
LOS errors: 0 SEF errors: 0
Errored Seconds: 0 Severely Err Secs: 0
Frame mode: 3 Max Frame mode: 0
Trained Path: 1 US Peak Cell Rate: 1056
Trained Mode: 3 Selected Mode: 1
ATUC Vendor Code: 54535443 ATUC Revision: 2
Hybrid Selected: 1 Trellis: 1
Showtime Count: 1 DS Max Attainable Bit Rate: 6144 kbps
BitSwap: 1 US Max Attainable Bit Rate: n/a
Annex: AnxA psd_mask_qualifier: 0x0000
ATUC ghsVid:  b5 00 54 53 54 43 00 00
T1413Vid: 00 00 T1413Rev: 00 VendorRev: 00
ATUR ghsVid:  b5 00 54 53 54 43 00 00
T1413Vid: 00 00 T1413Rev: 00 VendorRev: 00
[Upstream (TX) Interleave path]
CRC: 0 FEC: 0 NCD: 0
LCD: 0 HEC: 0
[Downstream (RX) Interleave path]
CRC: 7 FEC: 3131 NCD: 0
LCD: 0 HEC: 0
[Upstream (TX) Fast path]
CRC: 0 FEC: 0 NCD: 1
LCD: 0 HEC: 0
[Downstream (RX) Fast path]
CRC: 0 FEC: 0 NCD: 0
LCD: 0 HEC: 0
[ATM Stats]
[Upstream/TX]
Good Cell Cnt: 1510413
Idle Cell Cnt: 1739230

[Downstream/RX)]
Good Cell Cnt: 20756343
Idle Cell Cnt: 23809980
Bad Hec Cell Cnt: 83
Overflow Dropped Cell Cnt: 0
[SAR AAL5 Stats]
Tx PDU's: 690129
Rx PDU's: 684012
Tx Total Bytes: 37060242
Rx Total Bytes: 968351551
Tx Total Error Counts: 0
Rx Total Error Counts: 10

[OAM Stats]
Near End F5 Loop Back Count: 0
Near End F4 Loop Back Count: 0
Far End F5 Loop Back Count: 0
Far End F4 Loop Back Count: 0
SAR OAM Ping Response Drop Count=15

This after an hour on my backup Routertech'd DLINK router, with the wind blowing my drop cable all over the place.  The sync speed is faster with far less reported errors than my DLINK DSL-320B modem which I usually have feeding a OpenWRT box.
The packet loss got real bad at about 11PM last night, as this TBB BQM graph shows:

60 seconds of pinging google.co.uk directly from my router console:
--- www.google.co.uk ping statistics ---
61 packets transmitted, 37 packets received, 39% packet loss
round-trip min/avg/max = 30.000/33.243/90.000 ms

Excluding plugging into the test socket (physically impossible at this time) I have done everything I can think of at my end.  ALL the cabling running from the master socket to the modem / router is cat5e and above... I guess no more then 10 metres worth.
4 REPLIES
Plusnet Help Team
Plusnet Help Team
Posts: 1,953
Thanks: 22
Fixes: 5
Registered: 24-07-2014

Re: Very slow internet response times. Packet loss?

Please raise this to us at faults.plus.net so we can take a look in detail for you. Thanks.
If this post resolved your issue please click the 'This fixed my problem' button
 Tony T
 Plusnet Help Team
HojoNorem
Dabbler
Posts: 14
Registered: 08-04-2014

Re: Very slow internet response times. Packet loss?

Fault raised at roughly 12:30 yesterday.  No further communications received yet.  Saw something strange on my graph though:

At a time shortly after me reporting the fault, the packet loss vanishes.  The hike in latency lines up with my brother removing the limiter on his Steam downloads.  The resultant packet loss being reported I see as being normal because at the same time that his download was (reportedly) passing the 600KB/s mark we were still able to have a clear skype conversation.  When I got home from work at about 5:20PM I found my web browsing to be responsive even with Steam at full tilt.
As you can see, at about half six the packet loss retuned and total throughput dropped to the floor.
Here's my live graph:

Out of curiosity, if the packet loss was due to my ADSL connection, I would also see the error counters on my modem stats shoot up, right?
RPMozley
Aspiring Pro
Posts: 1,118
Thanks: 30
Fixes: 5
Registered: 04-11-2011

Re: Very slow internet response times. Packet loss?

Yes, that is correct. That graph almost certainly points towards exchange congestion.
That's RPM to you!!
HojoNorem
Dabbler
Posts: 14
Registered: 08-04-2014

Re: Very slow internet response times. Packet loss?

Yesterday's graph:

The packet loss grew until about 7PM at which point it just vanishes, barring the odd spike here an there, at least one of those was my router re-syncing at a faster speed.
Pinging my current gateway from the router console for an hour at 11AM today:

--- 195.166.128.188 ping statistics ---
3600 packets transmitted, 3471 packets received, 3% packet loss
round-trip min/avg/max = 30.000/36.888/730.000 ms

Current modem stats (18hr 13min since last resync):
AR7 DSL Modem Statistics:
--------------------------------
[DSL Modem Stats]
US Connection Rate: 448 DS Connection Rate: 6048
DS Line Attenuation: 46 DS Margin: 9
US Line Attenuation: 26 US Margin: 23
US Payload : 258949776 DS Payload: 1769051280
US Superframe Cnt : 3843429 DS Superframe Cnt: 3843429
US Transmit Power : 12 DS Transmit Power: 5
LOS errors: 0 SEF errors: 0
Errored Seconds: 0 Severely Err Secs: 0
Frame mode: 3 Max Frame mode: 0
Trained Path: 1 US Peak Cell Rate: 1056
Trained Mode: 3 Selected Mode: 1
ATUC Vendor Code: 54535443 ATUC Revision: 2
Hybrid Selected: 1 Trellis: 1
Showtime Count: 6 DS Max Attainable Bit Rate: 6048 kbps
BitSwap: 1 US Max Attainable Bit Rate: n/a
Annex: AnxA psd_mask_qualifier: 0x0000
ATUC ghsVid:  b5 00 54 53 54 43 00 00
T1413Vid: 00 00 T1413Rev: 00 VendorRev: 00
ATUR ghsVid:  b5 00 54 53 54 43 00 00
T1413Vid: 00 00 T1413Rev: 00 VendorRev: 00
[Upstream (TX) Interleave path]
CRC: 3 FEC: 408 NCD: 0
LCD: 0 HEC: 0
[Downstream (RX) Interleave path]
CRC: 142 FEC: 54130 NCD: 0
LCD: 0 HEC: 0
[Upstream (TX) Fast path]
CRC: 0 FEC: 0 NCD: 1
LCD: 0 HEC: 0
[Downstream (RX) Fast path]
CRC: 0 FEC: 0 NCD: 0
LCD: 0 HEC: 0
[ATM Stats]
[Upstream/TX]
Good Cell Cnt: 5394787
Idle Cell Cnt: 63641900

[Downstream/RX)]
Good Cell Cnt: 36855235
Idle Cell Cnt: 895137678
Bad Hec Cell Cnt: 2236
Overflow Dropped Cell Cnt: 1
[SAR AAL5 Stats]
Tx PDU's: 20604350
Rx PDU's: 22097047
Tx Total Bytes: 1437622877
Rx Total Bytes: 554244700
Tx Total Error Counts: 0
Rx Total Error Counts: 508

[OAM Stats]
Near End F5 Loop Back Count: 0
Near End F4 Loop Back Count: 0
Far End F5 Loop Back Count: 0
Far End F4 Loop Back Count: 0
SAR OAM Ping Response Drop Count=15

The connection is behaving itself ATM, I'm holding my breath to see what happens at the weekend.  I'm thinking exchange congestion myself, still no official word from PN yet tho.