cancel
Showing results for 
Search instead for 
Did you mean: 

Upstream lower than reported

FIXED
mrdubya
Hooked
Posts: 6
Thanks: 1
Fixes: 1
Registered: ‎29-10-2020

Upstream lower than reported

Hi,

My ADSL2 connection has been stable for the last week (no disconnects, yay!) with reported connection rates of 12.5Mb DS/1.1Mb US but in the last 24 hours throughput has become ... erratic. Latency varies over time (ping times normally about 15ms go up to between 300ms and 1000ms), download rates go down and back up to the link rate.

But the real killer is the achievable upstream rate doesn't exceed 300Kb - about a third of the connected US rate. The thinkbroadband speed test reports 0.1Mb to 0.2Mb when it doesn't fail and report an upload error.

This sounds like a routing issue. I have tried reconnecting to the plusnet network keeping the ADSL connection live (separate modem and router) and restarting the ADSL connection. Apart from usual slight variation in DS and US connection rates, the variable throughput and reduced achievable US rate hasn't changed.

Anyone else seen this before? Is it a case of bouncing the ADSL connection until it works as expected? Raise a ticket?

TIA

Mike

Mike
4 REPLIES 4
mrdubya
Hooked
Posts: 6
Thanks: 1
Fixes: 1
Registered: ‎29-10-2020

Re: Upstream lower than reported

24 hours on, no change.

To round out the info, this is testing on a wired network connection, not wifi. I can monitor the transmit rate on the router and see it does not exceed 300 Kbps during the thinkbroadband test run.

Here is the modem's current connection status after about 2 days since the last reconnect:

  --------------------------- ATU-R Info (hw: annex A, f/w: annex A) -----------
   Running Mode            : ADSL2+ Annex A       State                : SHOWTIME
   DS Actual Rate          : 12862000 bps   US Actual Rate       :  1099000 bps
   DS Attainable Rate      : 12936000 bps   US Attainable Rate   :  1092000 bps
   DS Path Mode            :        Fast    US Path Mode         :        Fast 
   DS Interleave Depth     :        1       US Interleave Depth  :        1 
   NE Current Attenuation  :       34 dB    Cur SNR Margin       :        7  dB
   DS actual PSD           :    19. 8 dB    US actual PSD        :    12. 4  dB
   NE Rcvd Cells           : 346291378       NE Xmitted Cells     : 13537385
   NE CRC Count            :     4010       FE CRC Count         :        0
   NE ES Count             :     2427       FE  ES Count         :        0
   Xdsl Reset Times        :        0       Xdsl Link  Times     :        5
   ITU Version[0]          : fe004452       ITU Version[1]       : 41590000
   ADSL Firmware Version   : 05-07-02-08-00-01 
   Power Management Mode   : DSL_G997_PMS_L0 
   Test Mode               : DISABLE 
  -------------------------------- ATU-C Info ---------------------------------
   Far Current Attenuation :       18 dB    Far SNR Margin       :        6  dB
   CO ITU Version[0]       : b5004946       CO ITU Version[1]    : 544e827a
   DSLAM CHIPSET VENDOR    : < IFTN >

Note US actual rate is 1.09Mbps while speed tests are reporting maximum rates of 0.2Mbps.

Ping times have improved but need a few to warm up the routing - starting at a few 100ms before dropping to a more consistent 14ms, but hey, Sunday mornings Wink

Mike
Gandalf
Community Gaffer
Community Gaffer
Posts: 26,594
Thanks: 10,330
Fixes: 1,602
Registered: ‎21-04-2017

Re: Upstream lower than reported

Hi Mike,

Our tests aren't showing any issues with the line, there's no congestion at the exchange either and there's nothing to suggest this is a routing issue. Can you try a different device and router if possible?

From 31st October 2022, I no longer have a regular presence here as I’ve moved on to a new role.
Anoush Mortazavi
Plusnet
mrdubya
Hooked
Posts: 6
Thanks: 1
Fixes: 1
Registered: ‎29-10-2020

Re: Upstream lower than reported

Hi,

FWIW the modem did a reconnect shortly after I posted, with slightly better upstream rate -

 --------------------------- ATU-R Info (hw: annex A, f/w: annex A) -----------                                                                                        
   Running Mode            : ADSL2+ Annex A       State                : SHOWTIME                                                                                       
   DS Actual Rate          : 12383000 bps   US Actual Rate       :  1111000 bps                                                                                         
   DS Attainable Rate      : 12892000 bps   US Attainable Rate   :  1124000 bps
   DS Path Mode            :        Fast    US Path Mode         :        Fast                                                                                          
   DS Interleave Depth     :        1       US Interleave Depth  :        1                                                                                             
   NE Current Attenuation  :       34 dB    Cur SNR Margin       :        9  dB                                                                                         
   DS actual PSD           :    19. 9 dB    US actual PSD        :    12. 4  dB
   NE Rcvd Cells           :     6876       NE Xmitted Cells     :     3785                                                                                             
   NE CRC Count            :        1       FE CRC Count         :        0
   NE ES Count             :        1       FE  ES Count         :        0
   Xdsl Reset Times        :        0       Xdsl Link  Times     :        6
   ITU Version[0]          : fe004452       ITU Version[1]       : 41590000
   ADSL Firmware Version   : 05-07-02-08-00-01           
   Power Management Mode   : DSL_G997_PMS_L0             
   Test Mode               : DISABLE                                                
  -------------------------------- ATU-C Info ---------------------------------
   Far Current Attenuation :       18 dB    Far SNR Margin       :        6  dB
   CO ITU Version[0]       : b5004946       CO ITU Version[1]    : 544e827a
   DSLAM CHIPSET VENDOR    : < IFTN >     

But the upload rate is capped out at ~0.2Mbps, thinkbroadband and dslreports speed tests, and file transfer to a remote machine.

I have used multiple devices from this end but I only have the one router.

Checking the modem connection log I did have a disconnection storm Monday 15th Feb around 8pm (20 minutes and 4 re-connection attempts before a good connection) with the first retrain settling at 576Kbps DS/288Kbps US.  Could this have caused an cap to be placed on the US connection somewhere?  The currently observed max upload data rates match the low US rate. I know that the link is otherwise quiet and not something taking up bandwidth - the observed rate flate line at the low rate seems show it is being limited and not from contention at my end.

FWIW my modem logs show only occasional US errors (1 or 2 an hour), and running ping does not report any lost packets, I have no reason to think the connection is having problems, just can't push packets through Sad

TIA

Mike
mrdubya
Hooked
Posts: 6
Thanks: 1
Fixes: 1
Registered: ‎29-10-2020

Re: Upstream lower than reported

Fix

Hi again,

I tried a few more speed test sites and apps and they were all fairly consistent at reporting a 0.2Mbps upload data rate. I went back over older speed tests to be sure I had previously had 1Mbps upload rates, and I had

I then tried the following things on the router:

  • turn off QoS
  • tweak data rates based on last reconnection
  • roll back router firmware 1 release and try with and with QoS
  • reapply latest firmware

None of these affected the reports upload rates, which then just leaves the modem.

I have a Draytek Vigor 130 modem so doesn't do much more than what comes out of the box. Confirmed I am running the latest BT firmware (instead of Kingston). As reported above a soft reboot didn't change the upload rate so that just left a hard reboot.

I turned the modem off and left it an hour so the exchange doesn't think it is a line fault. Turning the modem back on and the upload rate is now back at the connection rate at approx 1Mbps. The following are the new connection details:

  --------------------------- ATU-R Info (hw: annex A, f/w: annex A) -----------
   Running Mode            : ADSL2+ Annex A       State                : SHOWTIME
   DS Actual Rate          : 12858000 bps   US Actual Rate       :  1103000 bps
   DS Attainable Rate      : 12976000 bps   US Attainable Rate   :  1100000 bps
   DS Path Mode            :        Fast    US Path Mode         :        Fast 
   DS Interleave Depth     :        1       US Interleave Depth  :        1 
   NE Current Attenuation  :       34 dB    Cur SNR Margin       :        9  dB
   DS actual PSD           :    19. 9 dB    US actual PSD        :    12. 4  dB
   NE Rcvd Cells           :    50802       NE Xmitted Cells     :    55806
   NE CRC Count            :        6       FE CRC Count         :        0
   NE ES Count             :        5       FE  ES Count         :        0
   Xdsl Reset Times        :        0       Xdsl Link  Times     :        1
   ITU Version[0]          : fe004452       ITU Version[1]       : 41590000
   ADSL Firmware Version   : 05-07-02-08-00-01 
   Power Management Mode   : DSL_G997_PMS_L0 
   Test Mode               : DISABLE 
  -------------------------------- ATU-C Info ---------------------------------
   Far Current Attenuation :       18 dB    Far SNR Margin       :        5  dB
   CO ITU Version[0]       : b5004946       CO ITU Version[1]    : 544e827a
   DSLAM CHIPSET VENDOR    : < IFTN >

So it was either some issue in the modem from the disconnection storm 2 weeks ago that required a hard reset (not just a disconnect/reconnect) or an issue at the local exchange that the long disconnect time has resolved/worked around.

Anyway, issue is now resolved. Hopefully it doesn't happen again.

CIao

Mike