cancel
Showing results for 
Search instead for 
Did you mean: 

Upload speed slow after installing Win7Pro 64bit

TonyC
Grafter
Posts: 43
Registered: 15-02-2008

Upload speed slow after installing Win7Pro 64bit

Heres a question for you.
I just noticed that my upload speed seemed to be slower than normal, so went back through my speedtest logs.
I upgraded this PC from XP Pro, to Win7 Pro 64bit at the beginning on November. Prior to this, I was getting 8.2Mb/s upload. After the upgrade (which was a back to scratch clean install) my upload seems to be stuck at 5.9Mb/s - and I say stuck, because the needle fluctuates ever so slightly suggesting that it's being limited at 6Mb/s
BT is reporting a 10Mb upload cap, as it was before Nov. and I'm using the same router/config. This happened immediately when I switched to Win7
Has anyone had any experience of this, or any idea what might be causing it?
2 REPLIES
dfunked
Grafter
Posts: 181
Thanks: 5
Registered: 15-10-2011

Re: Upload speed slow after installing Win7Pro 64bit

Were the tests done using wired or wireless?
That does seem a little odd - what do your router stats show?
Bald_Eagle1
Grafter
Posts: 313
Registered: 24-06-2011

Re: Upload speed slow after installing Win7Pro 64bit

Win 7 is supposed to auto-detect the correct MTU settings etc. (I believe it is 1492 for FTTC connections)
Mine does, but it was pre-installed when I bought the PC.
As yours was an upgrade to Win 7, have the MTU settings stuck at the previous default?
I had to use a TCP Optimizer program to get higher speeds from an old XP machine as it was using the default 1500 for MTU.

Has your download speed increased at the expense of some upload speed?
That appeared to happen with the switch from the 8c profile to the 17a profile.
My switch was October & I believe everyone was switched by February.
Coincidence that your upload speed has reduced around the same time as the switching from 8c to 17a period?