cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to turn off UPnP

chrism6102
Newbie
Posts: 4
Registered: ‎13-05-2013

Unable to turn off UPnP

Hi guys,
I've been trying to disable UPnP on my Thompson TG585 v7 router so that I can play Battlefield 3 without constant disconnects that seem to plague the game if UPnP is on.
I'm able to access the gateway and uncheck the box for 'use UPnP'.
However, a few minutes later the router resets itself ( I lose internet connection for a few minutes) and when it comes back online UPnP is enabled once more!
I've tried this several times and the same thing keeps happening, can anyone advise me on how to disable UPnP and keep it disabled, and what I might be doing wrong.
Many thanks.
8 REPLIES
All4One
Grafter
Posts: 289
Registered: ‎17-03-2013

Re: Unable to turn off UPnP

Isn't the TG585v7 fairly old now? Thought about upgrading to a more advanced router for things like this?
chrism6102
Newbie
Posts: 4
Registered: ‎13-05-2013

Re: Unable to turn off UPnP

It was given to us by plusnet when we signed up last year, I'm hoping its not THAT out of date
All4One
Grafter
Posts: 289
Registered: ‎17-03-2013

Re: Unable to turn off UPnP

Oh, just googled it, and realised that was the one I received from my Irish provider early last year so mustn't be old. Never had a problem with it, but unsure of the re-enabling of itself :S
Edit: Does this help:
Community Veteran
Posts: 19,102
Thanks: 443
Fixes: 21
Registered: ‎31-08-2007

Re: Unable to turn off UPnP

Definitely a v7 and not a v8?
chrism6102
Newbie
Posts: 4
Registered: ‎13-05-2013

Re: Unable to turn off UPnP

Yes its definitely a V7, and All4One thank you but I already tried the fix on that video but it didn't help. Playing Battlefield at a friends house I never have any issues so I'm 90% sure its a router problem and the known UPnP issue seems to fit the bill.
Just need to figure out how to keep it disabled  Tongue
Edit: To clarify if I try the process laid out on the video, after I uncheck the UPnP box and hit apply, the page refreshes (theres no loading bar like the guy on the video had) and UPnP now shows as disabled. Then approx 2 mins later the router resets and UPnP now displays as enabled.
Superuser
Superuser
Posts: 6,807
Thanks: 873
Fixes: 56
Registered: ‎30-07-2007

Re: Unable to turn off UPnP

Two things to try :-
If you don't have the latest f/w ( see here http://community.plus.net/library/hardware/how-to-upgradedowngrade-the-firmware-on-the-thomson-585v7... ) then see if a f/w upgrade helps.
Try disabling upnp from the CLI rather than the gui and see if that makes the change permanent. The Cli command is
Quote
system config upnp = disabled

then use the
Quote
saveall
command to save the change. You will need to Telnet into the router to use the CLI commands ( see here http://npr.me.uk/telnet.html )
chrism6102
Newbie
Posts: 4
Registered: ‎13-05-2013

Re: Unable to turn off UPnP

Thank you MisterW!!
Using the CLI and telnet fixed the issue, upnp has remained off!
Superuser
Superuser
Posts: 6,807
Thanks: 873
Fixes: 56
Registered: ‎30-07-2007

Re: Unable to turn off UPnP

TBH I'm a bit surprised it fixed it, I was clutching at straws really Smiley
I suspected it was more likely a dodgy router, but if it's worked, then fine and useful to know for any future posters.