cancel
Showing results for 
Search instead for 
Did you mean: 

URL taking ages to resolve but VPN does not

acuvic
Dabbler
Posts: 16
Registered: ‎06-03-2013

URL taking ages to resolve but VPN does not

This resolving URL names problem has been happening for a week or so but is getting worse. Angry
Links taking ages to resolve and many takes several attempts (clicks) before anything starts to happen.
Speedtest.net shows a reasonable 16Mb/s, and once IP is resolves, page loads fast enough.
Some urls are worse and google.co.uk is one of the bad ones. Here are two examples of bad ones:
Matt Cutts Blog: http://www.mattcutts.com/blog/guest-blogging/
Random acupuncture site: http://acupunctureforlife.co.uk
But connecting through VPN (UK server) and all is well. I suspect the problem is Plusnet's DNS resolvers are failing.
Using nslookup on command line shows:
Plusnet default DNS -  Server:  dsldevice.lan
                                      - Address:  192.168.1.254
VPN's DNS: - Server:  resolver1.privateinternetaccess.com
                      -  Address:  209.222.18.222
Of course with the supplied Technicolor modem/router, changing DNS server is not trivial.
Also switching the router on and off does not help.
Plusnet Staff - please investigate!
4 REPLIES
Superuser
Superuser
Posts: 12,962
Thanks: 4,261
Fixes: 26
Registered: ‎22-08-2007

Re: URL taking ages to resolve but VPN does not

Hi Acuvic,
Are you still having problems?  I have just tried doing nslookup using PN DNS servers on the URLs you listed without issue.
Earlier to day, I was experiencing variable responses looking up new domain names.  It seems that not all of the (I believe) eight PN DNS cache servers update simultaneously, thereby one can get inconsistent results.
As of this evening I see consistent results for repeated look-ups.
The VPN experience might well be as you describe - it will be using its own DNS service.
acuvic
Dabbler
Posts: 16
Registered: ‎06-03-2013

Re: URL taking ages to resolve but VPN does not

Hi Towman, I've switched the VPN off and tried the links and now they work ok! Problem is that for a week now even just google search will give an interminable "loading" symbol ad infinitum. Then it timeout with "website not available".
That is, about 50% of the time they don't resolve. Switching through the VPN immediately gives me the website.
Hence I suspect the DNS servers Plusnet uses are either overloaded or website sniffing and blocking processes on the server are choking it up.
Guessing that our government's forcing the blocking of terrorist, pirate, porn and p2p sites is slugging UK's ISP infrastructure.
Let me say though that the sites I'm trying to get are clean ones like SEO, web design, and marketing ones. Even Gmail stutters at times.
The internet is lately becoming a very rough experience. Sad Hope this is just teething problems while GCHQ and Home Office hacks up UK's internet.
Superuser
Superuser
Posts: 12,962
Thanks: 4,261
Fixes: 26
Registered: ‎22-08-2007

Re: URL taking ages to resolve but VPN does not

"Website not available" is quite different from "Website not found".
Not found implies a DNS resolution issue.
Unavailable suggests a routing or performance issue.
Yesterday I noticed significant timeouts when undertaking tracert diagnostics to one of the sites I was having issues with.  That is well outside of PN's control.  If things work ok over VPN that could well be down to the VPN end point having a different route to the target.
Next time you encounter the issue do a tracert to the target.  That will clear distinguish between the two possible causes.
Something is certainly not right - I sometimes get "web site not found" when pressing the POST button on this forum!
pwatson
Rising Star
Posts: 2,468
Thanks: 8
Fixes: 1
Registered: ‎26-11-2012

Re: URL taking ages to resolve but VPN does not

Changing the DNS servers on the router may not be trivial but changing settings on a test PC is...