cancel
Showing results for 
Search instead for 
Did you mean: 

Thomson / Technicolour TG585 v8

Matt1
Newbie
Posts: 2
Registered: ‎18-04-2011

Thomson / Technicolour TG585 v8

Hi I've recently bought a new router a Thomson TG585 v8, and I've experienced some issues connecting to the router. I have four computers.
My Dads desktop - using Windows 7 (wired connection) connects with no problem ever.
My Mums desktop - using Windows 7 (wireless connection with AzureWave AW-NU120 802.11 b/g/n dongle) connects with no problems ever.
My cousins laptop - Vista (wireless) struggles to connect properly to the router
My laptop - Vista (wireless Realtek RTL8187B 802.11b/g network adapter) also struggles.
Roughly 70% of the time, when my cousin or I try to connect, it can only connect with limited access, although we can see it, and when trying to connect to it fully it will not work despite going through all the troubleshooting that Vista offers, until we restart the router (a 5 minute process), then once it's fully restarted we can connect to the router with no problems usually, but often as soon as the laptops enter hibernate or shutdown - losing connection, we must restart the router to connect again.
The Vista troubleshooters try to get a new IP address, and whenever connected with limited access, when i type ipconfig on cmd, it will say i haven't got an IP address.
Can anyone suggest what the problem could be? and possibly help me fix it? all help will be greatly appreciated!! If any more information is needed please ask, thanks. Also my laptop has no problem connecting to any other routers or wi-fi hotspots, the wireless works fine with every other network and I have no anti-virus or firewalls stopping it from connecting.
3 REPLIES
Epyon
Grafter
Posts: 285
Registered: ‎31-03-2011

Re: Thomson / Technicolour TG585 v8

Force it to just run wireless G & not B
What kind of security are you running WEP,WPA,WPA2?
Matt1
Newbie
Posts: 2
Registered: ‎18-04-2011

Re: Thomson / Technicolour TG585 v8

I'm using WPA2, also how would i force it to run G, and would that effect signal quality and strength for the network?
jojopillo
Grafter
Posts: 9,786
Registered: ‎16-06-2010

Re: Thomson / Technicolour TG585 v8

HI Matt,
Have you upgraded to the latest firmware? A thread about this contains the following quote...
Quote from: Joanne
please make sure the firmware version on your router is 8.2.7.8  If your router is still showing 8.2.7.7 then please perform the firmware upgrade.

Jojo Smiley