cancel
Showing results for 
Search instead for 
Did you mean: 

Terribly Slow on Some Websites

Kalimalian
Dabbler
Posts: 12
Registered: 27-03-2015

Terribly Slow on Some Websites

As of last night I've noticed some websites are loading extremely slowly - all sites for shops, actually! Other sites such as Youtube, Google, Gmail, are loading without a problem.
My computer is connected via ethernet to the router.
Router info:
1 - Product name: Plusnet Router
2 - Serial number: <snip>
3 - Firmware version: 7.273.1_F2704N_Plusnet
4 - Board version: F@ST2704N
5 - Mode ADSL
6 - Uptime: 0 days 00:14:48
7 - Data rate: 1227/19631
8 - Maximum data rate: 1232/19680
9 - Noise margin: 6.1/3.1
10 - Line attenuation: 12.9/24.5
12 - Data sent/received: 4.5M/196.7M
20 - Broadband username: <snip>
21 - Wi-Fi network/SSID: <snip>
22 - Wi-Fi connections: Enable(802.11 b/g/n(up to 144 Mb/s))20 MHz WPS enabled
23 - Wi-Fi security: WPA2
24 - Wi-Fi channel: Automatic (Smart Wireless)
25 - Firewall: Default
26 - MAC Address: 44:e9:dd:9f:70:58
27 - Software variant Version 1.0
28 - Boot loader: 7.273.1
BT Speed Test:
Download speedachieved during the test was - 13.88 Mbps
For your connection, the acceptable range of speeds is 4 Mbps-21 Mbps.
IP Profile for your line is - 17.32 Mbps
Upload speed achieved during the test was - 0.18Mbps
Additional Information:
Upstream Rate IP profile on your line is - 0.83 Mbps
Line Speed:
Estimated line speed:
17Mb (This may vary between 10Mb and 19.5Mb) - Checked on 2015-02-28 18:20:31
Current line speed:
17.2 Mb
(Although speedtest.net is showing a download speed of 14Mb/s so make of that what you will)
[Moderator's note by Jim (Oldjim)  serial number removed also username, etc ]
29 REPLIES
Community Veteran
Posts: 38,423
Thanks: 1,008
Fixes: 58
Registered: 15-06-2007

Re: Terribly Slow on Some Websites

Your problem is the tested upload speed - do you have anything such as P2P running
Kalimalian
Dabbler
Posts: 12
Registered: 27-03-2015

Re: Terribly Slow on Some Websites

Nope, all I have open is the browser, with Netflix running (absolutely fine), and some web pages.
Community Veteran
Posts: 38,423
Thanks: 1,008
Fixes: 58
Registered: 15-06-2007

Re: Terribly Slow on Some Websites

It is possible that Netflix is the culprit
Can you stop it and run the speed test again
Kalimalian
Dabbler
Posts: 12
Registered: 27-03-2015

Re: Terribly Slow on Some Websites

Netflix is now closed.
The problem websites still aren't loading or are loading very very slowly and incompletely.
Download speed: 16.46
Upload: 0.6
Ping: 18.88
Per BT speed test
Community Veteran
Posts: 38,423
Thanks: 1,008
Fixes: 58
Registered: 15-06-2007

Re: Terribly Slow on Some Websites

So stopping Netfix boosted the upload speed from 0.18Mb/s to 0.6Mb/s this indicates that Netflix is saturating your upload and any sites which rely on feedback - such as from cookies - like shopping are likely to be crippled
Why the sites are still slow I don't know
Kalimalian
Dabbler
Posts: 12
Registered: 27-03-2015

Re: Terribly Slow on Some Websites

Well even with Netflix turned off these sites are still unusable. Regardless, not a very impressive display from a broadband provider in this day and age - on my last provider I was able to do many things at once without a single problem. A shame they weren't available in the area I am currently in.
Community Veteran
Posts: 38,423
Thanks: 1,008
Fixes: 58
Registered: 15-06-2007

Re: Terribly Slow on Some Websites

It is doubtful that this is something Plusnet are doing
However one question - have you enabled Safeguard - see this thread http://community.plus.net/forum/index.php/topic,138055.0.html
Kalimalian
Dabbler
Posts: 12
Registered: 27-03-2015

Re: Terribly Slow on Some Websites

So how am I supposed to fix this non-loading problem? Looking at this forum, I'm not the only one experiencing it, so I fail to see how there isn't some degree of involvement from Plusnet. Sorry to be snippy, but I am paying for this service and am not receiving even the basic functionality of loading websites!
Safeguard is turned off.
dratddestroyer
Grafter
Posts: 164
Registered: 27-09-2007

Re: Terribly Slow on Some Websites

Is your MTU setting correct?
It should be 1500 on your router and in your operating system.
Community Veteran
Posts: 38,423
Thanks: 1,008
Fixes: 58
Registered: 15-06-2007

Re: Terribly Slow on Some Websites

I am sorry but I have pretty well run out of ideas
Your speeds are fine so it isn't the connection per se
Can you try setting the DNS to Google in the router interface and see if that makes any difference
Plusnet Staff
Plusnet Staff
Posts: 17,641
Thanks: 535
Fixes: 159
Registered: 05-04-2007

Re: Terribly Slow on Some Websites

I can't see anything obviously wrong, and the speedtests working fine are suggesting this isn't an issue with the line itself.
Might seem odd but has any security software updated recently (anti-virus, firewall etc)? I ask as your initial post said it's shop sites, so I wonder if it's related security measures on the sites.
If this post resolved your issue please click the 'This fixed my problem' button
 Chris Parr
 Plusnet Staff
Kalimalian
Dabbler
Posts: 12
Registered: 27-03-2015

Re: Terribly Slow on Some Websites

No recent updates to any security software, no.
I am looking at the MTU stuff but it's new ground for me and the Plusnet guides aren't particularly helpful as the tool they link to isn't working.
JayG
Aspiring Pro
Posts: 882
Thanks: 49
Fixes: 1
Registered: 30-10-2011

Re: Terribly Slow on Some Websites

Have you tried using a different browser?
If you have any add-ons enabled in your current one, try disabling them, at least temporarily, and clear out any unnecessary browser history/temporary files etc (CCleaner is a useful free tool to do this - make sure you don't delete your cookies unless you're prepared to re-enter all your stored usernames etc.)
Kalimalian
Dabbler
Posts: 12
Registered: 27-03-2015

Re: Terribly Slow on Some Websites

As stated above, it's across all browsers I have. This is Firefox, Chrome, and IE.
dick:quote