cancel
Showing results for 
Search instead for 
Did you mean: 

Technicolor TG582n and GRE

Superuser
Superuser
Posts: 2,596
Thanks: 288
Fixes: 5
Registered: 06-04-2007

Technicolor TG582n and GRE

Hi
I've set up a VPN Server in Windows Server 2008r2 on one of my networks and need to get the router sorted with it as well.  I set the server as the DMZ in the router and it all works fine, but obviously I don't want to leave it that way.
From this (and other sources) I need to port forward poer 1723 (no problem, done that without a problem).  I also need to set GRE to the server as well.
Does anyone know how to set this in the TG582n?
Many thanks
Phil
17 REPLIES
Superuser
Superuser
Posts: 2,596
Thanks: 288
Fixes: 5
Registered: 06-04-2007

Re: Technicolor TG582n and GRE

No one any ideas on this?  I've been having a search around the CLI guide.  On page 651 there is a command nat mapadd, which might give what I need, but I'm not sure what I should be entering for some of the options.  Any one suggest anything with it?
Thanks
Phil
Community Veteran
Posts: 6,824
Thanks: 1
Registered: 27-10-2012

Re: Technicolor TG582n and GRE

I would have thought the router should do it automatically with uPnP. My Asus does it with Windows Home Server (although there was a slight issue with the uPNP port range).
Edit: Another thought - have you looked in your event logs to see why it does not work with DMZ off? This might give you a clue. I also think there is a command to check the uPNP mappings to see if those are correct on the router.
Community Veteran
Posts: 6,364
Thanks: 490
Fixes: 45
Registered: 30-07-2007

Re: Technicolor TG582n and GRE

@pjmarsh,
PPTP and GRE are closeIy linked in most routers. When port 1723 ( the PPTP control port ) is forwarded, the router will automatically forward any GRE protocol packets to the same IP as port 1723 is forwarded. If that is the case then just forwarding port 1723 to your server should work. Does that not work with the TG582 or have you not actually tried it ?
Superuser
Superuser
Posts: 2,596
Thanks: 288
Fixes: 5
Registered: 06-04-2007

Re: Technicolor TG582n and GRE

@AndyH, surely uPNP would only come into play if the connection originated from the server, which is won't be since it is the client connecting via the WAN that is initiating the connection.
@MisterW, that is what I tried first of all and then when it wasn't working I tried it as the DMZ
I can't connect just at the moment as I tried making some changes with CLI commands, so I took it out of the DMZ and can't connect now until I pop down to change it again!
Thanks for the suggestions
Phil
Community Veteran
Posts: 6,824
Thanks: 1
Registered: 27-10-2012

Re: Technicolor TG582n and GRE

I haven't forwarded any ports on my router and I can VPN into my server running WHS. I believe once the service is activated and set up (which was a bit of a hassle in WHS), it sets up the correct ports with uPNP.
Is your dashboard showing any issues with your router?
I'm not sure if it's related but I had to edit the default start range of the uPNP ports on my router as WHS couldn't configure them correctly at first. It did take me quite a while to figure that bit out...
Superuser
Superuser
Posts: 2,596
Thanks: 288
Fixes: 5
Registered: 06-04-2007

Re: Technicolor TG582n and GRE

By Dashboard, do you mean the Server Management utility? That has no mention of the router in it at all.  There isn't anything in the Event Logs either.
Any idea how you change the uPNP port range on the TG582n?
Thanks
Phil
Community Veteran
Posts: 6,824
Thanks: 1
Registered: 27-10-2012

Re: Technicolor TG582n and GRE

I think so....WHS is a bit different (more user friendly) but is based on Windows Server 2008.
If you go Start > Run > services.msc  Is UPnP Device Host enabled and set to automatic?
I am not sure about the Technicolour router telnet commend to change the uPNP ports. There was a thread on here where I found a command though.
dragon2611
Grafter
Posts: 283
Registered: 20-10-2013

Re: Technicolor TG582n and GRE

They haven't removed the ALG/Nat helper for it again have they?
There was a problem with one of the 8.x firmwares for the 585v7 where Technicolor/Thompson forgot the NAT helper for GRE breaking PPTP based vpns.
I really wouldn't put it past them to make the same mistake a second time  Undecided
Superuser
Superuser
Posts: 2,596
Thanks: 288
Fixes: 5
Registered: 06-04-2007

Re: Technicolor TG582n and GRE

Thanks dragon. I'll have a look at the firmware later on today.
Thanks
Phil
Community Veteran
Posts: 6,364
Thanks: 490
Fixes: 45
Registered: 30-07-2007

Re: Technicolor TG582n and GRE

I've just had a look around on my TG582 via the telnet CLI  ( system service list ) and there is a GRE service BUT it is showing disabled. Might be interesting to enable it ( service system modify name=GRE state=enabled ) and see if it has any effect. Will try and see if I can find some more info...
Superuser
Superuser
Posts: 2,596
Thanks: 288
Fixes: 5
Registered: 06-04-2007

Re: Technicolor TG582n and GRE

Thanks MisterW. I'll hopefully be popping in this afternoon to give myself access again. That's the problem with testing VPN, you need to be in 2 places at once!
Thanks
Phil
dragon2611
Grafter
Posts: 283
Registered: 20-10-2013

Re: Technicolor TG582n and GRE

Perhaps use something like 3G to test the VPN from outside?
Superuser
Superuser
Posts: 2,596
Thanks: 288
Fixes: 5
Registered: 06-04-2007

Re: Technicolor TG582n and GRE

You don't get much of a signal there unfortunately. Best bet might be phone calls back to the wife asking her to try and connect! Though it might be easier just to drive home!
Thanks
Phil
Community Veteran
Posts: 1,829
Thanks: 93
Fixes: 5
Registered: 21-01-2013

Re: Technicolor TG582n and GRE

Have you seen “Problems connection to PPTP Servers“
Here: http://wiki.aa.org.uk/Router_-_TG582N_-_Firewall_and_Port_Forwarding
Also are you on a fibre connection? There has been reports of a recent update to the BT fibre modem breaking VPN.
http://revk.www.me.uk/2013/11/bt-huawei-fttc-modem-bug-breaking-vpns.html