cancel
Showing results for 
Search instead for 
Did you mean: 

Technicolor TG582n FTP problem

plusnetrph
Newbie
Posts: 2
Registered: 05-11-2011

Technicolor TG582n FTP problem

I have just upgraded to FTTC and received the TG582n router from PlusNet. It is not possible to put firmware into my current router to work with the BT modem.
I am unable to find a way to convince the TG582n to let go of the FTP port 21, so that I can allocate it to my own hobby web server. I have tried the telnet commands suggested in other posts, but still have not managed a solution.
Does anybody have any other ideas before I relegate the router to the bin ?  Is there a reason why it was "free" ?
Peter H.
2 REPLIES
Community Veteran
Posts: 1,841
Thanks: 103
Fixes: 6
Registered: 21-01-2013

Re: Technicolor TG582n FTP problem

Check the port forward rule assigned to the routes own FTP server has been unassigned. You should then be able to assign the FTP rule to a device of your choice.
hiakuryu
Newbie
Posts: 1
Registered: 17-10-2013

Re: Technicolor TG582n FTP problem

Sorry for the plus one month thread necro but I thought I would bring my answer up as I've just about finished wrestling this problem to the ground and then some.
First of all the router is running it's own FTP server for uploading of small configuration files and the like, therefore that needs to be disabled first (in addition tot he content sharing FTP server that the router has too). Then the IDS needs to be turned off because that is also going to be blocking the FTP as well.
So you need to telnet in to the router either using putty or the windows telnet command (not installed by default)
The commands are as follows.
:ids config state=disabled
to turn off the IDS
service system modify name=FTP state=disabled
to turn off the routers own FTP server
then enter the command
saveall
to save all the settings changes and then exit
I turned off the IDS because using passive mode for the FTP server requires that the IDS be off. Hope this has all helped.