cancel
Showing results for 
Search instead for 
Did you mean: 

Technicolor TG582n - Can't uncheck the 'Allowed on WLAN'

helengrout
Newbie
Posts: 1
Registered: 23-06-2013

Technicolor TG582n - Can't uncheck the 'Allowed on WLAN'

We've a Technicolor TG582n router and we're trying to uncheck the 'Allowed on WLAN' box for some devices.  We know what we're trying to do, and why, and the principle seems straightforward but the box won't uncheck!  How can we make it?  Or is there another way of denying access to certain devices?
17 REPLIES
Bjn
Grafter
Posts: 318
Thanks: 1
Registered: 11-11-2012

Re: Technicolor TG582n - Can't uncheck the 'Allowed on WLAN'

strange thing is I was trying to do this about an hour ago and found the same thing you could not uncheck the box. I could on my previous plusnet router which was replaced with a new one yesterday? (fibre router)
I think the software release on new router is different  8.C.M.0  to old router, but can't checked as posted old faulty router back yesterday,.
hypnoboy
Grafter
Posts: 40
Registered: 17-06-2013

Re: Technicolor TG582n - Can't uncheck the 'Allowed on WLAN'

I have also just posted with reference to this, and found the same issue, no one at the call centre appears to know and asked me to post the question here.
Also, why my router is connecting on WLAN at 65mbps and not 130 as it was when the connection was set up.
Any help on these issues appreciated.
Thanks
Craig
Plusnet Help Team
Plusnet Help Team
Posts: 12,751
Thanks: 105
Fixes: 32
Registered: 27-04-2007

Re: Technicolor TG582n - Can't uncheck the 'Allowed on WLAN'

Hi all,
Thanks for bringing this to our attention, we've just tested this ourselves and we saw the same issue.
We're going to raise this with Technicolor, I've raised problem 75744 for tracking purposes.
Adam
If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team
Pyrii
Grafter
Posts: 79
Registered: 06-06-2013

Re: Technicolor TG582n - Can't uncheck the 'Allowed on WLAN'

Is there a way to do this via the CLI?
Community Veteran
Posts: 1,819
Thanks: 87
Fixes: 5
Registered: 21-01-2013

Re: Technicolor TG582n - Can't uncheck the 'Allowed on WLAN'

That fault has been there in ever firmware version I've used, in three different Technicolor models Sad
This is how to do it with cli:
http://npr.me.uk/telnet.html#macaccess
Cagney1994
Rising Star
Posts: 304
Thanks: 5
Fixes: 2
Registered: 28-07-2013

Re: Technicolor TG582n - Can't uncheck the 'Allowed on WLAN'

Sorry to bump up this thread but has the issue been resolved ?
I seem to be having the same problem.
Plusnet Help Team
Plusnet Help Team
Posts: 12,751
Thanks: 105
Fixes: 32
Registered: 27-04-2007

Re: Technicolor TG582n - Can't uncheck the 'Allowed on WLAN'

Quote
Sorry to bump up this thread but has the issue been resolved ?

No worries and I'm afraid not. I'll chase that up.
Adam

UPDATE: This still hasn't been resolved I'm afraid, I'll give the relevant people a nudge although this looks like an issue with our hardware supplier. In the meantime you should be able to resolve this by using a CLI command as per some of the previous replies to this thread.
If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team
peter1000000
Newbie
Posts: 1
Registered: 27-10-2013

Re: Technicolor TG582n - Can't uncheck the 'Allowed on WLAN'

Using the CLI is s little inconvenient. When you get the solution appreciate if you can let me know.
mirageleppings
Newbie
Posts: 1
Registered: 15-11-2013

Re: Technicolor TG582n - Can't uncheck the 'Allowed on WLAN'

sorry to bump
but any more developments on this, still using the Technicolor TG582n router but STILL not able to check and uncheck Allowed on WLAN.
Any help or information on sorting this is greatly appreciated
regards 
Superuser
Superuser
Posts: 9,988
Thanks: 1,532
Fixes: 19
Registered: 22-08-2007

Re: Technicolor TG582n - Can't uncheck the 'Allowed on WLAN'

Quote from: npr
This is how to do it with cli:
http://npr.me.uk/telnet.html#macaccess

To get what you think is a 'proper' fix (ability to change via the web interface) will require the development, testing, distribution, download of a new firmware which you might then have to flash your router with.  Though the CLI might seem a little daunting at first, it is a heck of a lot simpler than the route to a 'proper' fix.
markos
Hooked
Posts: 9
Thanks: 2
Registered: 20-02-2013

Re: Technicolor TG582n - Can't uncheck the 'Allowed on WLAN'

I've enabled the Telnet client, logged in successfully, etc. But when I've entered the command line with the MAC address it says, "Station not present". Does that mean I can only block devices that are currently connected?
markos
Hooked
Posts: 9
Thanks: 2
Registered: 20-02-2013

Re: Technicolor TG582n - Can't uncheck the 'Allowed on WLAN'

Ignore that - sorry! I hadn't done the first step:-
wireless macacl add ssid_id=0 radio_id=0 hwaddr=00:xx:xx:xx:xx:xx permission=allow

Crazy
TORPC
Grafter
Posts: 5,163
Registered: 08-12-2013

Re: Technicolor TG582n - Can't uncheck the 'Allowed on WLAN'

Quote from: _Adam_Walker_
Quote
Sorry to bump up this thread but has the issue been resolved ?

No worries and I'm afraid not. I'll chase that up.
Adam

UPDATE: This still hasn't been resolved I'm afraid, I'll give the relevant people a nudge although this looks like an issue with our hardware supplier. In the meantime you should be able to resolve this by using a CLI command as per some of the previous replies to this thread.

Has this ever been resolved ?Huh
Plusnet Alumni (retired) LinnPlusnet
Plusnet Alumni (retired)
Posts: 1,686
Registered: 03-02-2014

Re: Technicolor TG582n - Can't uncheck the 'Allowed on WLAN'

Hi all,
Sorry an update was never posted on here!  Embarrassed
I've chased this up with our Products team and they've confirmed the following:
The Allowed on WLAN tick box is actually redundant and doesn't do anything, this is why it's unresponsive. The ability to dis-allow a device on the WLAN is done via a drop-down box that is only present when MAC address filtering is enabled. This is done by changing "Allow New Devices:" under the Wireless configuration menu to "New Devices Allowed (via Registration). The drop down box will then appear and you can select Yes or No for allowed.
Hope this helps!