cancel
Showing results for 
Search instead for 
Did you mean: 

Technicolor 582n showing USB port folders but there is NO USB port!

SoFarSoGood
Rising Star
Posts: 95
Thanks: 2
Fixes: 3
Registered: 30-03-2013

Technicolor 582n showing USB port folders but there is NO USB port!

Hi all
When I view Network media folders/files available via my Freeview hard disk recorder (Humax HDR Fox T2), only the Technicolor 582n appears with a number of sub-folders which don't exist.
How do I 'tell' the 582n it doesn't have a USB port and should not be showing these folders as if it had?
Ideally, I would like to have a USB port version but on checking with Plusnet I understand that they 'do not supply any routers with the option of USB any further as the current models are the latest edition available'.
I have a backup/spare TP-Link TD-W8968 modem/router/with USB port but not sure how to set this up to use as a router/USB port only, with the 582n only functioning as a modem (the TP-Link modem doesn't perform as well as the 582n) .
Any help or suggestions will be appreciated.




13 REPLIES
Community Veteran
Posts: 1,829
Thanks: 93
Fixes: 5
Registered: 21-01-2013

Re: Technicolor 582n showing USB port folders but there is NO USB port!

Quote from: SoFarSoGood

How do I 'tell' the 582n it doesn't have a USB port and should not be showing these folders as if it had?

Try the telnet commands:
contentsharing cifs config state=disabled
saveall
njay
Grafter
Posts: 184
Registered: 05-04-2013

Re: Technicolor 582n showing USB port folders but there is NO USB port!

Ermm, my 582n supplied for FTTC install on 16th April has a USB port on the side  Crazy
I haven't tried using it but the mediaserver is apparantly active in the router and says it can't detect the format of the usb drive which is understandable given the lack of drive connected to it lol
Community Veteran
Posts: 6,366
Thanks: 490
Fixes: 45
Registered: 30-07-2007

Re: Technicolor 582n showing USB port folders but there is NO USB port!

Quote
Try the telnet commands:
contentsharing cifs config state=disabled
saveall

In this thread http://community.plus.net/forum/index.php/topic,114061.0.html we seem to have established that the commands needed to disable cifs & upnp content sharing are not available via either the GUI or CLI on non USB models. The method suggested in that thread was either to try running the cli commands via 'script' or to edit the ini file.
SoFarSoGood
Rising Star
Posts: 95
Thanks: 2
Fixes: 3
Registered: 30-03-2013

Re: Technicolor 582n showing USB port folders but there is NO USB port!

Thanks npr and njay for your respective replies.
I'll try those telnet commands later.
Having now downloaded the 'standard version' TG582n User Guide it only mentions setting up the USB port as a 2G/3G fall-back WAN connection with no mention of any other use, so not what I'm looking for anyway.
The reply I quoted was from Steve in Customer Support 8.09am today.
So either this has only just happened (i.e on/about/after 16th April 2013) or someone in Support needs to update Steve.
Any suggestions or help regarding the penultimate paragraph of my query please.
 
njay
Grafter
Posts: 184
Registered: 05-04-2013

Re: Technicolor 582n showing USB port folders but there is NO USB port!

Prior to going fibre I had a tp-link 8960n (1st version as I gather there may be two). Also not to be confused with the 8961n which tp-link went cheap with (or is that even cheaper lol) the adsl chipset.
It was the most stable ADSL2plus modem/router I have had (DG834GT and Thomson 585v7 being the others) and the only one that managed weeks on end syncing at 4+ mbs on a line estimated for 2Mbits Smiley.
I have recently found that it can be converted to work with Fibre so it may be possible to use the same instructions for the 8968
http://www.tp-link.com/en/article/?faqid=344
I may give this a try on my 8960n (as the 582n is alot worse in my house for wireless ;() but the lure of the Asus n66u is strong lol
njay
Grafter
Posts: 184
Registered: 05-04-2013

Re: Technicolor 582n showing USB port folders but there is NO USB port!

Actually the 8968 looks even easier as justed downloaded the user guide under section 4.4 you have three options, one of which is Wireless router. This will prompt for WAN connection type PPPoE and you put in your PlusNet connection credentials. LAN port 4 then acts as an EWAN port much like the 582n does. Disconnect the PPP session on the 582n, switch it off and plug the OR Modem into port 4 of the 8968 and do the change above.
Let us know how you get on Smiley
Actually I misread your question as you don;t have fibre so ignore me LOL
SoFarSoGood
Rising Star
Posts: 95
Thanks: 2
Fixes: 3
Registered: 30-03-2013

Re: Technicolor 582n showing USB port folders but there is NO USB port!

Hi njay
I believe your 8960n, and the Netgear DG834GT, both us a Broadcom chip which, imo, would explain the better performance, whereas the W8968 uses a Trend chip.
My W8968 is connected to the 582n so I can use it's better wifi performance but would also like to use the USB port as a 'NAS' drive, so looking for suggestions on how best to connect/set-up.
I also have a DG834GT (with DGTeam Firmware) and agree it's a great modem but I find the 582n offers similar performance but with less options.
Thanks for your help.
 
 
Community Veteran
Posts: 38,438
Thanks: 1,015
Fixes: 60
Registered: 15-06-2007

Re: Technicolor 582n showing USB port folders but there is NO USB port!

Regarding the USB port this may be of help although it is specific to a printer http://beusergroup.co.uk/technotes/index.php?title=Printer_sharing_TG582n
SoFarSoGood
Rising Star
Posts: 95
Thanks: 2
Fixes: 3
Registered: 30-03-2013

Re: Technicolor 582n showing USB port folders but there is NO USB port!

Thanks Oldjim for the link
SoFarSoGood
Rising Star
Posts: 95
Thanks: 2
Fixes: 3
Registered: 30-03-2013

Re: Technicolor 582n showing USB port folders but there is NO USB port!

Quote from: MisterW
Quote
Try the telnet commands:
contentsharing cifs config state=disabled
saveall

In this thread http://community.plus.net/forum/index.php/topic,114061.0.html we seem to have established that the commands needed to disable cifs & upnp content sharing are not available via either the GUI or CLI on non USB models. The method suggested in that thread was either to try running the cli commands via 'script' or to edit the ini file.

Sorry MisterW, I've only just noticed your reply.
Thanks for the info and link.
Community Veteran
Posts: 26,543
Thanks: 788
Fixes: 9
Registered: 10-04-2007

Re: Technicolor 582n showing USB port folders but there is NO USB port!

Re using the TP-link: you don't want it to act as a router as this function is being performed by the TG582. I think if you disable DHCP in the TP-link you should be able to connect one of it's Ethernet ports to a spare port on the TG582. You will need to give it it's own IP address on the same 192.168.1.* subnet but outside the DHCP range assigned by the TG582. You'll also need to configure it not to attempt to connect to ADSL.
jelv (a.k.a Spoon Whittler)
   Why I have left Plusnet (warning: long post!)   
Broadband: Andrews & Arnold Home::1 (FTTC 80/20)
Line rental: Pulse 8 Home Line Rental (£13/month)
Mobile: iD mobile (£4/month)
SoFarSoGood
Rising Star
Posts: 95
Thanks: 2
Fixes: 3
Registered: 30-03-2013

Re: Technicolor 582n showing USB port folders but there is NO USB port!

Hi  jelv
Thanks for the info.
I had already got to the point you suggest except that I used the LAN4/WAN port so have now done as you suggest and moved to the LAN4 port.
Wireless is working fine but still need to get the USB 'NAS' working at some point.
njay
Grafter
Posts: 184
Registered: 05-04-2013

Re: Technicolor 582n showing USB port folders but there is NO USB port!

I know it doesn't help but just to say that I have tried the USB port on mine and it works fine with the 4GB pendrive I plugged in. Recognise the 250Gb USB drive too but told me it was wrong format as it is NTFS. As I have a NAS its going to be unused though.
Anyway, I believe doing a bit of digging on here the TG582n FTTC variant still have USB ports so that at least explains why mine does.