cancel
Showing results for 
Search instead for 
Did you mean: 

Technicolor 582n Bridge Mode with Time Capsule

phil4k
Newbie
Posts: 3
Registered: 27-07-2013

Technicolor 582n Bridge Mode with Time Capsule

Hi,
My plusnet service was activated yesterday after around 2 years with BE. Whilst I was with BE and O2 before I've always used the technicolor router in modem (bridge) mode and haven't experienced any significant performance degradation when paired with either my Time Capsule of Airport Extreme. That said my connection with O2 was limited to 4Mb/s and BE a little faster at around 8Mb/s.
I first setup my technicolor normally and did a quick speed test which was around 18Mb/s.
I put the technicolor into bridge mode using the following commands:
ppp relay flush
ppp flush
eth flush
atm flush
atm phonebook flush
saveall
atm phonebook add name=BrPPPoE_ph addr=0.38
atm ifadd intf=BrPPPoE_atm
atm ifconfig intf=BrPPPoE_atm dest=BrPPPoE_ph encaps=llc ulp=mac
atm ifattach intf=BrPPPoE_atm
eth bridge ifadd intf=BrPPPoE_br
eth bridge ifconfig intf=BrPPPoE_br dest=BrPPPoE_atm
eth bridge ifattach intf=BrPPPoE_br
service system modify name=DHCP-S state=disabled
system config upnp=disabled
wireless radio state=disabled
saveall

The Time Capsule is able to establish a connection but if I run a speed test now the maximum through put is in the region of 11Mb/s. This has been setup over night and there was no difference in test results this morning. My line statistics are identical in both configuration.
I did note that when I download a dummy test file through thinkbroadband that the throughput is listed at maximum spikes of 2.2MB/s and minimums of 1.5MB/s however, surfing still seems a little hesitant in comparison to using the technicolor in isolation.
Has anyone ever noted anything similar and can offer any advise on resolving these problems?
Would there be any benefit in buying a dedicated modem such as the Vigor 120, is it likely that will operate better with the Apple routers?
Any help and advise would be appreciated.
Thanks
Phil
4 REPLIES
Community Veteran
Posts: 1,840
Thanks: 102
Fixes: 6
Registered: 21-01-2013

Re: Technicolor 582n Bridge Mode with Time Capsule

Try changing the line:
atm ifconfig intf=BrPPPoE_atm dest=BrPPPoE_ph encaps=llc ulp=mac
To
atm ifconfig intf=BrPPPoE_atm dest=BrPPPoE_ph encaps=vcmux ulp=ppp
See "telnet method" here:
http://npr.me.uk/nbridge.html
phil4k
Newbie
Posts: 3
Registered: 27-07-2013

Re: Technicolor 582n Bridge Mode with Time Capsule

Quote from: npr
Try changing the line:
atm ifconfig intf=BrPPPoE_atm dest=BrPPPoE_ph encaps=llc ulp=mac
To
atm ifconfig intf=BrPPPoE_atm dest=BrPPPoE_ph encaps=vcmux ulp=ppp
See "telnet method" here:
http://npr.me.uk/nbridge.html

Thanks but it didn't like those options  Sad
Destination interface atm_Internet has incompatible ulp parameter.
Community Veteran
Posts: 1,840
Thanks: 102
Fixes: 6
Registered: 21-01-2013

Re: Technicolor 582n Bridge Mode with Time Capsule

Strange, I've just tried here and it accepted the commands ok.
Can't test bridge mode anymore as I'm now on fibre.
Did you use the commands in the link or modify the previous commands, both should work.
phil4k
Newbie
Posts: 3
Registered: 27-07-2013

Re: Technicolor 582n Bridge Mode with Time Capsule

Quote from: npr
Did you use the commands in the link or modify the previous commands, both should work.

Both. I also tried different encaps options based on some other posts and comments on this forum without success.
As an FYI the command:
atm ifconfig intf=atm_Internet dest=pvc_Internet encaps=vcmux ulp=ppp

is accepted but:
Destination interface atm_Internet has incompatible ulp parameter.

is fedback after entering the command:
eth bridge ifconfig intf=Internet dest=atm_Internet wan=enabled