cancel
Showing results for 
Search instead for 
Did you mean: 

TP-Link TD-W8980 dropping DSL connection

eddieg
Newbie
Posts: 8
Registered: 06-09-2014

TP-Link TD-W8980 dropping DSL connection

Hi guys,
Having just switched over to PlusNet I'm trying to connect using the above router, but the DSL connection keeps initialising, briefly obtaining an IP address and then dropping off again. I've checked the forum for other users having the same issue but the recommended fix for the one I found does not apply to my situation as the firmware in that instance was older.
I've updated the router firmware and it auto-populates most of the fields required (correctly too, checking these against the PlusNet site) but nothing changes. Can someone please advise what further info I need to provide in order to get some help with this problem?
Many thanks in advance,
Ed
12 REPLIES
eddieg
Newbie
Posts: 8
Registered: 06-09-2014

Re: TP-Link TD-W8980 dropping DSL connection

One further thing to add - I had an old Netgear DG834Gv2 lying around that I have just reconfigured with the PlusNet settings and this has managed to hold a stable connection, so I accept it's not a line issue as such, but just need to understand what is wrong/different with the TP-Link...
Community Veteran
Posts: 1,607
Thanks: 20
Registered: 29-06-2010

Re: TP-Link TD-W8980 dropping DSL connection

Can you take a screenshot of the TP-Link settings page and post it here?
Obviously omit any personal info...
eddieg
Newbie
Posts: 8
Registered: 06-09-2014

Re: TP-Link TD-W8980 dropping DSL connection

Absolutely - and thanks for responding. Thought I actually posted this last night but apparently it timed out...
What are the best screens to post? There are quite a few - is there an upload limit on this forum or shall I post as many as possible?
Moderator
Moderator
Posts: 26,006
Thanks: 1,244
Fixes: 51
Registered: 14-04-2007

Re: TP-Link TD-W8980 dropping DSL connection

Status page from an 8980 I have access to for reference.

Customer and Forum Moderator.

eddieg
Newbie
Posts: 8
Registered: 06-09-2014

Re: TP-Link TD-W8980 dropping DSL connection

This is the status screen I have...
Community Veteran
Posts: 3,274
Thanks: 339
Fixes: 12
Registered: 24-10-2013

Re: TP-Link TD-W8980 dropping DSL connection

your line isn't connected in that screenshot.
you'll need to post it once it has connected.
eddieg
Newbie
Posts: 8
Registered: 06-09-2014

Re: TP-Link TD-W8980 dropping DSL connection

That's the problem though - it doesn't hold a connection to the line. It initialises, connects and then drops out again before repeating the cycle.
The Netgear holds the connection but is sloooooooooooooow so I just did a ping test and 50% of the packets dropped, which means now I don't know whether it's the line or the router  Angry
eddieg
Newbie
Posts: 8
Registered: 06-09-2014

Re: TP-Link TD-W8980 dropping DSL connection

Update: the Netgear now drops no packets, but is still too slow to be useable even when wired in (ie. ethernet as opposed to wireless).
Community Veteran
Posts: 4,976
Thanks: 375
Fixes: 16
Registered: 10-06-2010

Re: TP-Link TD-W8980 dropping DSL connection

Where did you get the TD-W8980 firmware dated 140701? The latest on the tp-link website are 140619 and 140627 (UK specific).
We really need to see the ADSL stats from either router. You could try setting the TD-W8980 to ADSL1 (G.DMT) only, or ADSL2 (G.DMT.bis) only, instead of the default that auto selects (Multimode).
eddieg
Newbie
Posts: 8
Registered: 06-09-2014

Re: TP-Link TD-W8980 dropping DSL connection

I just searched on the TP-Link site and it came up with three options, so I took the most recent. However, going back there from my internet history, I'll admit I can't see that version now. Wonder if it's been removed...?
What are the ADSL stats you need? The Netgear is up at the moment and it has the attached (although bear in mind it shows line speed as 6Mbps due to the line being capable of that, not that it's the actual speed I'm getting). I'm actually using my phone as a hotspot though, since the speed is just unusable.
kitz
Rising Star
Posts: 817
Thanks: 46
Registered: 08-06-2007

Re: TP-Link TD-W8980 dropping DSL connection

You say the Netgear will connect, but is slow and getting packet loss.   What are the stats from the netgear.
Im wondering if the line is so poor and SNR so low that the the TPlink cant get a sync that lasts for long.  
The netgear may be just holding on to the line but at a low speed..  this could also explain the packet loss - low SNR meaning lots of CRC's/ES/SES - meaning data has to be retransmitted.
It the line noisy?  Try doing a quiet line test.

---------------
ETA. 
Oops we posted at exactly the same time.  I see your stats now -  8dB SNRm so it should be fine.
eddieg
Newbie
Posts: 8
Registered: 06-09-2014

Re: TP-Link TD-W8980 dropping DSL connection

Ah, damn - I thought you might have solved it then! It sounded good, anyway.
Thanks for the suggestion, regardless. Is there anything else I could try?