cancel
Showing results for 
Search instead for 
Did you mean: 

TP-Link Router wireless problem

Timalay
Grafter
Posts: 158
Registered: 02-05-2010

TP-Link Router wireless problem

I recently purchased a new TP-Link Archer C7 to replace my Plusnet fibre router (technicolor tg582n). It seems very slow streaming wirelessly via my laptop, TV and Xbox 360.
Anything that might help it. Should I using a specific wifi channel.
12 REPLIES
tazmaniandevil
Grafter
Posts: 85
Thanks: 3
Registered: 07-02-2014

Re: TP-Link Router wireless problem

Normally setting the channel to auto if that setting is available means the router will select the clearest channel. Try downloading inSSIDer to check channel, signal quality, and any other networks in range.
TCP Optimizer is useful too for altering your wireless card settings to the best performance
Timalay
Grafter
Posts: 158
Registered: 02-05-2010

Re: TP-Link Router wireless problem

I thought it was just wireless, it seems wired as well.  Also when I do some speed tests it seems to hand on the upload speed  test as well.
Timalay
Grafter
Posts: 158
Registered: 02-05-2010

Re: TP-Link Router wireless problem

A week on and I'm still having trouble streaming anything (wireless or wired).  Also Google seems really slow at time.  Any help guys. 
I did use the same Ethernet cable that I had connected to the Plusnet Fibre router.  Should I change to the one in the TP-Link router box?
Plusnet Staff
Plusnet Staff
Posts: 6,346
Thanks: 31
Fixes: 5
Registered: 26-11-2011

Re: TP-Link Router wireless problem

Hmm...very odd. Here's your line stats.
Downstream Speed 67.5 Mbps
Upstream Speed 17.2 Mbps
Profile: 37M-74M Downstream, Interleaving Off - 10M-19M Upstream, Interleaving Off
So everything from that side of things looks fine.
Your Speed Profile set on our systems looks to be correct. It might be worth trying a direct connection into your Modem though? http://community.plus.net/library/broadband/fibre-help-how-to-set-up-a-pppoe-dialler-in-vistawindows...
Chris Pettitt
Cloud Environments Engineer
Timalay
Grafter
Posts: 158
Registered: 02-05-2010

Re: TP-Link Router wireless problem

I still have the old Plusnet Router also.  Is it worth trying that?
Plusnet Staff
Plusnet Staff
Posts: 6,346
Thanks: 31
Fixes: 5
Registered: 26-11-2011

Re: TP-Link Router wireless problem

You can do, just to compare the two - it'll at least help determine whether or not the TP-Link you bought is faulty or not.
Chris Pettitt
Cloud Environments Engineer
Timalay
Grafter
Posts: 158
Registered: 02-05-2010

Re: TP-Link Router wireless problem

Also could have been something I entered wrong in setting it up?
Plusnet Staff
Plusnet Staff
Posts: 6,346
Thanks: 31
Fixes: 5
Registered: 26-11-2011

Re: TP-Link Router wireless problem

I'm not 100% with a TP-Link but it's unlikely. It might be worth taking a look through the hand guide that came with the router just to double check though.
Chris Pettitt
Cloud Environments Engineer
Timalay
Grafter
Posts: 158
Registered: 02-05-2010

Re: TP-Link Router wireless problem

Is it just a case of swapping over the cables for changing the router back?
Plusnet Staff
Plusnet Staff
Posts: 6,346
Thanks: 31
Fixes: 5
Registered: 26-11-2011

Re: TP-Link Router wireless problem

Yep - should be Smiley
Chris Pettitt
Cloud Environments Engineer
Timalay
Grafter
Posts: 158
Registered: 02-05-2010

Re: TP-Link Router wireless problem

Update.
Plugged in the old Plusnet fibre router, and everything seems to be working fine again.
Community Gaffer
Community Gaffer
Posts: 5,259
Thanks: 547
Fixes: 5
Registered: 04-04-2007

Re: TP-Link Router wireless problem

TP-Link, make sure you are clear of this: http://community.plus.net/forum/index.php/topic,124783.0.html
Kelly Dorset
Broadband Service Manager