cancel
Showing results for 
Search instead for 
Did you mean: 

TG585 v8 firmware upgrade failed

paulstockting2
Newbie
Posts: 1
Registered: 11-09-2013

TG585 v8 firmware upgrade failed

Over the last 6 - 9 months we have been experiencing appalling download and upload speeds. We live in a rural area so not surpising that we're not getting 20MB but 0.5mb is a bit much !!
Continuous complaints to Plusnet have resulted in being told only the standard  tests to eliminate other problems - change the ADSL filter, make sure everything's plugged into your master socket (we only have one!) and change your router.
Some research on the web suggested that it would be worth trying to upgrade the firmware.
I'm not a techhie by any stretch but managed to download the appropriate flash utility and upgrade package.
Having tried 3 times, following instructions to the letter it told me each time the process had failed. I'm running Windows 7 Home Premium 64 bit system.
Can anyone offer any advice please?
Cheers
Paul
22 REPLIES
Community Veteran
Posts: 6,313
Thanks: 86
Fixes: 3
Registered: 08-01-2008

Re: TG585 v8 firmware upgrade failed

I'd hope it's not the case but it's possible that the software doesn't like a 64bit OS.
Did you try a full reset of the router before trying the firmware upgrade?
It was a long time ago now but I definitely managed to flash a 585v8 using W7 (32 bit though), first attempt failed because I didn't follow the instructions properly and tried the flash via wi-fi  Embarrassed second attempt via ethernet worked OK but if the router is corrupted then it's (remotely) possible that a flash may not work.
It should be possible to get Plusnet to (try to) flash the router remotely, alternatively you could probably ask for a new one (subject to 12 months deferred fee).
Call me 'w23'
At any given moment in the universe many things happen. Coincidence is a matter of how close these events are in space, time and relationship.
Opinions expressed in forum posts are those of the poster, others may have different views.
RPMozley
Aspiring Pro
Posts: 1,116
Thanks: 30
Fixes: 5
Registered: 04-11-2011

Re: TG585 v8 firmware upgrade failed

W7 64bit the flash tool works fine, so not that problem. Where exactly does it fail at? A particular point or never even gets going?
That's RPM to you!!
Plusnet Alumni (retired) chrispurvey
Plusnet Alumni (retired)
Posts: 5,369
Fixes: 1
Registered: 13-07-2012

Re: TG585 v8 firmware upgrade failed

Hi Paul,
We can remotely upgrade this firmware, let me know if you'd like us to do this.
lotrjw
Grafter
Posts: 64
Registered: 11-09-2013

Re: TG585 v8 firmware upgrade failed

Can you update the Technicolor TG582n FTTC firmware from the 8.C.M.0 to whatever the latest one is?
jim:quote
Plusnet Alumni (retired) chrispurvey
Plusnet Alumni (retired)
Posts: 5,369
Fixes: 1
Registered: 13-07-2012

Re: TG585 v8 firmware upgrade failed

The FTTC version would need to be upgraded by yourself, you can do this here.
lotrjw
Grafter
Posts: 64
Registered: 11-09-2013

Re: TG585 v8 firmware upgrade failed

I tryed the 'Plusnet - FTTC - TG582n (with USB port) - 10.2.5.2' firmware but this wouldnt take, it failed is there any reason why it would?
Is there any other firmware virsion I can try, as I would like the most up to date?
Plusnet Alumni (retired) chrispurvey
Plusnet Alumni (retired)
Posts: 5,369
Fixes: 1
Registered: 13-07-2012

Re: TG585 v8 firmware upgrade failed

What error message did you get? There's no others to try apart from the one you're on and the one you attempted to upgrade to.
markm9
Grafter
Posts: 104
Registered: 14-01-2013

Re: TG585 v8 firmware upgrade failed

lotrjw
if you are using w8, this will not allow you to update, i had to borrow sons laptop w7, to update my router, once this was done it updated immediately.
lotrjw
Grafter
Posts: 64
Registered: 11-09-2013

Re: TG585 v8 firmware upgrade failed

@markm9 I use windows 7 on all my PCs so it shouldnt be an issue
@chrispurvey I tried it a few days ago now so cant remember the exact error, but it started the process got past backing up ect and onto loading it to the router.
I think it then got to about 40 something % and then stalled and said there was an error.
Plusnet Alumni (retired) chrispurvey
Plusnet Alumni (retired)
Posts: 5,369
Fixes: 1
Registered: 13-07-2012

Re: TG585 v8 firmware upgrade failed

I'll get one of our product guys to take a look to see they can spot anything.
lotrjw
Grafter
Posts: 64
Registered: 11-09-2013

Re: TG585 v8 firmware upgrade failed

thanks
lotrjw
Grafter
Posts: 64
Registered: 11-09-2013

Re: TG585 v8 firmware upgrade failed

Quote from: chrispurvey
I'll get one of our product guys to take a look ...

Chris I worked out what was wrong I was connecting through my server so not direct to the router, when I switched to connect straight to the router it loaded the new firmware. Although the firmware updater still said there was another error afterwords, even though it all worked ok.
Plusnet Alumni (retired) chrispurvey
Plusnet Alumni (retired)
Posts: 5,369
Fixes: 1
Registered: 13-07-2012

Re: TG585 v8 firmware upgrade failed

Glad to hear that's sorted, let us know how you get on with it.
lotrjw
Grafter
Posts: 64
Registered: 11-09-2013

Re: TG585 v8 firmware upgrade failed

Chris I do have some issues which I put in other threads here: http://community.plus.net/forum/index.php/topic,118334.0.html and here: http://community.plus.net/forum/index.php/topic,118329.0.html
They appear to be unrelated to each other, but they could both be related to the firmware updater reporting an issue, after it had put the new firmware on successfully, it said something about not being able to upload the settings back on properly!