cancel
Showing results for 
Search instead for 
Did you mean: 

TG585 DHCP DNS settings

jhoughton1234
Newbie
Posts: 8
Registered: ‎24-08-2010

TG585 DHCP DNS settings

I have a TG585v7.  I also have a server on my internal network that runs a DNS server that serves up names for my local statically-defined IP addresses.  I need to access this DNS server from clients that don't (and can't) have static settings, so I have to have the DHCP server send that DNS server as the only DNS server address (if there are other DNS servers sent, they will reply NXDOMAIN for my internal addresses).
I have configured the router thus:
Quote
{admin}=>dhcp server pool config
name = LAN_private
[state] = enabled
[allocation] = dynamic
[intf] = LocalNetwork
[index] =
[poolstart] = 192.168.1.160
[poolend] = 192.168.1.199
[netmask] = 24
[gateway] = 192.168.1.254
[server] = 192.168.1.254
[primdns] = 192.168.1.2
[secdns] = 192.168.1.2
[dnsmetric] = 0
[primwins] = 192.168.1.2
[secwins] =
[leasetime] = 86400
[renewtime] =
[rebindtime] =
[unnumbered] = disabled
[localgw] = disabled
[localdns] = enabled

However the config that clients get does not have the right DNS server info:
Quote
DHCP info:
ipaddr 192.168.1.164
gateway 192.168.1.254
netmask 255.255.255.0
dns1 192.168.1.254
dns2 192.168.1.2
DHCP server 192.168.1.254
lease 86400 seconds

Any ideas how to stop this damned thing sending itself as the first DNS server?
2 REPLIES
houlton23
Grafter
Posts: 268
Registered: ‎22-05-2011

Re: TG585 DHCP DNS settings

If you run
dns server route list
(on telnet)
from here, what does it list for the DNS servers?
Alex Smiley
EDIT: Just noticed the '[localdns] = enabled'  line. Have you tried disabling this?
Further Reading found this:
Quote from: Paul03
TO get it to stop handing out it's own ip as primary DNS you need to use the CLI command:
dns server config state disable
If you want it to hand out local IP addresses in a range other than 192.168.1.x you need to go to the page in the screenshot below and add the appropriate range.
jhoughton1234
Newbie
Posts: 8
Registered: ‎24-08-2010

Re: TG585 DHCP DNS settings

Thanks, that seems to have done the trick.  (Needed to be 'false' rather than 'disabled' on the end -- guest they've updated it a bit since that was written).