cancel
Showing results for 
Search instead for 
Did you mean: 

TG582n router requires constant logging in

bbgmp
Dabbler
Posts: 23
Registered: 04-02-2012

TG582n router requires constant logging in

Whenever I try to access my router through the web interface, I'm constantly being sent back to the login screen.

I usually have to enter my details a few times before even being able to go to the dashboard. Then every time I click something, I have to log in again.
Is this a sign there's something wrong with my router?
17 REPLIES
Community Veteran
Posts: 3,380
Thanks: 2
Registered: 18-01-2013

Re: TG582n router requires constant logging in

A couple of things to try.
First log in via its IP address - 192.168.1.254
Secondly try a different browser and see if that makes a difference (Firefox / Chrome are good alternatives)
Superuser
Superuser
Posts: 11,066
Thanks: 2,422
Fixes: 21
Registered: 22-08-2007

Re: TG582n router requires constant logging in

Are you seeing this on every page refresh or just when you "return" to the session and want to refresh the page?
If this is the former, then I guess you have disabled all cookies, in which case there is no persistent session state between the bowser and the router's web service.  Therefore you will have to authenticate EVERY access request.
If this is the latter, then I suggest that the session has timed out and you need to re-authenticate.
Session timeout is a standard security measure on browser fronted applications - it prevents someone walking up to your computer and accessing an open session to the router.  I have taken a brief look at the telnet interface and cannot discern any option to alter the GUI session timeout duration.
Community Veteran
Posts: 19,100
Thanks: 437
Fixes: 21
Registered: 31-08-2007

Re: TG582n router requires constant logging in

There is a 10 minute timeout on the GUI if there is no activity, is this what may be happening?
bbgmp
Dabbler
Posts: 23
Registered: 04-02-2012

Re: TG582n router requires constant logging in

Thanks for all the responses so far.
I should have added that I generally have to enter my credentials 3-6 times every time before the dashboard loads. Before then it just simply keeps reloading the login page. Auto-enter credentials using KeePass so it's not a matter of mistyping them.
Quote from: DomS
First log in via its IP address - 192.168.1.254

Tried this, still an issue.
Quote from: DomS
Secondly try a different browser and see if that makes a difference (Firefox / Chrome are good alternatives)

Use Chrome as my main browser. Tried with Firefox and same problem.
Quote from: Townman
Are you seeing this on every page refresh or just when you "return" to the session and want to refresh the page?

Every page refresh. As in:
1. Login page - enter credentials
2. Dashboard loads - click any link
3. Login page again - enter credentials
4. Link loads - click any other link
5. Login page - bash head on desk  Angry
Quote from: Townman
If this is the former, then I guess you have disabled all cookies, in which case there is no persistent session state between the bowser and the router's web service.

Nope. All cookies accepted.

Deleted cookies to see if that was the problem but still an issue.
Quote from: Anotherone
There is a 10 minute timeout on the GUI if there is no activity, is this what may be happening?

Happens right after logging in so don't think it's this.
Are there any settings on the router that might cause this?
Superuser
Superuser
Posts: 11,066
Thanks: 2,422
Fixes: 21
Registered: 22-08-2007

Re: TG582n router requires constant logging in

Hi,
What you describe is symptomatic of there being no session cookies.  Can you try with IE browser - or an iPad / Smart Phone?
I cannot think of any settings on the router which can impact this.  I have though seen incidents of the router not presenting web pages due to being busy doing other things.  Are you having line problems?
How long is it since the router was rebooted?
Which version of firmware is it using?
Community Veteran
Posts: 3,380
Thanks: 2
Registered: 18-01-2013

Re: TG582n router requires constant logging in

Are the time and date correct on both your PC and Router ?
Are you able to temporarily turn off your KeePass to rule that out of the equation ?
bbgmp
Dabbler
Posts: 23
Registered: 04-02-2012

Re: TG582n router requires constant logging in

Quote from: Townman
Can you try with IE browser
Are you having line problems?
How long is it since the router was rebooted?
Which version of firmware is it using?

Same situation with IE after clearing cache and all cookies. Sad
Have had disconnect issues in the past but nothing recently.
Rebooted it today to see if it fixed the login issue (it didn't).
Software version 10.2.2.B
Quote from: DomS
Are the time and date correct on both your PC and Router ?
Are you able to temporarily turn off your KeePass to rule that out of the equation ?

Yes. They both are the same (and correct).
IE doesn't have any KeePass extensions so also rules that out.

Can the session timeout for the router be adjusted? Wondering if something has reduced it to 0 somehow.
RPMozley
Aspiring Pro
Posts: 1,116
Thanks: 30
Fixes: 5
Registered: 04-11-2011

Re: TG582n router requires constant logging in

Maybe your antivirus software is interfering with the login process? Some AVs can be obtrusive but best to check just in case and rule it out.
That's RPM to you!!
Community Veteran
Posts: 19,100
Thanks: 437
Fixes: 21
Registered: 31-08-2007

Re: TG582n router requires constant logging in

Well suggested RPM, also maybe check there isn't anything daft in your Firewall settings that might cause this.
Quote from: bbgmp
Can the session timeout for the router be adjusted? Wondering if something has reduced it to 0 somehow

Not that I've managed to find, there's not even a relevant telnet command for the GUI timeout.
Do you have any customised settings? Have you tried the dreaded factory reset? (I'd do that off-line so as not to get DLM thinking your connection is playing up).
waffley
Newbie
Posts: 9
Registered: 16-02-2015

Re: TG582n router requires constant logging in

We are having the same problem, having tried all of the things suggested above. Everything has been fine for the last 10 months since we joined plusnet, but yesterday this started to happen for random webpages, incuding plusnet itself!
I have emailed plus net and am awaiting a response.
Community Veteran
Posts: 19,100
Thanks: 437
Fixes: 21
Registered: 31-08-2007

Re: TG582n router requires constant logging in

Hi waffley,
Welcome to the forum.
To be crystal clear, do you mean you go to the 582n homepage (192.168.1.254) try logging in, and then in asks you to login again?
Or is it a case of the 582n login page is popping up when you aren't expecting it?
waffley
Newbie
Posts: 9
Registered: 16-02-2015

Re: TG582n router requires constant logging in

Thank you for the welcome!
In my case, the 582n login page just pops up unexpectedly! At the moment it seems OK since the last router reboot, however when it happens it is on laptops, tablets (android and iPad), and phones too! Very frustrating!
dick:quote
nufab4
Newbie
Posts: 1
Registered: 16-02-2015

Re: TG582n router requires constant logging in

My system has been abysmal for the last week; however this login screen is a constant- it however does not seem to impact on the service.it pops up; it goes away; it pops up; goes away. I can't login through chrome at all; but can through firefox. It does seem strange

However is there maintenance going on as we are having big problems with keep internet working in  any form
Community Veteran
Posts: 19,100
Thanks: 437
Fixes: 21
Registered: 31-08-2007

Re: TG582n router requires constant logging in

Welcome to nufab4 as well.
When the 582n login screen pops up unexpectedly, this sounds like what's called "Web Browsing Interception" and usually happens when connection is lost, albeit maybe temporarily for a reason. So I'm guessing that maybe both of your are on ADSL connections and have a fault of some sort.
You can disable the "feature" to stop the irritation, but need to get the fault that's causing it addressed.
Goto http://192.168.1.254/cgi/b/cfg/cfg/?be=0&l0=1&l1=1 (you'll get the login screen first) and at the bottom of the System Configuration box, select "Disabled" in the dropdown box for Web Browsing Interception, and then click Apply, and then logout (top RHS).
I hope that direct link works on both your firmware versions, if not, get to the page as follows -
Login to the 582n, (on some Firmwares select 5.4 Advanced Options at the bottom of the page). Otherwise then select Technicolor Gateway from the LH menu, then Configuration (from either link) and then Configure on the top RHS.
If my assumption is right, it would be best if you both start your own threads on the ADSL board and post TG582n Full DSL stats (you'll get the login screen if you aren't already) as well as run the BTw Performance test (DON'T REBOOT, ignore the red preamble except make sure no other programs are using the Internet) and at the end of the first run, click the Further Diagnostics button, enter just your Phone number and Run the Further Diagnostics Test. Do a Copy and Paste of the results and put in the post (no need to grab an image)..
Also your Current Line speed (Login required) - don't post your phone number.