cancel
Showing results for 
Search instead for 
Did you mean: 

TG582n router is completely useless

jeanners49
Grafter
Posts: 31
Registered: ‎07-06-2013

TG582n router is completely useless

I've given up with the TG582n and gone back to using the old Thomson router.  OK, it doesn't always work with wifi but I have been able to log in here in a matter of seconds, rather than wait ages for pages to load or be timed out.    I tried several different channels as suggested and they were no better.  I don't think the router is faulty, it's just an all round failure.
It's pretty poor in my opinion and I'm not happy.  I expect better of Plusnet.
Angry
Jean
3 REPLIES
JayG
Pro
Posts: 1,022
Thanks: 94
Fixes: 3
Registered: ‎30-10-2011

Re: TG582n router is completely useless

As a long time lurker and occasional poster on here it's pretty clear that although far from brilliant in the Wifi department, the TG582n is perfectly adequate for most people's needs.
My Hudl tablet always connects reliably to it downstairs with the router upstairs - are you sure the signal is not being blocked by nearby objects and/or that you're not expecting it to go through too many walls?
Does it work better if you move your device closer to it (if possible?)
Longliner
Rising Star
Posts: 59
Thanks: 11
Fixes: 1
Registered: ‎22-10-2014

Re: TG582n router is completely useless

I'm no techie and still on ADSL so I don't know how the TG582N compares with the expensive routers. I can say that it performs at least as well as my previous BT Home Hub around this end of the house. The house is 45 yrs old and built in the old-style solid concrete block and brick, which stop my hammer drill as well as the router signal! The (pricey) solution is a couple of Devolo units, we have no problems running two iPads and two smart TVs around the house.
Plusnet Help Team
Plusnet Help Team
Posts: 1,953
Thanks: 22
Fixes: 5
Registered: ‎24-07-2014

Re: TG582n router is completely useless

There are numerous local issues that can cause these problem. I've given some advice on the other thread.
If this post resolved your issue please click the 'This fixed my problem' button
 Tony T
 Plusnet Help Team