cancel
Showing results for 
Search instead for 
Did you mean: 

TG582n dropping idle tcp connections

burble
Dabbler
Posts: 15
Registered: 20-03-2014

TG582n dropping idle tcp connections

Something is causing idle tcp connections to drop, and I wondered if anyone had any tips. I'm seeing this over telnet, in a talker/mud which doesn't support telnet keepalive - the actual internet connection is fine, but when I try to send data on the telnet connection after a few minutes of inactivity, I get disconnected.
I think it may have something to do with plusnet's TG582n configuration, because this is happening to a couple of us and that's the only thing we have in common which has changed - it was fine when my friend was on plusnet but with different router, or when I was on BE with their TG582n.
It doesn't seem to happen after a specific time period, so I'm wondering if the router's NAT table may be filling up and kicking off the oldest idle ones? However, I haven't had any luck with google, so wondered if anyone here had experienced the same thing and/or could point me in the direction of what I should be searching for.
4 REPLIES
Plusnet Help Team
Plusnet Help Team
Posts: 12,859
Thanks: 115
Fixes: 36
Registered: 27-04-2007

Re: TG582n dropping idle tcp connections

Hi Burble,
I've just run this past one of our product specialists. Rather than drop the connection the NAT and firewall tables are cleared when idle. Whilst there are settings for both of those it's likely to be something that you might not be able to change I'm afraid.
Sorry if that's an inconvenience.
If this post resolved your issue please click the 'This fixed my problem' button
 Adam Walker
 Plusnet Help Team
Community Veteran
Posts: 1,829
Thanks: 93
Fixes: 5
Registered: 21-01-2013

Re: TG582n dropping idle tcp connections

Looks like there's a tcp timeout of 15 minutes in the router. From what you say I assume your drop time is less than 15 minutes so I doubt this is the problem, but you could have a play with the following router telnet settings just to check.
Command to view the time outs:
connection timerconfig
Result
tcpidle          : 15' 0"
tcpneg          : 2' 0"
tcpkill          : 1 0"
udpidle          : 1"
udpkill          : 2' 4"
icmpidle        : 5"
icmpkill        : 1' 0"
ipidle          : 1' 0"
ipkill          : 0"
                         
Command to change tcpidle to 20 minutes:
connection timerconfig timer=tcpidle value=1200
Command to view change:
connection timerconfig
Result:
tcpidle          : 20' 0"
tcpneg          : 2' 0"
tcpkill          : 1 0"
udpidle          : 1"
udpkill          : 2' 4"
icmpidle        : 5"
icmpkill        : 1' 0"
ipidle          : 1' 0"
ipkill          : 0"
Note:
AFAIK there's not much difference between the O2 / Be router settings and  those used by Plusnets R8 firmware.
If your using Plusnets R10 firmware it may be worth trying the R8 FW.
Firmware download:
http://products.plus-payh.co.uk/firmware/


burble
Dabbler
Posts: 15
Registered: 20-03-2014

Re: TG582n dropping idle tcp connections

Thank you both for your help! I had looked at tcp idle, but had discounted it as sometimes the idle connection seems to last for much longer than 15 minutes. It appears to be linked to how many other connections I make; perhaps idle connections are only cleared when the NAT table count reaches a certain threshold?
I'm using R8 already - perhaps I was mis-remembering my experiences with BE's 582n, I didn't have it for very long, mostly used their older thompson.
I may try R10, or increase the idle limit to something silly and see what happens when the NAT table fills up.
Thanks again!
Community Veteran
Posts: 1,829
Thanks: 93
Fixes: 5
Registered: 21-01-2013

Re: TG582n dropping idle tcp connections

These two links may be of interest, if you haven't already seen them.
http://www.dslreports.com/faq/7792
http://blogs.technet.com/b/nettracer/archive/2010/06/03/things-that-you-may-want-to-know-about-tcp-k...
Also this firewall setting may be worth a try -- long shot
firewall config keep=enabled
"Disable/Enable keeping existing connections when firewall rules change."
Default is disabled