cancel
Showing results for 
Search instead for 
Did you mean: 

Surfing speed bad, then good, then bad, etc

moley
Grafter
Posts: 48
Registered: ‎06-11-2008

Surfing speed bad, then good, then bad, etc

Since moving house and ADSL connection (still on same exchange as before and located a lot nearer to it), website surfing speed has been intermittently awful.
A speedtest.net test returns about 13-14 Mb which is fine.  The delays come in connecting to websites in the first place.
Sometimes in browser status bar I've seen 'Looking up...' during the delays, so I wondered if the problem might be DNS related.  I've tried 'auto' for DNS servers, and the Google ones (8.8.8.8 and 8.8.4.4).  am also now trying OPenDNS DN servers on the offchance it may help.
Does anyone else experience this intermittent slow surfing?
router stats:
[tt]ADSL Link    Downstream Upstream
Connection Speed 18499 kbps 443 kbps
Line Attenuation 14.5 db 5.1 db
Noise Margin 6.3 db 19.4 db[/tt]

When all is well, a traceroute looks like this:
[tt]$ traceroute plus.net
traceroute: Warning: plus.net has multiple addresses; using 212.159.9.2
traceroute to plus.net (212.159.9.2), 64 hops max, 52 byte packets
1  192.168.0.1 (192.168.0.1)  3.121 ms  1.791 ms  5.010 ms
2  lo0-central10.pcl-ag01.plus.net (195.166.128.182)  17.615 ms  14.156 ms  16.818 ms
3  link-a-central10.pcl-gw01.plus.net (212.159.2.160)  14.513 ms  13.463 ms  18.941 ms
4  xe-10-0-0.pcl-cr01.plus.net (212.159.0.192)  16.707 ms  19.596 ms  17.888 ms
5  po2.pcl-gw01.plus.net (195.166.129.41)  16.557 ms  14.694 ms  15.421 ms
6  gi5-8.ptp-cr01.plus.net (84.93.224.4Cool  22.001 ms  22.109 ms  23.704 ms
7  vlan2658.ptp-elb02.plus.net (84.93.224.45)  25.066 ms  23.835 ms  24.542 ms
8  vlan2658.ptp-elb02.plus.net (84.93.224.45)  26.297 ms  23.739 ms  26.043 ms[/tt]
But if I run the same traceroute in a loop at intervals of a few seconds, every now and again the traces time out on the 1st line, eg:
[tt]$ traceroute plus.net
traceroute: Warning: plus.net has multiple addresses; using 212.159.9.2
traceroute to plus.net (212.159.9.2), 64 hops max, 52 byte packets
1  192.168.0.1 (192.168.0.1)  3.216 ms  3.758 ms *
2  * * *
3  link-a-central10.pcl-gw01.plus.net (212.159.2.160)  17.892 ms  15.377 ms  15.685 ms
4  xe-10-0-0.pcl-cr01.plus.net (212.159.0.192)  14.318 ms  14.212 ms  15.139 ms
5  po2.pcl-gw01.plus.net (195.166.129.41)  14.846 ms  14.706 ms  15.192 ms
6  gi5-8.ptp-cr01.plus.net (84.93.224.4Cool  37.170 ms  21.646 ms  22.965 ms
7  vlan2658.ptp-elb02.plus.net (84.93.224.45)  25.016 ms  24.720 ms  21.888 ms
8  vlan2658.ptp-elb02.plus.net (84.93.224.45)  22.914 ms  26.217 ms  24.718 ms[/tt]
Once the 'blockage' clears, ie traceroute leaps back in to life, all is fine again for a few minutes.
Any help figuring out the blocakage would be great.
1 REPLY
Community Veteran
Posts: 1,624
Thanks: 24
Registered: ‎29-06-2010

Re: Surfing speed bad, then good, then bad, etc

Getting your upstream uncapped would probably be beneficial.