cancel
Showing results for 
Search instead for 
Did you mean: 

Sudden poor download speed.

vultura
Grafter
Posts: 251
Thanks: 4
Registered: 22-05-2011

Sudden poor download speed.

Hello all
Been with PN for a year now and quite happy with service.
Noticed today that general surfing seemed a little sluggish, just put it down to congestion or the site servers being slow.  Its now gone 1.50am and its still the same.  Trying to stream video just results in almost constant buffering.  A test via speedtest.net gives download speed at a little under 1mb with upload around normal at .3mb.  Normally I would expect to see download speed around 4mb.
Just trying now to download the Java installer (to run bt test) from sun.com and getting around 22kb per second, which is crazy.
PN profile states -
Estimated line speed:
4.0Mb (This may vary between 2.5Mb and 7Mb) - Checked on 2012-05-22 23:49:37
Current line speed:
4.8 Mb
Router currently synced at 7411 kbps, with stats showing
ADSL Link                Downstream Upstream
Connection Speed 7411 kbps 443 kbps
Line Attenuation    44.5 db      25.5 db
Noise Margin          0.2 db          26.5 db
Have done a resynch, same stats and uptime previously was 33hours.
Edit: BT Speedtest results - 1.34Mb download, 0.37Mb upload, 39.00ms ping.

5 REPLIES
Plusnet Staff
Plusnet Staff
Posts: 6,346
Thanks: 31
Fixes: 5
Registered: 26-11-2011

Re: Sudden poor download speed.

Hi vultura,
I have taken a look at your line and it would seem that your SNR is very low. I have changed your profile on our internal systems to match BT's which should have brought those speeds back up. If you notice that your speeds have not changed, please let us know and we can look at this again for you.
Smiley
Chris Pettitt
Cloud Environments Engineer
vultura
Grafter
Posts: 251
Thanks: 4
Registered: 22-05-2011

Re: Sudden poor download speed.

Thanks Chris
Just done a further test via speedtest.net and got just over 3Mb download.  Better than it was, but not as high as I have seen in the past. 
I did change router a month or so ago, from a 2wire 2700HGV (BT Business hub) to a Netgear DG834GT with DGTeam firmware.  This was to try and improve the ping for gaming.  Speed has been fine since though.
Community Veteran
Posts: 19,100
Thanks: 437
Fixes: 21
Registered: 31-08-2007

Re: Sudden poor download speed.

I can only guess that maybe the error rate is extremely high with that very low Noise Margin, which is consistent with the sync speed taking the line attenuation into account.
A very high error rate means lots more data has to be retransmitted, the net effect being a slowdown of throughput speed.
I would expect a more normal sync speed for that attenuation to be around 6816/7008ish kbps giving you a 6Mbps IP profile on 20CN which I assume you are on from the information provided.
If you want a lower ping, then interleaving has to be off but that would not be possible with anything but a low error rate so you need a more typical noise margin.
You aren't forcing your Target Noise Margin down with that Netgear are you?
vultura
Grafter
Posts: 251
Thanks: 4
Registered: 22-05-2011

Re: Sudden poor download speed.

Speed has improved a little more, tests now giving 4.7Mb as the download.  If I download Java installer now I see 600kb per second transfer.
Quote from: Anotherone
If you want a lower ping, then interleaving has to be off but that would not be possible with anything but a low error rate so you need a more typical noise margin.
You aren't forcing your Target Noise Margin down with that Netgear are you?

I should be on fastpath, as I requested interleaving be set to off 6 months ago.  Certainly was when I last checked using the control panel of the 2700, but I can't find the same info in the Netgear.
No tweaks have been made to change the SNR.  The only thing I have done is to set my xbox as the DMZ, to bypass the firewall so I am not restricted by a moderate NAT.
I saw very few errors reported by the 2700 once interleaving was set to off, with it on I was getting many many of them - see http://community.plus.net/forum/index.php/topic,100408
Edit - Seems you need to either access the Netgear using telnet or something like DMT to see if interleaving is on/off.  Using DMT 8.07 it looks like it off still.
Gave me the following error counters too.
Counters        Down            Up
SF:             3684260         3511605
SFErr(CRCErr):  473             0
RS:             0               0
RSCorr:         0               0
RSUnCorr:       0               0
HEC:            305             0
OCD:            17              0
LCD:            0               0
Total Cells:    781693256               836928
Data Cells:     566545          10843
Drop Cells:     0
Bit Errors:     0               0
ES:             114845          0
SES:            107503          0
UAS:            172             0
AS(Uptime):     59699
INP:            0.00            0.00
PER:            16.20           17.84
delay:          0.24            0.24
OR:             32.09           8.07
Bitswap:        3268            841
Total uptime:   514878

Total time = 1 days 23hours 6min 0sec
SF  = 31729860   CRC = 4564162
LOS = 3   LOF = 27   ES = 114845
Latest 1 day time = 23hours 6min 0sec
SF  = 5127162   CRC = 975
LOS = 1   LOF = 9   ES = 331
Previous 1 day time = 24hours 0sec
SF  = 5327083   CRC = 1586372
LOS = 1   LOF = 9   ES = 41491
Plusnet Alumni (retired) orbrey
Plusnet Alumni (retired)
Posts: 10,540
Registered: 18-07-2007

Re: Sudden poor download speed.

Hi vultura,
Just checked and you're showing as being on fastpath from BTs side of things too Smiley